Live Interior 3D Pro Edition
End User License Agreement

THIS LICENSING AGREEMENT ("AGREEMENT") IS A LEGAL AGREEMENT BETWEEN YOU, EITHER AN INDIVIDUAL OR A SINGLE ENTITY, AND BELIGHT SOFTWARE ("LICENSOR"). IF YOU DO NOT AGREE TO EACH AND EVERY TERM, DO NOT INSTALL LIVE INTERIOR 3D PRO EDITION. YOU MUST EITHER RETURN THE SOFTWARE, DOCUMENTATION AND PACKAGING TO THE PLACE OF PURCHASE OR, IN THE CASE OF DOWNLOADED SOFTWARE, DELETE THE SOFTWARE FROM YOUR COMPUTER AND/OR ANY OTHER DATA STORAGE DEVICE.

1. GENERAL
The software, documentation and any 3D object or ready-made design accompanying this License whether on disk or on any other media (collectively the "Software") are licensed to you by BeLight Software ("Licensor") for use only under the terms of this License, and Licensor reserves all rights not expressly granted to you. The rights granted herein do not include any other patents or intellectual property rights.

The title and intellectual property rights in and to any content displayed by or accessed through the Software belong to the respective content owner. This License does not grant you any rights to use such content.

2. LICENSE
Licensor hereby grants to You, and You accept, a non-exclusive license to install and use Software and Documentation, only as authorized in this license. The license permits either multiple users to install and use the software on a single computer, or a single user to install and use the software on multiple computers. The license does not allow multiple users to use the Software on multiple computers. You agree that You will not assign, sub license, transfer, pledge, lease, rent, or share Your rights under this license. You may not reverse engineer, decompile or disassemble the Licensed Software for any purpose whatsoever.

3D Objects: The Software contains numerous 3D objects that are either owned by Licensor or licensed from a third party. You are free to use and modify 3D objects as you wish subject to the restrictions set out in this section. You can publish images (screenshots) of interiors created using those 3D objects as you wish subject to the restrictions set out in this section. If you are uncertain about your rights to use any material, you should contact your legal advisor.

You may NOT resell, sublicense or otherwise make available the 3D object(s) for use or distribution separately or detached from a product or Web page. You may NOT a) create scandalous, obscene, defamatory or immoral works using the 3D object(s) nor use the 3D object(s) for any other purpose which is prohibited by law; b) use or permit the use of the 3D object(s) or any part thereof as a trademark or service mark, or claim any proprietary rights of any sort in the 3D object(s) or any part thereof; c) use the 3D object(s) in electronic format, on-line or in multimedia applications unless the 3D object(s) are incorporated for viewing purposes only and no permission is given to download and/or save the 3D object(s) for any reason; d) use any 3D object(s) except as expressly permitted by this License; and e) use the 3D object(s) related to identifiable individuals, products or entities for any commercial purpose or in a manner which suggests their association with or endorsement of any product or service.
3. TRANSFER
You may not distribute copies of the Software including 3D objects, ready-made designs, in whole or in part, to any third party, nor may you use, rent, loan, sublicense, or lease the Software to third parties. You may, however, transfer all your rights to use the Software to another person or legal entity provided that: (a) You also transfer this Agreement, the Software and all other software bundled or pre-installed with the Software, including all copies, Updates and prior versions, to such person or entity; (b) You retain no copies, including backups and copies stored on a computer; and (c) the receiving party accepts the terms and conditions of this Agreement and any other terms and conditions upon which You legally purchased a license to the Software. Notwithstanding the foregoing, You may not transfer pre-release or not for resale copies of the Software.

4. ILLEGAL USE
You are not to use the Software, whether directly or indirectly, for any illegal purpose under the laws or ordinances of Federal, State, or local governments. It is Your sole responsibility to know and understand the laws and/or ordinances that govern the use of the Software. In the event that You violate any Federal, State or local law or ordinance by direct or indirect use of the Software, You shall take full legal responsibility for such illegal use. You shall hold Licensor harmless and without fault and otherwise indemnify Licensor for any damage, cost or liability incurred by Licensor as a result of any use, whether or not such use is within the scope of the license set forth herein.

5. UPDATES
If the Software is an Update to a previous version of the Software, You must possess a valid license to such previous version in order to use the Update. You may continue to use the previous version of the Software on your computer after You receive the Update to assist You in the transition to the Update, provided that: the Update and the previous version are installed on the same computer; the previous version or copies thereof are not transferred to another party or computer unless all copies of the Update are also transferred to such party or computer; and You acknowledge that any obligation BeLight Software may have to support the previous version of the Software may be ended upon availability of the Update.

6. LICENSOR’S RIGHTS
You acknowledge and agree that the Software and Documentation consists of proprietary, published and unpublished property of Licensor. You further acknowledge and agree that all right, title, and interest in and to the Software and Documentation are and shall remain with Licensor. This license conveys to You the right to install and use the Software and Documentation in accordance with the terms of this license. All rights not expressly granted here are reserved by BeLight Software. The Licensor will not transmit your personal information to any third party without your express consent.

7. TERMINATION
This license is effective upon installing the software on any machine, and shall continue until terminated. You may terminate this Agreement at any time. The Licensor may immediately terminate this License Agreement if you breach any representation, warranty, agreement or obligation contained or referred to in this License Agreement. Upon termination, you must dispose of the Software and all copies or versions of the Software by destroying the Software.
8. LIMITED WARRANTY
BeLight Software provides a thirty (30) day money-back guarantee on the Software. If, during this period, you are dissatisfied with the Software for any reason, BeLight Software will refund your money if you return the Software and all copies to the place of purchase within thirty (30) days of the date of the original purchase.
THE FOREGOING IS THE SOLE AND EXCLUSIVE WARRANTY OFFERED BY BELIGHT SOFTWARE. BELIGHT SOFTWARE DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH REGARD TO THE LICENSED SOFTWARE AND ALL ACCOMPANYING MATERIALS. BELIGHT SOFTWARE AND ITS AGENTS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY OBTAIN BY USING THE SOFTWARE.

9. LIMITATION OF LIABILITY
IN NO EVENT WILL BELIGHT SOFTWARE OR ITS AGENTS BE LIABLE TO YOU FOR ANY DAMAGES, CLAIMS OR COSTS WHATSOEVER OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGES, OR ANY LOST PROFITS OR LOST SAVINGS. BELIGHT SOFTWARE’S AGGREGATE LIABILITY AND THAT OF ITS AGENTS UNDER OR IN CONNECTION WITH THIS AGREEMENT SHALL BE LIMITED TO THE AMOUNT PAID FOR THE SOFTWARE, IF ANY.

10. FEES
The Software is available in download and CD versions. If your download version of the Software does not come with a License Code, you may register your copy of the Software (except for Demo version) by purchasing a License Code for downloaded Trial version at: http://www.belightsoft.com/buy/ The License Code will remove the restriction on the save functionality. By purchasing the CD version of the software, your License Code is delivered to you together with the CD. You may not distribute the License Code. By clicking “Agree”, you acknowledge that you have paid the Licensor all applicable license fees for the Software.

11. SEVERABILITY
Should any term of this license be declared void or unenforceable by any court of competent jurisdiction, such declaration shall have no effect on the remaining terms hereof.

12. GENERAL PROVISIONS
This License Agreement is personal between You and BeLight Software. It is not transferable and any attempt by You to rent, lease, sublicense, assign or transfer any of the rights, duties or obligations hereunder. YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU FURTHER AGREE THAT IT IS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE AGREEMENT BETWEEN YOU AND BELIGHT SOFTWARE WHICH SUPERSEDES ANY PROPOSAL OR PRIOR AGREEMENT, ORAL OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN YOU AND BELIGHT SOFTWARE OR BELIGHT SOFTWARE’S AGENT(S) RELATING TO THE LICENSED SOFTWARE.
By using Trimble 3D Warehouse™ in the software you agree with the following Terms of Service. Review up-to-date Trimble 3D Warehouse™ Terms of Service at: http://sketchup.google.com/3dwarehouse/preview_tos.html

If you have any questions regarding this Agreement or if you wish to request any information from BeLight Software please use the address and contact information included with this product to contact BeLight Software.

© 2007-2014 BeLight Software, Ltd. All Rights Reserved. BeLight Software and Live Interior 3D Pro Edition are trademarks of BeLight Software, Ltd. Mac, the Mac logo, Mac OS X, Retina and Macintosh are trademarks of Apple Computer, Inc. The inclusion of “SPARKLE”: Copyright (c) 2006 Andy Matuschak. All other trademarks, registered trademarks, product and/or brand names are the sole property of their respective owners.
Contents

Chapter 1:
Introduction .................................................................................. 13
  Brief Description ........................................................................... 13
  System Requirements ..................................................................... 14
  Installing Live Interior 3D ............................................................. 14
  Registration .................................................................................... 14
  Updating the Program .................................................................... 15
  Removing the Program ................................................................... 15
  Web Resources ............................................................................... 16
  Conventions Used in this Document .............................................. 17

Chapter 2:
Live Interior 3D Workspace ............................................................ 19
  The Main Window .......................................................................... 19
  The Assistant ................................................................................ 20
  The 2D View ................................................................................ 21
    The Toolbar .................................................................................. 23
  The 3D View .................................................................................. 26
    Camera Orientation and Walk Control ......................................... 28
    Walking Around the Interior ....................................................... 30
    Moving Objects in the 3D View ................................................... 31
  The Inspector Window .................................................................... 32
  The Program Preferences ............................................................... 34
    The New Project Tab .................................................................... 34
    The 3D Settings Tab ..................................................................... 35
    The Trimble 3D Warehouse™ Tab .............................................. 41
    The Miscellaneous Tab ............................................................... 41
  Live Interior 3D Menus ................................................................... 43
  Live Interior 3D Keyboard Shortcuts .............................................. 49

Chapter 3:
Getting Started .............................................................................. 53
  Setting Up the Program after Installation ..................................... 53
  Project Design Workflow ............................................................... 55
  Quick Start Guide .......................................................................... 56
    Opening or Creating a Project ....................................................... 56
    Drawing Walls .............................................................................. 57
    Drawing a Room ............................................................................ 58
    Adding Floors and Ceilings ......................................................... 62
    Adding Doors and Windows ......................................................... 63
    Adding Furniture .......................................................................... 64
    Working with Materials ............................................................... 65
Working with Cameras ................................................................. 67
Setting Up the Lighting ................................................................. 69
Printing a Floor Plan ................................................................. 70
Taking Pictures of the 3D View .................................................. 70
Creating a Movie Track in 2D .................................................. 71

Video Tutorials .............................................................................. 74

Chapter 4:

Working with Projects ................................................................. 75
What is a Project? ............................................................................ 75
Creating and Opening Projects .................................................. 76
Project Setup ................................................................................ 77
Saving Projects ............................................................................. 78
The Project Tree ........................................................................... 79
The Environment Panel ................................................................. 81
Exporting the Floor Plan ............................................................... 82
Exporting 3D Views to Graphic Files ......................................... 83
Exporting 3D Views to QuickTime VR (QTVR) ......................... 83
Exporting to the 3D File Format .................................................. 84
Printing ......................................................................................... 88
The Render Boost Plug-in ............................................................. 91
Creating Movies ........................................................................... 93
Creating and Modifying Movie Tracks in 2D ......................... 99
Creating and Modifying Movie Tracks in 3D ......................... 105

Chapter 5:

Working with Storeys ................................................................. 109
Introduction ................................................................................ 109
Managing Storeys in the Inspector ........................................... 110
Inspector Controls ........................................................................ 110
Adding Storeys ........................................................................... 111
Removing Storeys ....................................................................... 111
Choosing the Active Storey ....................................................... 111
Choosing the Ground Floor ....................................................... 111
Changing the Slab Height ........................................................... 112
Changing the Storey Height ........................................................ 112
Storeys and the 2D View ........................................................... 113

Chapter 6:

Working with Roofs ................................................................. 115
Roofs in Live Interior 3D ................................................................. 115
The Roof Types ........................................................................... 116
Using Panels, Openings and Niches with Roofs ....................... 116
Adding and Deleting Roofs................................................................. 117
   The Roofing Assistant ..................................................................... 117
   Adding a Roof ................................................................................ 118
   Deleting a Roof .............................................................................. 119
Roof Properties .................................................................................. 120
Modifying the Style of a Roof .......................................................... 122
Adding a Skylight to the Roof ......................................................... 126
Adding a Dormer Window ................................................................. 127
Interior Walls in the Loft ................................................................. 128

Chapter 7:
Working with Objects ................................. 129

Basics ......................................................................................... 129
   Adding and Removing Objects .................................................. 129
   Selecting Objects ........................................................................ 130
   Using the Project Tree to Select Objects .................................. 130
   Moving Objects ........................................................................... 131
   Modifying Objects ...................................................................... 131
   Materials ..................................................................................... 131
Walls ......................................................................................... 132
   Wall Segments ........................................................................... 132
   Adding and Removing Walls .................................................... 133
   Selecting Walls ........................................................................... 134
   Moving Walls ............................................................................. 134
   Wall Parameters .......................................................................... 134
   Modifying Walls .......................................................................... 135
Ceilings and Floors ................................................................. 137
   Adding and Removing Ceilings and Floors ................................ 137
   Selecting Ceilings and Floors .................................................... 138
   Moving Ceilings and Floors ....................................................... 138
   Resizing Ceilings and Floors ..................................................... 138
   Setting up the Level of the Floor or Ceiling ............................. 139
   Materials ..................................................................................... 139
   Ceiling and Floor Representation on the Plan ......................... 140
   Text Label of the Floor ................................................................ 140
Windows, Doors and Openings ............................................. 141
   Adding and Removing Openings .............................................. 141
   Selecting Openings .................................................................... 141
   Moving Openings ....................................................................... 141
   Parameters of Openings ............................................................ 142
Niches and Wall Panels ...................................................... 144
   Adding and Removing Niches and Wall Panels ...................... 144
   Selecting Niches and Wall Panels ............................................ 144
   Moving Niches and Wall Panels ................................................. 144
   Parameters of Niches and Wall Panels ..................................... 145
   Changing the Size and Shape ..................................................... 145
   Materials ..................................................................................... 146
   Object Representation in the 2D Layout .................................... 146
# Columns
- Adding and Removing Columns ........................................ 147
- Parameters of Columns .................................................. 147

# Furniture ........................................................................ 148
- Adding and Removing Furniture ......................................... 148
- Selecting a Piece of Furniture ........................................... 148
- Moving Furniture ............................................................. 148
- Furniture Parameters ....................................................... 148
- Modifying Furniture ......................................................... 149
- Object Representation in the 2D Layout .............................. 151

# Staircases ........................................................................ 152
- Adding and Removing Staircases ......................................... 152
- Selecting a Staircase .......................................................... 153
- Moving a Staircase ............................................................ 153
- Parameters of Staircases .................................................... 153
- Editing the Opening Shape ............................................... 155

# Properties of Objects in 2D ................................................ 156

# Type and Representation................................................... 158
- Controlling the Object Preview ........................................... 158
- Object Properties ............................................................. 159

# Importing Objects ................................................................ 161
- Import Options ................................................................... 161
- Importing Trimble SketchUp™ Objects ............................... 163
- Editing Objects in Trimble SketchUp .................................. 165
- The Wall Panels, Openings and Niches Editor .................... 166
- Aligning and Distributing Objects ....................................... 169
- Grouping and Ungrouping Objects ...................................... 171
- Merging Objects ............................................................... 171

## Chapter 8:
The Library of Objects ....................................................... 173
- The Library Panel ............................................................ 173
- Object Information in the Library ....................................... 176
- Managing Objects in the Library ......................................... 177

## Chapter 9:
Working with Materials ..................................................... 181
- Applying Materials ........................................................... 181
  - Applying a Material to an Object .................................... 183
  - Working with the List of Object’s Materials ....................... 183
  - Adjusting the Texture Size and Orientation ...................... 184
- Adding Materials to the Library ........................................ 186
- Editing Materials ............................................................ 188
- Material Picker ............................................................... 192
### Chapter 10: Lighting
- Light Sources ............................................................. 193
- Managing Light Sources in the Inspector .................. 195
- The Light Source Editor .............................................. 196
  - Main Elements of the Light Source Editor ............... 196

### Chapter 11: Using Cameras ........................................ 203

### Chapter 12: Auxiliary Objects ................................. 207
- Text Annotation .......................................................... 207
- Measurement Tool ..................................................... 209
- Images ....................................................................... 211
  - Images on the Floor Plan ........................................ 211
  - Images in 3D ............................................................. 211

### Chapter 13: Guidelines and the Layout Grid ............. 215
- Guidelines ................................................................. 215
- Layout Grid ............................................................... 216

### Chapter 14: Solving Problems ................................. 217
- Troubleshooting ......................................................... 217
  - Cannot Register the Program ................................. 217
  - Cannot Open the Program ....................................... 217
  - Cannot Select an Object ......................................... 217
  - Performance Issues ............................................... 218
  - Red Circles on the Floor Plan .................................. 220
  - Printing Problems ................................................... 221
- Known Issues and Limitations ................................. 222
- Technical Support ...................................................... 225
Chapter 1: Introduction

Brief Description

Live Interior 3D is a program for designing the interior of a house or an apartment. It helps you visualize your ideas and imagine your future home or office. Using this program, you can find optimal design solutions and choose a suitable location for your furniture. Before ordering various pieces of furniture, you will be able to see how they fit in the interior.

The program lets you design different types of buildings: homes, apartments, offices, living rooms, dining rooms, etc.

The program contains models of furniture and accessories that are copies of the actual items produced by leading manufacturers (PIIROINEN, Villeroy&Boch and others). Some models from the supplied library have no real prototypes.

The program can be used by professional as well as amateur designers.

As a result, you get a computer model of your apartment. Your project contains:

- A printable floor plan of the apartment with walls, doors, windows, furniture and other accessories.
- 3D model that lets you walk inside your apartments. You will see the room as if you were inside it. You can take “photographs” (screenshots) of the preview area.
System Requirements

<table>
<thead>
<tr>
<th>System Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>Intel Core 2 Duo (Core i3 recommended)</td>
</tr>
<tr>
<td>Memory</td>
<td>2 GB or more (4 GB is recommended)</td>
</tr>
<tr>
<td>Video</td>
<td>OpenGL compatible video card</td>
</tr>
<tr>
<td>Video Memory</td>
<td>128 MB or more (512 MB is recommended)</td>
</tr>
<tr>
<td>OS</td>
<td>Mac OS X 10.6.8 or higher</td>
</tr>
<tr>
<td>HDD</td>
<td>2 GB of available space</td>
</tr>
<tr>
<td>Display</td>
<td>1024x768 (or higher) with 32 bit color</td>
</tr>
<tr>
<td>Min. screen resolution</td>
<td>1024x768</td>
</tr>
<tr>
<td>Peripherals</td>
<td>Keyboard and mouse</td>
</tr>
<tr>
<td>Other</td>
<td>Apple QuickTime 7 (for exporting to QTVR format)</td>
</tr>
<tr>
<td></td>
<td>Google SketchUp 6 or higher (for editing 3D models)</td>
</tr>
</tbody>
</table>

Internet connection is required to use online services.

Installing Live Interior 3D

Retail version:
1. Insert the disc into the drive.
3. Follow the installation instructions.

Download version:
1. Double-click the LiveInterior3DPro.dmg file.
2. Double-click the Live Interior 3D Pro Edition installer icon in the window that comes up.
3. Follow the installation instructions.

Registration

If you purchased the download version of the program, you’ll find the license code in the purchase confirmation email. If you have the program on a disc, find the code inside the program pack on the disc envelope.
To register Live Interior 3D:
1. Open the application.
2. Bring up the License dialog by choosing Live Interior 3D Pro > License... in the menu.
3. Enter your name and license code.

It’s recommended that you keep the e-mail or the disc package containing your license code in a safe place in case you need to register the application after re-installation or after update.

The unregistered version of Live Interior 3D cannot save projects.

To upgrade from the trial to the registered version of the program you need to purchase and register it. See details on BeLight’s web site: http://www.belightsoft.com/buy/

**Updating the Program**

From time to time, the software developer releases new versions of the product.

Before starting the update installer, make sure that the application and supporting files are placed in their default locations. For default file locations, see below.

To check for and download the latest update, click Check for Updates in the Live Interior 3D Pro program menu. Alternatively, you can visit the Live Interior 3D Updates web page: http://www.belightsoft.com/liveinterior/update

**Removing the Program**

To uninstall the program completely or delete some of its parts, choose Live Interior 3D Pro > Uninstall... from the menu. Then select the items to delete and click the Uninstall button.

To delete the program files and folders, select:
- Remove Live Interior 3D Application
- Remove Live Interior 3D Preferences

These items can be restored by re-installing the application.

To delete objects and materials that you have added to the library, select the Remove User Content check box. Be careful! You will not be able to restore the user’s libraries by re-installing Live Interior 3D.
Removing the Program Manually

To remove the program manually, remove the following files and folders:

- Live Interior 3D Pro.app from the Applications folder.
- com.belightsoft.LiveInterior3DPro.plist file from the ~/Library/Preferences/ folder.
- If you don’t need your custom materials and documents that may be stored in the program’s folder, delete the Live Interior 3D folder from the ~/Library/Application Support/BeLight Software/ folder.
- All *.pkg files whose name begins with “liveInterior3D” from the /Library/Receipts/ folder if these files exist.

“~” means the user’s Home folder.

To access the Library folder, in the Finder choose Go > Go to Folder (Cmd-Shift-G). Then type “~/Library/” into the edit box, and click the Go button.

To remove manually the program downloaded from Mac AppStore, remove the following files and folders:

- /Applications/Live Interior 3D Pro.app
- ~/Library/Containers/com.belightsoft.LiveInterior3DProMAS/

**Note:** By default, the program saves custom content in:
~/Library/Containers/com.belightsoft.LiveInterior3DProMAS/Data/Library/Application Support/Live Interior 3D Pro/
Don’t remove this folder if you are going to use your content in the future.

To access the ~/Library/Containers/ folder, in the Finder choose Go > Go to Folder (Cmd-Shift-G). Then copy “~/Library/Containers/” to the edit box, and click the Go button.

Web Resources

Live Interior 3D Home Page: Download, Updates, Buy and FAQ
http://www.belightsoft.com/liveinterior/

Useful articles connected with using Live Interior 3D
http://www.belightsoft.com/products/liveinterior/resources.php

The home page of BeLight Software: Products, Download, Support, Buy
http://www.belightsoft.com/
BeLight Software Support
http://www.belightsoft.com/support/

Conventions Used in this Document

- **Bold text** is used for names of menu items, shortcuts, buttons, radio buttons, edit boxes, check boxes and other controls.

- *Text in italics* is used for the names of windows, dialog boxes, panels, tabs and other elements of the program interface.

Such text formatting is also used for names of programs, files, folders and web links.

It is also used for chapter and section references and to introduce important remarks.

- For menu items hierarchy, the “>” symbol is used. “**File > Open**” is equivalent to “the Open item in the File menu”.

- A shortcut (shortkey) is one or several keys pressed together. **Cmd-S** means you should hold down the **Command** key while pressing the **S** key, then release them.

- Ctrl-click is a click holding the **Ctrl** key down. Right-click is a click by the right button of a two-button mouse. Both actions are equivalent.

- The context (contextual or shortcut) menu is a pop-up menu that contains options that vary depending on the object (image, text, etc.) you have clicked on. To open the context menu, right-click or Ctrl-click on an object.
Chapter 2: Live Interior 3D Workspace

The Main Window

1 – The Library panel displays the library of 3D models or the Project Tree.

2 – A handle to expand/collapse the Library panel.

3 – The 2D toolbar with tools for adding walls, ceilings, floors and other objects. For details, see The Toolbar section.

4 – The 2D View area for displaying the floor plan.

5 – The splitter bar between the 2D and 3D views. Move it with the mouse to distribute space between the views.

6 – The 3D mode selector.

7 – The 3D View window.
The Assistant

When you start Live Interior 3D for the first time, it opens the Assistant, a collection of pre-designed projects. The Assistant allows you to choose what project to open:

- Project from the built-in collection
- Custom template (user’s project saved as a template)
- One of recently opened documents
- Any project on your computer
- Empty project

By default, the Assistant opens on start-up. To control this, use the Show Assistant on start-up option in the Miscellaneous tab of the program Preferences dialog.

To open the Assistant at any time, use the File > New From Assistant… menu command (Cmd-Shift-N).

Using Templates

Projects from the Assistant are intended for:

- Learning the program. You can open and change a template to see how the program works.
- Creating new projects. You can modify a pre-designed project to meet your needs, or create a custom template and then use it to make several variations of the furniture arrangement, decoration and so on.

Pre-designed projects are grouped into categories. In the left part of the Assistant window is a list of the template categories. The right box shows the template previews from the selected category.

To open a template, select its thumbnail and click OK, or double-click the thumbnail.

To open a project saved on your hard disk, click the Open button in the Assistant. Select the File > Open menu item when the Assistant is not open.

The creation of custom templates is described in Chapter 4: "Working with Projects” > "Saving Projects”.

Opening a project as a template differs from opening it through the File > Open… command. The template will not be overwritten: the program will offer you to save the modified template under another name.
The 2D View

The 2D view window is used for drawing floor plans.

To open the 2D view, choose the **View > Toggle 2D/3D View** menu command or click the **2D View** button in the toolbar (item 10 in the “The Toolbar” section below).

In the 2D view, you can add objects from the library and draw walls, floors and ceilings.

1 – The toolbar (see “The Toolbar” section below).

2 – The Information bar shows detailed information about the selected object, such as its dimensions, elevation and orientation. The bar disappears when you hide the rulers.

3 – Click on the current measurement unit to choose another in the Project Setup.
4 – Rulers. To turn the rulers on/off, use the View > Hide/Show Rulers (Cmd-R) menu command.

When you move an object with the mouse in the 2D View, the rulers can display rulerlines. Rulerlines are thin lines that show the coordinates of left, right, top and bottom object edges on the rulers. Rulerlines move along with the object. To control rulerlines, use the View > Rulerlines menu.

5 – The 2D view area.

6 – The handle of the splitter bar that separates the Library panel and 2D View. Move it to the right or to the left to make the Library panel bigger or smaller.

7 – Storey pop-up menu.

The upper section displays a list of storeys in the project. The lower section lets you add and remove floors. You can also choose the current floor to be the ground floor.

8 – Zoom control.

9 – The splitter bar between the 2D and 3D views.
Chapter 2: Live Interior 3D Workspace

The Toolbar

1 – The Selection tool for choosing and moving objects.

2 – The Straight Wall tool for drawing walls.

3 – Tools for working with slabs.

3.1 – The Floor tool. You can add a floor manually instead of using the floor added by the program.

3.2 – The Ceiling tool. You can add a ceiling manually instead of using the ceiling added by the program.

3.3 – The Floor+Ceiling tool. Use it for adding a floor and ceiling objects together. The result is as if you draw a floor using tool 3.1, and then draw a ceiling right over the floor using tool 3.2.

3.4 – The Ceiling Opening tool. Creates an opening in a slab of the current storey.
4 – Tools for adding auxiliary objects.

4.1 – The Measurement tool. Defines distances between the specified points.

4.2 – Text Annotation. Adds text boxes for typing or pasting text.

5 – The Camera tools.

5.1 – The Camera tool. Adds individual cameras.

5.2 – The Movie Track tool. Adds movie cameras. A chain of these cameras defines a movie track.

6 – Zoom.

6.1 – Zoom In.

6.2 – Zoom Out.

7 – The Pan tool (“scrolling hand”) for scrolling the 2D view with the mouse.
An activated tool is highlighted.

The **Straight Wall, Floor, Ceiling, Floor+Ceiling, Ceiling Opening, Text Annotation** and **Camera** tools have two active modes.

Upon a single click, the tool activates in the standard mode. After adding or modifying a corresponding object, the tool becomes deactivated and the **Selection** tool becomes active.

Upon a double-click, the tool activates in the continuous mode. After adding or modifying a corresponding object, the tool stays active and you can continue working with it. This is useful if you need to add, for instance, several cameras.

8 – Browse the Trimble 3D Warehouse on-line collection.

9 – Open Inspector.

10 – Display the 2D view.

11 – Display the 2D and 3D views together.

12 – Display the 3D view.
The 3D View

Walk mode selector

1 – The Selection mode. In this mode, the mouse can be used for selecting and moving objects. To walk around, click on the arrows of the 3D Walk Control, or use the arrow keys.

2 – The Look Around and Fly Around modes. Using the mouse, you can change the view direction or fly around a fixed point.

3 – The Walk mode. The mouse cursor turns into an arrow showing the walk direction. To change the direction, move the cursor to sides or corners of the 3D view. To walk, press the left mouse button.
Rendering quality selector

4 – Display the picture without lights and shadows. The lowest quality, the highest walk speed.

5 – Display the picture with lights but without shadows. Intermediate quality and walking speed.

6 – Display the picture with lights and shadows. The highest quality, the lowest walk speed.

7 – Take a picture of the 3D view.

8 – Browse the Trimble 3D Warehouse on-line 3D object collection.

9 – Open Inspector.

View mode selector

10 – Display the 2D view.

11 – Display the 2D and 3D views together.

12 – Display the 3D view.

The width of views

13 – The splitter bar between the 2D and 3D views. Move the splitter bar to expand one view while at the same time narrowing down another view.

14 – The handle of the library of objects. Move the handle to change the panel width.

In the top right corner of the 3D preview, a camera icon may be displayed. Its purpose is described in Chapter 11: "Using Cameras".
Camera Orientation and Walk Control

One of the possible ways to move inside your 3D model is to use the **Walk Control**. This is a round control that is sensitive to mouse clicks. The direction of movement depends on the point where you click on it.

The **Walk Control** appears at the bottom of the 3D view when you move the mouse cursor over this area. This happens in the automatic mode. There are two other modes: the control is always displayed or never displayed. To choose a mode, use the **View > Display 3D Walk Control** menu. The control is semi-transparent and lets you see the space behind it.

Note that the **Walk Control** is not displayed when the **Walk** mode is selected in the **View > 3D View > Tools** menu.

The current view point can be fine tuned using the **Cameras Controls** in the **Cameras Properties** tab of the **Inspector**.
**Walk Control**

1 – Turn to the left. 
2 – Move forward turning to the left. 
3 – Move forward. 
4 – Move forward turning to the right. 
5 – Turn to the right. 
6 – Move leftward. 
7 – Move backward. 
8 – Move rightward. 

**Camera Pitch**

9 – Tilt Up – look upwards. 
10 – Restore the default tilt (double-click) – look straight forward. 
11 – Tilt Down – look downwards. 

**Camera Elevation**

12 – Move the camera up. 
13 – Restore the default level (double-click). 
14 – Move the camera down.
Walking Around the Interior

The program offers several methods of walking and turning around in the 3D space:

- Using the **Walk Control**.
- Using the keyboard.
- Using the **Look Around** and **Fly Around** tools.

You can control whether or not you can walk through walls and other objects. To do this, use the **Consider Collisions** toolbar button **View > 3D View > Consider Collisions**. The program disables the Consider Collisions mode when you walk while a user camera is selected (the camera icon in the right top corner of the 2D view indicates this).

If the current camera or view point is located in an improper position (inside a wall, for instance), the program temporarily disables the Consider Collisions mode which is indicated in the 3D view by the following icon:

![Man walking icon](image)

**Using the Keyboard**

The keyboard arrow keys are used for moving forward, backward, and turning left and right. Alternative shortkeys are shown in brackets.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up (W)</td>
<td>Move forward</td>
</tr>
<tr>
<td>Down (S)</td>
<td>Move backward</td>
</tr>
<tr>
<td>Left</td>
<td>Turn to the left</td>
</tr>
<tr>
<td>Right</td>
<td>Turn to the right</td>
</tr>
<tr>
<td>Cmd-Up (Q)</td>
<td>Tilt the camera up</td>
</tr>
<tr>
<td>Cmd-Down (Z)</td>
<td>Tilt the camera down</td>
</tr>
<tr>
<td>Option-Up (E)</td>
<td>Move the camera up</td>
</tr>
<tr>
<td>Option-Down (C)</td>
<td>Move the camera down</td>
</tr>
<tr>
<td>Option-Left (A)</td>
<td>Move the camera leftward</td>
</tr>
<tr>
<td>Option-Right (D)</td>
<td>Move the camera rightward</td>
</tr>
</tbody>
</table>
The walking speed depends on the rendering quality. At a higher quality setting, the movement will be slower.

Use the rendering quality control to set the most appropriate quality. When taking a picture (export the 3D view), set the maximum quality.

**Using the Look Around and Fly Around Tools**

The **Look Around** and **Fly Around** tools can be activated either in the View > 3D View > Tools menu or in the 3D Toolbar. In the toolbar they share the same button. To activate the selected tool, click the toolbar button or press the Space key. To select and activate other tool, click the button and hold it for a while. Then choose a tool in the pop-up menu.

In the Look Around mode, your location is fixed. You can change the view direction.

In the Fly Around mode, you can fly around a point specified in the 3D view this way. Place the cursor at the desired point, press the left mouse button and then move the mouse around.

To change the view direction in both Look Around and Fly Around modes, place the mouse cursor over the 3D view, press the left mouse button, and move the mouse.

**Moving Objects in the 3D View**

To move an object horizontally in the 3D view, drag it with the mouse.

The state of the **Glue By** option in the Inspector (the Object Properties tab) defines the vertical location of the object in relation to the floor and other objects. When the option is disabled, the object movement is strictly horizontal. When it is enabled, the object can change its elevation. For example, if you move a vase off a table, it will fall onto the floor.

Holding the **Cmd** key temporarily disables the **Glue By** option. When you release **Cmd** or the mouse button, the object will have the elevation that it should have according to the **Glue By** function.

To move an object in a vertical plane (perpendicular to the current view direction), hold the **Opt** key.

The **Glue By** and **Lock Elevation** options prevent changing the elevation accidentally. Disable them to change the object’s elevation.
The Inspector Window

The Inspector is a floating window that lets you change object properties, control cameras and manage storeys. The Inspector window is sensitive to the type of the selected object. It displays the current settings for this object and lets you modify them.

To open the Inspector window:
- Choose Window > Show Inspector menu item;
- Click the “i” toolbar button;
- Press Cmd-I.

Below is some basic information about Inspector tabs. Each tab is described in more detail in the sections dedicated to particular objects.

The Object Properties Tab

The Object Properties tab contains the tools that control properties of most objects.

To open the tab, choose Window > Inspector > Object Properties.

The displayed properties depend on the object selected in the project. When you select an object, the program opens the corresponding set of properties.

The Materials Tab

The Materials tab lets you change materials of objects and create new materials. The built-in library of materials is located in this tab.

To open the tab, choose Window > Inspector > Materials.

The 2D Properties Tab

The 2D Properties tab lets you specify the appearance of objects in the 2D view.

To open the tab, choose Window > Inspector > 2D Properties.

The Drawing settings can be used only with drawn objects: walls, ceilings and floors. They allow you to modify the color of outlines, filling, color and type of the fill pattern.

The Text Annotations section contains text formatting tools.
The Cameras Properties Tab

The Cameras Properties tab lists all the cameras in the current project: predefined, custom and movie cameras.

To open the tab, choose Window > Inspector > Cameras.

Predefined cameras are always present in the list. Custom cameras and movie cameras can be added and removed by the user.

The camera selected in the Inspector defines the point of view for the 3D view.

The Lights Properties

The Lights Properties tab controls light sources.

To open the tab, choose Window > Inspector > Lights Properties.

To change brightness or color of a light source, select it in the list. To turn the light on or off, click the on bulb icon.

The Building Properties Tab

The Building Properties tab lets you add and remove floors. You can also change the storey and slab height. Any floor can be assigned to be the ground level.

To open the tab, choose Window > Inspector > Building Properties.
The Program Preferences

Before starting your work on the first project, set up the program. The program settings are stored in the program preferences file and apply to all projects. The program settings are used as default settings for new projects.

The New Project Tab

These settings are used as defaults for Project Setup when you create a new project. To change the current project only, use File > Project Setup.

1 – Measurement units.

2 – The Suppress Units check box lets you hide measurement units in the 2D layout (you will see 40’ 00.0” instead of 40’ 00.0” ft, or 2.6 instead of 2.6 m).

3 – Scale of the floor plan in the 2D view. “1:100” means that one meter will be equal to one centimeter on the screen.

4 – The default story height for new projects.

5 – Type of 2D representation. Here you can choose either the line drawing type, or automatically created object’s top view.

6 – The quality of auto-generated 2D representations.
The 3D Settings Tab

3D settings affect the quality and speed of rendering a picture in the 3D view.

1 – Retina™ High Resolution
2 – Full Scene Anti-Aliasing
3 – Textures Filtering
4 – Reflections Quality
5 – Decrease Quality when Moving
6 – Shadow rendering technique
7 – Shadow Casting Lights
8 – Shadow Maps Quality

1 – The Retina™ High Resolution check box enables native high resolution for all the 3D renderings and auto-generated 2D representations (when activated) on all Macintosh computers with Retina™ display. If you face the performance decrease, deselect this check box.
2 – Full Scene Anti-Aliasing makes the picture look softer by smoothing edges of objects.

To apply the parameter change, restart the program.

Anti-aliasing: off

Anti-aliasing: on
3 – Textures Filtering lets you choose a type of filter, or turn it off.

Texture filtration softens transition from texture tiles near the view point to texture tiles far away.

To apply this parameter, restart the program.

Filter: None

Filter: Trilinear

Note that in some cases choosing different filter types produces similar pictures. If only plain color materials were used in the scene, you may not notice any difference when the texture filtration is on and off. It is not recommended that you set this parameter to None because textures are used in most 3D models.
4 – Reflections quality. This parameter affects how detailed the reflected picture is. At lower quality, the picture may look more pixelated, but rendering is faster.

5 – The Decrease Quality when Moving option can change the rendering mode automatically. When this option is activated, the program turns off reflections, shadows and lights while you are walking around in 3D. When you stay still, lights, reflections and shadows restore. Note that if lights and shadows are already turned off in View > 3D View > Rendering Quality (or in the toolbar) then nothing will change when you start walking in 3D.
Chapter 2: Live Interior 3D Workspace

6 – Shadow rendering technique. The program lets you choose the Stencil Shadows or Shadow Maps mode. The Stencil Shadows mode is the default mode.

The 3D pictures rendered by these modes are different.

Stencil Shadows

Shadow Maps

The difference:
1. The Stencil Shadows method is more accurate. The Shadow Maps give less sharp shadows (compare 2 and 4). Completely or almost invisible shadows can be rendered by Shadow Maps when a very thin object is located very close to a large surface (compare 1 and 3).
2. When you are walking around, rendering in the Shadow Maps mode is faster if Shadow Maps Quality is set to the intermediate or lower values.
3. The Shadow Maps mode must be supported by the graphic card. These cards don’t support Shadow Maps:
   • GeForce4 Ti
   • GeForce3
   • GeForce2 MX/4 MX
   • Radeon 9600/9700/9800/X600
   • Radeon 9000/9200
   • Radeon 8500
   • Radeon 7200/7500
   • Radeon 7000
   • GMA 950

7 – Shadow Casting Lights defines how many light sources (including the sun and the moon) are taken into account when the program is rendering shadows. At smaller numbers, rendering is faster.

Note that if the quantity of considered light sources is too small, you can get an unrealistic picture because you cannot see shadows that normally exist.
In the picture:
1 – Light source 1
2 – Light source 2
3 – Shadow from the Sun
4 – Shadow from the light source 1
5 – No shadow from the light source 2 with Shadow Casting Lights set to Nearest 2
6 – Shadow from the light source 2 with Shadow Casting Lights set to Nearest 4

8 – The Shadow Maps Quality can be used to increase the rendering speed. To do this, set lower or intermediate values. At low quality, shadows look blurred.

**The Trimble 3D Warehouse™ Tab**

These options control import of Trimble SketchUp™ objects.

Make all surfaces double-sided to avoid invisible surfaces changes the way of importing Trimble SketchUp™ objects. It is set by default.

Split object instances splits a compound object to make its parts separate objects in Live Interior 3D.

See details in Chapter 7: "Working with Objects" > "Import Options”.

**The Miscellaneous Tab**

Show Assistant on start-up opens the Assistant when you launch the program. This lets you choose and load a sample project.

Animate Library 3D Preview by default enables or disables automatic rotation of the selected 3D object in the preview box. Deselect this option to increase computer performance.

The Save supplied content in projects option lets you control the project file size. Normally, the 3D models of all objects used in the project are saved along with the project file. When the option is selected, links to the library objects are saved instead of the actual objects. The option affects only the objects taken from the built-in library. Modified library objects and objects imported from the outside Live Interior 3D are always saved in the project.

The Autosave modified projects option allows the program to automatically save a copy of a project to the same folder. If the program quits unexpectedly, at the next start-up the program it will open the autosaved copy.
Snap Sensitivity on 2D Plan defines how close you need to bring one object to another before the objects snap together.

Automatically check for updates lets you specify how frequently the program checks for updates.
Chapter 2: Live Interior 3D Workspace

Live Interior 3D Menus

The “Live Interior 3D Pro” Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Live Interior 3D</td>
<td>Display information about the program.</td>
</tr>
<tr>
<td>Licenses…</td>
<td>Open the registration dialog.</td>
</tr>
<tr>
<td>Check for Updates</td>
<td>Check for the latest updates on the Internet.</td>
</tr>
<tr>
<td>Preferences (Cmd-“,”)</td>
<td>Bring up the program Preferences dialog.</td>
</tr>
<tr>
<td>Uninstall…</td>
<td>Delete the whole program or its parts.</td>
</tr>
<tr>
<td>Quit (Cmd-Q)</td>
<td>Exit the application.</td>
</tr>
</tbody>
</table>

The “File” Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New (Cmd-N)</td>
<td>Create a new empty project.</td>
</tr>
<tr>
<td>New from Assistant… (Cmd-Shift-N)</td>
<td>Open template projects in the Assistant.</td>
</tr>
<tr>
<td>Open… (Cmd-O)</td>
<td>Open an existing project.</td>
</tr>
<tr>
<td>Open Recent &gt;</td>
<td>Open the list of the projects you recently worked with.</td>
</tr>
<tr>
<td>Close (Cmd-W)</td>
<td>Close the active project.</td>
</tr>
<tr>
<td>Close All</td>
<td>Close all open projects.</td>
</tr>
<tr>
<td>Save (Cmd-S)</td>
<td>Save the open project.</td>
</tr>
<tr>
<td>Save As… (Cmd-Shift-S)</td>
<td>Save the open project under a new name.</td>
</tr>
<tr>
<td>Save As Template</td>
<td>Save the open project as template.</td>
</tr>
<tr>
<td>Revert</td>
<td>Load the last saved version of the project.</td>
</tr>
<tr>
<td>Import 3D Object…</td>
<td>Import a 3D object.</td>
</tr>
<tr>
<td>Export 2D Plan…</td>
<td>Save the 2D layout as a graphic file.</td>
</tr>
<tr>
<td>Export 3D View…</td>
<td>Export the current 3D view to a graphic file.</td>
</tr>
<tr>
<td>Export To</td>
<td>Export the project or selected objects to the 3D file format.</td>
</tr>
<tr>
<td>Project Setup…</td>
<td>Open project settings.</td>
</tr>
</tbody>
</table>
Print... (Cmd-P) | Bring up the standard print dialog for printing the floor plan.

**The “**Edit**” Menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo (Cmd-Z)</td>
<td>Reverse the last operation you performed.</td>
</tr>
<tr>
<td>Redo (Cmd-Shift-Z)</td>
<td>Reverse the last Undo operation.</td>
</tr>
<tr>
<td>Cut (Cmd-X)</td>
<td>Remove the selected objects and place the selection onto the Clipboard.</td>
</tr>
<tr>
<td>Copy (Cmd-C)</td>
<td>Copy the selected objects onto the Clipboard.</td>
</tr>
<tr>
<td>Paste (Cmd-V)</td>
<td>Paste the content of the Clipboard into the project.</td>
</tr>
<tr>
<td>Duplicate (Cmd-D)</td>
<td>Duplicate the selected object.</td>
</tr>
<tr>
<td>Delete (Backspace)</td>
<td>Remove the selected object.</td>
</tr>
<tr>
<td>Make Object Invisible</td>
<td>Make the selected object(s) invisible.</td>
</tr>
<tr>
<td>Lock Object</td>
<td>Lock the selected object(s).</td>
</tr>
<tr>
<td>Add Selected Objects to Library</td>
<td>Add the selected object(s) to the current category of the object library.</td>
</tr>
<tr>
<td>Tools &gt; Selection (Cmd-1)</td>
<td>Activate the selection tool.</td>
</tr>
<tr>
<td>Tools &gt; Straight Wall (Cmd-2)</td>
<td>Activate the wall drawing tool.</td>
</tr>
<tr>
<td>Tools &gt; Floor (Cmd-3)</td>
<td>Activate the floor drawing tool.</td>
</tr>
<tr>
<td>Tools &gt; Ceiling (Cmd-4)</td>
<td>Activate the ceiling drawing tool.</td>
</tr>
<tr>
<td>Tools &gt; Floor &amp; Ceiling (Cmd-5)</td>
<td>Activate the Floor+Ceiling drawing tool.</td>
</tr>
<tr>
<td>Tools &gt; Ceiling Opening (Cmd-6)</td>
<td>Activate the ceiling opening drawing tool.</td>
</tr>
<tr>
<td>Tools &gt; Camera</td>
<td>Activate the camera tool.</td>
</tr>
<tr>
<td>Tools &gt; Movie Track</td>
<td>Activate the movie camera tool.</td>
</tr>
<tr>
<td>Building &gt; ...</td>
<td>Functions to add and delete storeys and roofs.</td>
</tr>
<tr>
<td>Light Sources ...</td>
<td>Open the light source editor for the selected object.</td>
</tr>
<tr>
<td>Type &amp; Representation...</td>
<td>Open the Type &amp; Representation settings for the selected object.</td>
</tr>
</tbody>
</table>
## The **Insert** Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image...</td>
<td>Insert an image from a graphic file into the 2D layout.</td>
</tr>
<tr>
<td>Measurement</td>
<td>Activate the Measurement tool.</td>
</tr>
<tr>
<td>Text Annotation</td>
<td>Insert a text box into the 2D layout.</td>
</tr>
<tr>
<td>Horizontal Guide</td>
<td>Insert a horizontal layout guide in the 2D view.</td>
</tr>
<tr>
<td>Vertical Guide</td>
<td>Insert a vertical layout guide in the 2D view.</td>
</tr>
<tr>
<td>User Camera</td>
<td>Insert a camera into the 2D layout.</td>
</tr>
<tr>
<td>Movie Camera</td>
<td>Add a movie camera to the current position in the 3D view.</td>
</tr>
</tbody>
</table>

## The **View** Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/Hide Toolbar</td>
<td>Show or hide the toolbar of the main window.</td>
</tr>
<tr>
<td>Customize Toolbar...</td>
<td>Customize the toolbar.</td>
</tr>
<tr>
<td>Zoom In (Cmd-“=””)</td>
<td>Enlarge the current view.</td>
</tr>
<tr>
<td>Zoom Out (Cmd-“−”)</td>
<td>Zoom out the current view.</td>
</tr>
<tr>
<td>Actual Size (Cmd-)</td>
<td>Display the 2D view at its actual size (100%).</td>
</tr>
<tr>
<td>Zoom &gt; ...</td>
<td>Scale the 2D layout to one of the predefined sizes.</td>
</tr>
<tr>
<td>Zoom &gt; Fit Plan (Cmd-0)</td>
<td>Scale the 2D layout so that it fits the view window.</td>
</tr>
<tr>
<td>Zoom &gt; Fit Width</td>
<td>Scale the 2D layout so that its width fits the view area width.</td>
</tr>
<tr>
<td>Zoom &gt; Fit Height</td>
<td>Scale the 2D layout so that its height fits the view area height.</td>
</tr>
<tr>
<td>Toggle 2D/3D View (Cmd-)</td>
<td>Toggle from the 2D to 3D view and vice versa.</td>
</tr>
<tr>
<td><strong>3D View &gt; Tools &gt; ...</strong></td>
<td>Activate the Selection, Look Around, Fly Around or Walk mode. For more detail, see the description of 3D view controls.</td>
</tr>
<tr>
<td><strong>3D View &gt; Rendering Quality &gt; ...</strong></td>
<td>Change the rendering quality. For more detail, see the Lighting section.</td>
</tr>
<tr>
<td><strong>3D View &gt; Daytime &gt; ...</strong></td>
<td>Change the sunlight options. For more detail, see the Lighting section.</td>
</tr>
<tr>
<td><strong>3D View &gt; Consider Collisions</strong></td>
<td>Turns on or off the Consider Collisions mode.</td>
</tr>
</tbody>
</table>
| **3D View > Show Statistic Info (Cmd-Opt-S)** | Show or hide 3D rendering information in the status bar.  
Triangles – how many triangles were processed to render the last frame in the 3D scene.  
Batches – how many batches were processed to render the last frame in the 3D scene. A batch is a group of objects or their parts with the same material applied.  
FPS (frames per second) – average and at the moment (in brackets). |
| **Display 3D Walk Control** | Change the way the Walk Control appears in the 3D view. |
| **Jump to Selection in 3D (Cmd-Shift-V)** | Display the selected object in the 3D view. |
| **Disable/Enable 2D Snapping** | Deactivate or activate snapping in the 2D view. |
| **Show Rulers (Cmd-R)** | Show or hide the rulers. |
| **Show Rulerlines** | Show or hide rulerlines. |
| **Show Floor Labels** | Show or hide floor labels. |
| **Show 3D Viewpoint** | Show or hide the current point of view on the floor plan. |
| **Show Smart Guidelines** | Enable/disable displaying guidelines and snapping to them when you are moving an object. |
| **Show Grid** | Show or hide the layout grid. |
| **Show Storey Above Current** | Show or hide walls of the storey above the current. |
| **Show Storey Below Current** | Show or hide walls of the storey below the current. |
## Chapter 2: Live Interior 3D Workspace

<table>
<thead>
<tr>
<th>Show Compass in 2D</th>
<th>Show or hide the compass in the 2D view.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2D Representations &gt; ...</td>
<td>Select a 2D representation type. This applies to all objects in the project that can change the representation, except those whose representation was manually altered in the Inspector. Choose the quality of auto-generated 2D representation of the selected object.</td>
</tr>
<tr>
<td>Show Copyrights Info</td>
<td>Show the copyright information bar when a downloaded object is selected.</td>
</tr>
<tr>
<td>Enter/Exit Full Screen (Ctrl-Cmd-F)</td>
<td>Enter or exit the full screen mode.</td>
</tr>
</tbody>
</table>

### The “Arrange” Menu

| Align > ... | Align the selected objects by their edges or centers. |
| Distributed > ... | Distribute spacing or centers of the selected objects. |
| Group (Cmd-G) | Group the selected objects. |
| Ungroup (Cmd-Shift-G) | Ungroup the selected objects. |
| Merge into Single Object | Create one object out of several selected. |

### The “Window” Menu

| Minimize (Cmd-M) | Minimize the window that is currently active. |
| Zoom | Toggle between the maximum size of the window and the recently set size. |
| Library > ... | Open one of the object library sections. |
| Project Tree | Open the Project Tree. |
| Trimble 3D Warehouse | Open the browser of the Trimble 3D Warehouse online library. |
| Inspector > ... | Open tabs of the Inspector window. |
Bring All to Front | Move all application windows in front of the windows of other active applications.
---|---
Toggle Library | Show or hide the Library panel.
Show Inspector (Cmd-I) | Show or hide the Inspector window.
Show Environment Settings (Cmd-E) | Show or hide the Environment window.

**The “Help” Menu**

<table>
<thead>
<tr>
<th>Live Interior 3D Help</th>
<th>Open the built-in Help.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live Interior 3D Web Site…</td>
<td>Live Interior 3D product web page.</td>
</tr>
<tr>
<td>Useful Online Resources…</td>
<td>Useful resources on BeLight Software web site connected with Live Interior 3D.</td>
</tr>
<tr>
<td>Online Registration…</td>
<td>Open an online registration form.</td>
</tr>
<tr>
<td>Send Feedback…</td>
<td>Lets you email your feedback to the developers.</td>
</tr>
<tr>
<td>Video Tutorials</td>
<td>Lets you choose and play online video tutorials.</td>
</tr>
</tbody>
</table>
# Live Interior 3D Keyboard Shortcuts

## Working with Projects

<table>
<thead>
<tr>
<th>Key Sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd-N</td>
<td>Create a new empty project.</td>
</tr>
<tr>
<td>Cmd-Shift-N</td>
<td>Create a new project by using the Assistant.</td>
</tr>
<tr>
<td>Cmd-O</td>
<td>Open an existing project.</td>
</tr>
<tr>
<td>Cmd-W</td>
<td>Close the active project.</td>
</tr>
<tr>
<td>Cmd-S</td>
<td>Save the active project.</td>
</tr>
<tr>
<td>Cmd-Shift-S</td>
<td>Save the open project under a new name.</td>
</tr>
<tr>
<td>Cmd-Q</td>
<td>Quit the Application.</td>
</tr>
<tr>
<td>Cmd-P</td>
<td>Bring up the standard print dialog for printing the 2D layout.</td>
</tr>
</tbody>
</table>

## Working with Objects

<table>
<thead>
<tr>
<th>Key Sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd-Z</td>
<td>Undo the last operation.</td>
</tr>
<tr>
<td>Cmd-Shift-Z</td>
<td>Redo the last operation.</td>
</tr>
<tr>
<td>Cmd-X</td>
<td>Cut the selected object(s) to the Clipboard.</td>
</tr>
<tr>
<td>Cmd-C</td>
<td>Copy the selected objects into the Clipboard.</td>
</tr>
<tr>
<td>Cmd-V</td>
<td>Paste the content from the Clipboard into the project.</td>
</tr>
<tr>
<td>Cmd-D</td>
<td>Duplicate the selected object.</td>
</tr>
<tr>
<td>Del</td>
<td>Delete the selected object.</td>
</tr>
<tr>
<td>Cmd-A</td>
<td>Select all the objects in the document.</td>
</tr>
<tr>
<td>Cmd-1</td>
<td>Activate the selection tool.</td>
</tr>
<tr>
<td>Cmd-2</td>
<td>Activate the wall drawing tool.</td>
</tr>
<tr>
<td>Cmd-3</td>
<td>Activate the floor drawing tool.</td>
</tr>
<tr>
<td>Cmd-4</td>
<td>Activate the ceiling drawing tool.</td>
</tr>
<tr>
<td>Cmd-5</td>
<td>Activate the Measurement tool.</td>
</tr>
<tr>
<td>Cmd-6</td>
<td>Activate the ceiling opening drawing tool.</td>
</tr>
</tbody>
</table>
### Arrows

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrows</td>
<td>Move the selected object in the 2D view. Walk in the 3D view.</td>
</tr>
<tr>
<td>Arrows-Shift</td>
<td>Move the selected object in the 2D view (by larger increments).</td>
</tr>
<tr>
<td>Cmd-G</td>
<td>Group the selected objects.</td>
</tr>
<tr>
<td>Cmd-Shift-G</td>
<td>Ungroup the selected objects.</td>
</tr>
<tr>
<td>Cmd-Shift-V</td>
<td>Display the selected object in the 3D view.</td>
</tr>
</tbody>
</table>

### Working with Windows and Panels

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd-&quot;+&quot;</td>
<td>Zoom In.</td>
</tr>
<tr>
<td>Cmd-&quot;-&quot;</td>
<td>Zoom Out.</td>
</tr>
<tr>
<td>Opt and mouse wheel</td>
<td>Zoom in or zoom out.</td>
</tr>
<tr>
<td>Cmd-'</td>
<td>Show the floor plan at 100%.</td>
</tr>
<tr>
<td>Cmd-M</td>
<td>Minimize the active window.</td>
</tr>
<tr>
<td>Cmd-W</td>
<td>Close the active window.</td>
</tr>
<tr>
<td>Cmd-Ctrl-F</td>
<td>Enter or exit the full screen mode.</td>
</tr>
<tr>
<td>Cmd-,</td>
<td>Bring up the application Preferences dialog.</td>
</tr>
<tr>
<td>Cmd-R</td>
<td>Show or hide the rulers.</td>
</tr>
<tr>
<td>Cmd-\</td>
<td>Switch from 2D to 3D view and vice versa.</td>
</tr>
<tr>
<td>Cmd-I</td>
<td>Open or close the Inspector window.</td>
</tr>
<tr>
<td>Cmd-E</td>
<td>Open or close the Environment window.</td>
</tr>
<tr>
<td>Cmd-Opt-S</td>
<td>Show or hide 3D rendering statistics.</td>
</tr>
<tr>
<td>Cmd-0</td>
<td>Fit the floor plan to the 2D window.</td>
</tr>
<tr>
<td>Space-Drag</td>
<td>Scroll the 2D view using the mouse. This way you can use the pan tool without deactivating the currently active tool.</td>
</tr>
</tbody>
</table>

### Working with the Mouse

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd-Mouse</td>
<td>Turn the snap mode on or off in the 2D view.</td>
</tr>
<tr>
<td>Option-Mouse</td>
<td>Duplicate objects in the 2D view.</td>
</tr>
<tr>
<td>Shift-click</td>
<td>Select/deselect the object without changing the selection of other objects (can be used for multiple selection).</td>
</tr>
</tbody>
</table>

**Walking and Looking Around in 3D view**

| Up Arrow (or W) | Move forward. |
| Down Arrow (or S) | Move backward. |
| Left Arrow | Turn to the left. |
| Right Arrow | Turn to the right. |
| Cmd-Up Arrow (or Q) | Tilt the camera up. |
| Cmd-Down Arrow (or Z) | Tilt the camera down. |
| Option-Up Arrow (or E) | Move the camera up. |
| Option-Down Arrow (or C) | Move the camera down. |
| Option-Left Arrow (or A) | Move the camera leftward. |
| Option-Right Arrow (or D) | Move the camera rightward. |
| Space-Drag | Look around staying in the same place. |
| Space-Opt-Drag | Move around the point located in the center of the 3D view. |
| Cmd-Opt-[mouse scroll] | Move the camera up or down. |
| Opt-[mouse scroll] | Move the camera to or away from the center of the screen. |

**Moving Objects in the 3D View**

| Cmd-Drag | Move an object with temporarily disabled the Glue By option. It is used to rip an opening out of the wall. The object moves horizontally. |
| Cmd-Otp-Drag | Move an object with temporarily disabled the Glue By option. It is used to change the object elevation. |

* Drag means you move the mouse pressing down the right key.*
Using Trackpad Gestures in the 3D View

<table>
<thead>
<tr>
<th>Gesture Description</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll up or down with two fingers</td>
<td>Move the camera forward or backward horizontally.</td>
</tr>
<tr>
<td>Scroll left or right with two fingers while holding down Cmd</td>
<td>Rotate the camera left or right.</td>
</tr>
<tr>
<td>Scroll left or right with two fingers while holding down Shift</td>
<td>Move the camera leftward or rightward.</td>
</tr>
<tr>
<td>Rotate with two fingers</td>
<td>Rotate the selected object.</td>
</tr>
<tr>
<td>Pinch with two fingers</td>
<td>Zoom in or out at the cursor position.</td>
</tr>
<tr>
<td>Scroll up or down with two fingers while holding down Opt-Shift</td>
<td>Tilt the camera up or down.</td>
</tr>
</tbody>
</table>

Using Trackpad Gestures in the 2D View

<table>
<thead>
<tr>
<th>Gesture Description</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll with two fingers</td>
<td>Scroll the 2D view.</td>
</tr>
<tr>
<td>Rotate with two fingers</td>
<td>Rotate the selected object.</td>
</tr>
<tr>
<td>Pinch with two fingers</td>
<td>Zoom in or out at the cursor position.</td>
</tr>
</tbody>
</table>
Chapter 3: Getting Started

Setting Up the Program after Installation

Register Live Interior 3D

Register the program if you have purchased a license code. Otherwise, the program will work in the demo mode.

To do this, choose Live Interior 3D Pro > Licenses... menu item to open the registration dialog box. Input your name and your license code.

Set Up the Program Preferences

Check out the program Preferences (Cmd-,) where the application settings are located.

Below, you will find brief information that is important when you start using the program. For details, see Chapter 2: "Live Interior 3D Workspace" > "Program Preferences".

The New Project Tab

Settings in this tab are used for the creation of new projects. To adjust the current project, use File > Project Setup.

Set up Measurement Units.

Other settings can be left unchanged.
The 3D Settings Tab

3D settings affect the quality and speed of rendering a picture in the 3D view.

It is not recommended that you change these settings the first time.

Try walking around in the 3D view. If you feel that your computer renders the scene quickly enough, try to deselect the **Decrease Quality when Moving** check box. In this case, the picture quality will not become low when you are moving.

The Trimble 3D Warehouse™ Tab

Options in this tab control import of Trimble SketchUp™ objects.

Keep them in the default state.

The Miscellaneous Tab

Keep the **Show Assistant on start-up** check box selected if you want the *Assistant* to open and display sample projects when you launch the program.

For better computer performance, don’t turn on the **Animate Library 3D Preview by default** feature.
Project Design Workflow

The majority of your work can be done in the 2D view. The 3D view is usually used in the middle and at the end – basically, to choose materials, match colors, adjust light and, finally, take pictures of your interior design.

Live Interior 3D designs are made up of objects: walls, floors, ceilings, openings, furniture, lighting sources, etc. You can draw basic objects like walls, floor and ceilings by using the corresponding tools in the 2D view. More complicated objects can be taken from the built-in library.

You can add, delete, move, resize objects and apply materials (textures) to them.

The major steps of the design process are as follows:
1. Opening or creating a project
2. Setting up the project
3. Drawing walls
4. Adding floors and ceilings
5. Adding doors and windows
6. Adding furniture and other objects
7. Setting up the lighting
8. Applying materials to objects
9. Adding cameras
10. Printing a 2D plan, taking pictures in the 3D view, creating QTVR and movies

Actually, the order of the steps may be altered, as the design process usually consists of iterations. Some steps may be omitted. For example, you can draw all the walls, insert all the furniture, and then change their materials. Or you can change materials right after adding a new object.

If you are creating a multi-floor building, you should add more storeys and repeat steps 3 – 10 (all or some of them) for each storey.
Quick Start Guide

Opening or Creating a Project

Before you start working, you should open an existing project or create a new one.

To create a new empty project, use the File > New menu command.

To create a project using a template, use the Assistant (File > New from Assistant).

To open an existing project, open the necessary file by double-clicking on it in Finder. Another way is to use the File > Open menu command or choose your project from the File > Open Recent list.
Drawing Walls

Usually, you start your project by adding outer walls and drawing interior walls.

The wall height (actually the whole storey height) can be set in the Building Properties tab of the Inspector window.

**Drawing a Single Wall Segment**

1. Open the 2D view window (View > Toggle 2D/3D View).

2. Select the **Straight Wall** tool in the toolbar.

3. Click with the mouse in the layout where the wall should begin, then move the mouse where the end should be located.

   When you move the mouse, thus creating a wall, it snaps to the existing objects and to the guides at angles of 0, 45, 90, ... degrees (by 45-degree increments). Smart guides will be shown to align the wall with other objects more accurately.

   The information bar above the horizontal ruler shows the wall length as you draw. If the ruler is not shown, press **Cmd-R**.

4. Double-click where the wall end should be located.

**Removing a Single Wall Segment**

To remove a wall segment, select it by clicking on it and press the **Backspace** (or **Delete**) key.

**Resizing a Single Wall Segment**

To resize a wall segment, select it and drag a handle on its end.

The length and thickness of the wall can be changed in the **Object Properties** tab of the Inspector window.
Drawing a Room

1. Open the 2D view window (View > Toggle 2D/3D View).

2. Select the **Straight Wall** tool in the toolbar.

3. Click with the mouse in the layout to start drawing a wall. Move the mouse pointer and click to specify a corner.

   Every click will specify the end of the current wall segment and start another one.

4. Add two more corners.

5. Click on the free end of the first segment to set the end of the last wall. The program will make the room outline closed and quit the wall drawing mode.

6. If you need to resize the room, select one of its walls and drag it with the mouse.

1 – First click

2 – Second click (making a corner)

3 – Third click (another corner)

4 – Current position of the mouse pointer

5 – Fourth click (one more corner)

6 – Final click
Before you start drawing walls, set the wall parameters in the *Object Properties* tab of the *Inspector* window. You can also choose “Master Walls” (wall templates) in *Inspector*.

To move a wall, select it and drag it with the mouse.

To apply a material to the wall, drag the material from the *Materials* tab of the *Inspector* window and drop it onto the wall.

To stop drawing a wall segment, press the **Esc** key.
Using a Floor Plan Created in Another Program

You may already have a floor plan drawn on paper or in another design software. It is possible to use this floor plan when working in Live Interior:

1. Make a graphic file of your floor plan. Scan it if it is on paper. Save it as an image if it is saved as a project from another application.

   The most preferable is PDF format. GIF and JPEG are also supported. TIFF will work, but it is not recommended because of the large file size.

2. Insert the image in a new project using the Insert > Image menu. It is better to do this after adjusting the project settings.

3. Resize the image to fit the current project scale.

4. Select the image and lock it in the Project Tree to prevent occasional displacement.

To lock any object, select it in the view, then open the Project Tree (Window > Project Tree), and click the lock icon near the name of this object (this object is selected in the Project Tree).

1 - Unlocked image.
2 - Locked image.

5. Outline the walls (shown on the plan) and place openings, light sources and furniture (if their positions are marked on the floor plan).
**Drawing an Interior Wall**

One or both ends of an interior wall may be joined with existing walls.

1. Open the 2D view window (View > Toggle 2D/3D View).

2. Select the **Straight Wall** tool in the toolbar.

3. Click the desired location on the outer wall to start drawing an interior wall.

4. Click on the opposite outer wall to place the end of the interior wall.

5. If necessary, adjust the location of the interior wall by dragging it with the mouse.

The joint between the interior wall and the outer wall divides the outer wall into two parts.

1 – First click
2 – Current position of the mouse pointer
3 – Final click
Adding Floors and Ceilings

The program adds the floor and the ceiling automatically when several wall segments make a closed shape. So usually you do not need to add floors and ceilings manually.

To draw floors and ceilings by yourself, use the corresponding toolbar buttons in the 2D view:

1. Open the 2D view window (View > Toggle 2D/3D View).

2. Select the Floor or Ceiling tool in the toolbar.

3. The floor or ceiling shape will be determined by its corners. Click with the mouse in the layout to specify a corner, then click where the next corner should appear on the floor plan, and so on.

   When you move the mouse pointer, thus drawing a wall, it snaps to the existing objects. Smart guides will be displayed to align a floor or ceiling with other objects more accurately.

4. Double-click on the floor plan where the last corner should be located.
Adding Doors and Windows

You do not need to leave gaps in the wall for future doors or windows; the program will do this automatically when you drop a window or a door onto the wall.

1. Open the Building Elements tab in the Library panel (Window > Library > Building Elements).

2. Choose Doors or Windows from the drop-down list.

3. Drag the desired door or window onto the wall.

4. Adjust the location of the door or window by moving it along the wall.

5. Adjust the parameters of the door or window by using controls in the Object Properties tab of the Inspector window.
Adding Furniture

In this example, you will add a wardrobe from the built-in object library and adjust its size and location.

Adding a Wardrobe

1. Open the Furnishing tab of the Library panel.

2. Type “wardrobe” in the search box and press the Return key.

3. Choose one of the displayed wardrobes and drag it into the project layout (the 2D view should be open).

Another way to find a piece of furniture is to open the Library (Window > Library > Furnishing), select the corresponding category in the drop-down list and look through the thumbnails.

Changing the Size of the Wardrobe


2. Unlock the Width, Depth and Height controls by clicking the lock icon next to them.

3. Enter the desired dimensions.

Moving the Wardrobe to the Right Place

1. To make the wardrobe snap to walls, set the Glue By option in the Object Properties tab of the Inspector window. Then, select the Bottom and Back check boxes.

   Selecting the Bottom option prevents the object from hovering above the floor.

2. If you need to turn the wardrobe, use the Rotate control in the Inspector (Window > Inspector > Object Properties).

3. Use the mouse to move the wardrobe into the proper position.
Working with Materials

The objects supplied with the program have default materials. The object’s material determines its color and also the light dissipation and light reflection characteristics. Usually, several materials are used in one object.

When creating a specific interior design, you may want objects in your design to have the same color or finish.

In our example, you will change the materials of a sofa and then copy them to an armchair.

Changing a Material of the Sofa

1. Open the **Furnishing** tab of the object library. Select the **Sofas** category from the drop-down list. Drag the “California VZ” sofa to the project layout.

2. Open the 3D view.

3. While the sofa is selected, open the **Materials** tab in the **Inspector** window. All the materials used in the sofa are shown in the **Object’s Materials** box (the upper one).

4. Select “Wood/ArchiBase_Cherry” in **Object’s Materials**.
5. Open the *Wood* category in the *Materials Gallery*, scroll down and click to select “026 Sharp Oak”. It will replace the previously used material of the sofa.

### Copying the Wood Material from the Sofa to the Armchair

1. From the *Armchairs* category (*Furnishing* tab of the *Library* panel), drag the “California” armchair to the project layout and let it remain selected.

2. Open the 3D view.

3. Select “Wood/ArchiBase_Cherry” in the *Object’s Materials* box of the *Inspector* window (*Materials* tab). We want to replace this material with the one used for wooden parts of the sofa.

4. Click on the **Material Picker** tool to activate it (the mouse pointer will change).

5. Now we want to pick the material used for the wooden parts of the sofa.

   With the **Material Picker** tool, click the sofa to pick one of its materials, and repeat the clicks as necessary to go through its other materials, one at a time.

   Each time, the material picked will replace the selected material of the armchair. Make sure that you picked “Wood/026 Sharp Oak”.

6. Click on the **Material Picker** tool again to deactivate it.

   To apply a material to the walls, ceiling and floor, drag this material onto the object in the 3D view.
Chapter 3: Getting Started

Working with Cameras

Walking in the 3D view allows you to get to any place within your 3D space. Placing cameras, you can specify one or many locations in the 3D space and then quickly jump to any of them at any moment.

By default, five cameras are set up in the project.

The cameras are listed in the Cameras Properties tab of the Inspector window.

Suppose you want to take pictures of the room from three points, change the color of walls or furniture, and then compare the pictures to choose the best color. In this case, you will put three custom cameras in the desired locations, change the wall color, you just select a camera from the list, and save a picture.
To add a camera:

1. Open the 2D layout.

2. Choose the **Camera** tool in the toolbar.

3. Click on the point on floor plan where a new camera should be located.

4. The camera object has handles (green dots) when selected. Drag one of them to change the location and orientation of the camera.

The selected camera moves along your walk in the 3D view. So walking is another way to point the camera in some direction.

Unnecessary cameras can be **removed** in the same way as ordinary objects in the 2D view.
Chapter 3: Getting Started

Setting Up the Lighting

The program lets you use several kinds of light sources: sunlight, light from electric lamps and open fire.

You can manage light sources in the current project using the Lights Properties tab of the Inspector window. All the light sources are listed here.

*Daytime* has four predefined states. To choose one, click a corresponding button in the Inspector: *Day*, *Evening*, *Night* or *Morning*. The other button lets you choose the time you prefer.

![Inspector window with Lights tab]

Electric light sources are under your control. You can add, move and delete them from the layout. Also, you can use the Inspector window to set their luminosity and color.

**To add a lamp:**

1. Open the *Furnishing* tab of the *Library* panel.
2. Select the *Lamps* section in the drop-down list.
3. And finally, drag a lamp into the 2D view.

Lamps must have the **Glue By** option selected in the *Object Properties* tab in the *Inspector*. Set the lamps to stick to the ceiling (*Top*) or wall (*Back*). Lamps that stand on the floor or on a table should have the **Glue By** option set to *Bottom*. The **Glue By** option lets you move the lamp in 3D without detaching it from the selected surface.

To change the luminosity and color of a lamp, select it and adjust its parameters in the *3D Window Properties* tab of the *Inspector* window. You can also switch any lamp on or off.

To switch light sources on or off, click the bulb icon in the *Lights* list in the *Lights Properties* tab of the *Inspector* window.
Printing a Floor Plan

To print a floor plan, use the Print command from the File menu.

To export a floor plan to a graphic file:

1. Choose the Export 2D Plan command from the File menu.

2. Select the file format. Some graphic formats have adjustable export parameters.

3. Choose where to save your file, enter a file name and click the Save button.

The printing scale will be taken from the scale that is set in File > Project Setup (the Measurements section).

Before printing the layout, you may want to add measurements or some text to it. Choose Insert > Measurement or Insert > Text Annotation for this.

Taking Pictures of the 3D View

1. Choose a point from which the picture will be taken.

To do this, walk to some point in 3D. If necessary, adjust the camera position and orientation using the Walk control located at the bottom of the 3D window.

To make it visible all the time, choose View > Display 3D Walk Control > Always.

2. Choose the Export 3D View command from the File menu.

3. Select the file format. Some graphic formats allow setting export parameters.

4. Choose where to save the picture, enter a file name and click the Save button.

Note: All objects in Live Interior 3D have the Visibility option in the Project Tree in the Library panel. If you don’t want an object to be shown in the 3D view or on the floor plan, make the object invisible. To do this, select the object and click the eye icon in Project Tree.
Creating a Movie Track in 2D

We are going to create a movie track with straight segments. An L-shaped movie track will lay along two guidelines.

1. Choose the **Movie Track** tool in the tool bar.

2. Place the cursor over the point where the movie track should begin.

3. Press the mouse button and don’t release it.

   Now a movie camera has been added and it is rotating in the direction of the mouse.

   Change the direction of the camera (it should be pointed along the horizontal guide line rightwards, in this example). When done, release the mouse button. You can adjust the orientation of the camera later.
4. Move the cursor to a new position for adding the second camera.

5. Click on the floor plan to add a new camera. After adding the second camera, don’t move the mouse (see the next step).

6. Now, the movie track should turn right. To force the existing track segment to stay straight, we will use the Opt key. When it is pressed, the existing part of the movie track keeps the shape constant while you are moving around the Movie Track tool. Press Opt before you move the cursor.

Point with the mouse at a new camera location and click.

Don’t release the Opt key, because we do not want the previous track segment to change its shape.
7. Move the cursor to the location of the end point of the movie track. Double-click to add the final camera. Then release the **Opt** key.
Video Tutorials

In order to help you make your first steps in Live Interior 3D, the developer offers video tutorials. These short videos describe how to do some particular tasks. Watching the tutorials, you will also learn the program interface.

To bring up the window with the video tutorials, select Help > Video Tutorials.

To view the video tutorials, Internet connection is required.

All tutorials are in English.

An alternative way to view the tutorials is to go to the developer’s web site: http://www.belightsoft.com/products/liveinterior/screencasts.php
Chapter 4: Working with Projects

What is a Project?

A Live Interior 3D project is a computer file in a special format which is used to save your work. This file stores the floor plan drawing, used 3D models, materials, etc.

A Live Interior 3D project is based on the 2D layout of a building. The floor plan shows walls, windows, doors and furniture (objects).

The project stores various project settings (they can be modified in the Project Setup dialog).

The program can create a 3D representation of your project layout. The 3D view is available at any moment of the design process.

You can modify the project by editing the layout in the 2D as well as in the 3D representation.

An easy way to start with the program is to open one of the sample projects by using the Assistant.
Creating and Opening Projects

To create a new empty project, use the **File > New (Cmd-N)** menu command.

Default settings of a new project correspond to the program **Preferences (Cmd-"","")**. They can be modified later in the **Project Setup** dialog.

A typical project design sequence is described in **Chapter 3: "Getting Started" > "Project Design Workflow"**.

To create a project from a template, use the **Assistant**.

By default, the **Assistant** opens on start-up. To change this, use the **Show Assistant on start-up** option in the **Miscellaneous** tab of the program **Preferences** dialog (**Live Interior 3D Pro > Preferences**).

Another way to open the **Assistant** is to use the **New From Assistant (Cmd-Shift-N)** command from the **File** menu.

To open a project located on your hard drive, double-click on it in the Finder.

Another way is to use the **File > Open** menu command or choose your project from the **File > Open Recent** list.
Project Setup

To access the project settings, choose the **File > Project Setup** menu command.

The settings are grouped in the following tabs:

- **Project Info** – You can type the author’s name, copyright information and project description to save together with the project.

- **Measurements** – Here you can choose measurement units for your project.

  The **Suppress Units** check box lets you hide measurement units in the 2D layout (you will see 40’ 00.0” instead of 40’ 00.0” ft, or 2.6 instead of 2.6 m).

  You can set the scale for your project (a predefined or custom one). “1:100” means that a one meter distance will be one centimeter on the screen. Also, you can specify the scale as “1/4 in : 1 ft”. The default measurement values are taken from the New Project tab of the program Preferences.

  The upper left corner of the rulers shows the current measurement units. For quick access to the Measurements section of the project settings, click in the corner where the current measurement units are displayed.

- **Preview** – You can choose an image that will be shown for the preview in the Finder when your project file is selected.
Saving Projects

To save your project, use the File > Save menu command or the Cmd-S shortcut.

You have the option to save your project in the Mac OS native bundle format (.li3d), or in the compressed format (.lizd). The bundle format includes a Quick Look preview that makes it useful on the Mac OS platform. In the compressed format, your project is a regular file (not a bundle). This format should be used for emailing, sharing over the Internet, or backing up to a non-Mac OS network drive.

All the materials used in the design are saved in the project file. This guarantees that your project will look the same way on other machines with Live Interior 3D installed.

If you plan to view the project on a computer where Live Interior 3D is not installed, save the 2D and 3D views as graphic files.

For more information, see Chapter 4: "Working with Projects” > “Printing”.

Saving Templates

To save your project as a template, use the File > Save as Template menu command. Templates are saved only in the compressed format (.lizd).

Once you have saved a custom template, the program doesn’t retain the link between the open project and this template. To update the template after modification, select it in the Save As Template dialog to overwrite.
Chapter 4: Working with Projects

The Project Tree

The Project Tree is a list of objects that have been added to the current project. To open it, choose Window > Project Tree.

1 – The floor selector. You can choose to display objects located on one floor or on all the floors.

2 – An object. Clicking an item in the list, you will select the object in the list and in the 2D and 3D views.

3 – Sub-items of an object. Click on the triangle to show or hide an object’s sub-items.

4 – The Visibility option. Click on the icon to hide or show an object in the project.

5 – The Lock option. Click on the icon to prevent the occasional changing or moving of an object.

6 – Turn on/off the preview animation mode.

7 – Zoom in or zoom out the preview.

8 – Show or hide the preview box.

9 – The preview box displays the preview of the object selected in the Project Tree. If a camera or movie camera is selected, you can see here the view produced by this camera.

Objects get a default name when you add them to the project. For example, all wall segments are named “Wall”. If you need to distinguish objects of the same type, assign different names to them. To change the name, double-click it on in the Project Tree.

The objects are grouped by type.

The Project Tree can display items on a selected floor or all items in the project. When all floors are displayed in the Project Tree, floors and slabs are at the top. Walls, windows, furniture, etc. are sub-items of the corresponding floors.
When you select an object in the 2D or 3D view, it gets selected in the **Project Tree**, and vice versa.

If you need to select all objects of the same type, it is easier to do this in the **Project Tree**.

In the **Project Tree**, the objects have two controls:

- **Visibility** – clicking the eye icon makes the selected object visible or invisible in the 2D and 3D views.

- **Lock** – if the object is locked, it cannot be moved or modified.

A locked object cannot be selected by clicking on it in the 2D or 3D view.

These settings can be modified for several objects by a single click when those objects are selected in the list (multiple selection is possible).

Some objects may contain their parts shown in the list as sub-objects. For instance, a door object has a door frame and a door itself. Their parameters may be changed separately. A wall object contains crowns and bases on both sides.

To bring up the context menu, right-click on an object. Most commands are the same as in the context menu in the 2D view. In addition to those, you will find **View In 3D**. Use this command to find objects in the 3D view.
The Environment Panel

The *Environment* panel lets you set up the geographic orientation of the building, time of day and cloudiness. All this affects the 3D scene illumination intensity.

To open the panel, choose **Window > Show Environment** or press **Cmd-E**.

**Daytime & Weather**

Choose daytime. Four buttons (1) set predefined time (6:00, 12:00, 18:00 and 24:00). The last button lets you set your own time. To do this, use the numeric time control (3) or turn the hour hand on the clock (2) with the mouse.

To vary cloudiness, use the slide bar (4).

**Geographic Location**

Rotate the compass (6) with the mouse to change the geographic orientation of the floor plan. The compass icon on the floor plan, if it is enabled by the check box (7), will reflect the selected direction.

The **Latitude** parameter (5) defines how high the sun is at any particular time of day.
Exporting the Floor Plan

To save your 2D layout as a graphic file, select File > Export 2D Plan. The following formats are available: PDF, BMP, TIFF, JPEG and PNG.

The scale of the exported floor plan is the same as the scale specified in the Measurements section of the project settings (see Chapter 4: "Working with Projects" > "Project Setup").

If you need more control over the export layout, you can save your floor plan to a PDF file using the printing procedure. In the system print dialog, choose PDF > Save as PDF.
Chapter 4: Working with Projects

Exporting 3D Views to Graphic Files

To take a picture of the current 3D view:

1. Open the 3D View.

2. Make the 3D View display the picture you want to shoot.
   
   To do this, choose the camera pointing in the necessary direction in the Camera list (Inspector window, the Cameras Properties tab). Or, use the walk controls and camera orientation tools to position the current camera.

3. Choose the File > Export 3D View menu item, or click the camera icon in the 3D toolbar.

4. Choose the image format and size.
   
   You can choose one of the following graphic file formats: BMP, TIFF, JPEG, PNG. Graphic formats with compression let you choose better quality or better compression.

5. Type a file name and click Save.

After an image is saved, the program offers to show you a preview of it.

To print the 3D view, open the exported picture in the Preview application and print it (File > Print).

Exporting 3D Views to QuickTime VR (QTVR)

QuickTime VR (virtual reality) format lets you save a panoramic view of your project from the point where you are “standing” in 3D. Then you can open the exported file in QuickTime and look in any direction.

To export to QTVR:

1. Open the 3D View.

2. Walk to the central point of your panorama.
   
   To do this, choose the camera located at the desired point from the Camera list (Inspector window, the Cameras tab).

   Or, use the walk controls to navigate to the necessary point.
3. Choose the **File > Export 3D View** menu item, or click the camera icon in the 3D toolbar.

4. Choose QTVR format. Then select the size and quality.

5. Type a file name and click **Save**.

After a QTVR file is saved, the program offers to show a preview of it.

### Exporting to the 3D File Format

You can export to the following formats:

- Trimble SketchUp (*.skp).
- VRML Version 2.0 (*.wrl).
- X3D (*.x3d).
- RenderMan (*.rib). This format is used to transfer your 3D scene to and export photorealistic images in 3Delight.
- Collada (*.dae). This format is used to transfer your project to other 3D editing programs (3DS Max, Maya, Cinema, Strata, Shade and others). The list of applications that support Collada can be found on the Collada web site.
- Render Boost (*.lga).

### Trimble SketchUp

1. Choose what you want to export.

   To export an object, select it in the project.

   To export a floor, activate it in the *Building Properties* tab of the *Inspector*.

   To export the entire project, you don’t have to select anything particular.

2. Choose **File > Export To...** in the menu.

3. Select *Trimble SketchUp (*.skp)* in the **Save As Type** drop-down list.

4. In the *Export* section, choose what you want to export (an object, a floor, entire project).

5. Select the version of the SketchUp format.
6. To simplify the object before exporting it, select the *Merge coplanar triangles* check box. To keep all the details, keep the check box deselected. This option does not affect the object in the Live Interior 3D project.

7. Type a file name and click **Save**.

**VRML Version 2.0 and X3D**

1. Choose what you want to export.

   To export an object, select it in the project.

   To export a floor, activate it in the *Building Properties* tab of the *Inspector*.

   To export the entire project, you don’t have to select anything particular.

2. Choose **File > Export To...** in the menu.

3. Select **VRML Version 2.0 (*.wrl) or X3D (*.x3d)** in the **Save As Type** drop-down list.

4. In the *Export* section, choose what you want to export (an object, a floor, entire project).

5. Type a file name and click **Save**.

**RenderMan**

1. Choose **File > Export To...** in the menu.

2. Select **RenderMan (*.rib)** in the **Save As Type** drop-down list.

3. Set up the size and quality of the image you wish to render.

4. Specify whether you wish to export the terrain using **Export Terrain** and sky using **Export Background**.

5. Type a file name and click **Save**.
Collada

1. Choose what you want to export.

   To export an object, select it in the project.

   To export a floor, activate it in the Building Properties tab of the Inspector.

   To export the entire project, you don’t have to select anything particular.

2. Choose File > Export To... in the menu.

3. Select Collada (*.dae) in the Save As Type drop-down list.

4. In the Export section, choose what you want to export (an object, a floor, entire project).

5. Set up the export options.

   **Up Axis** defines the name of the vertical axis in the output file. If you don’t know the requirements of the software you will use to open the exported scene, keep the default state.

   Specify whether you wish to export the light sources, predefined and user cameras using the corresponding check boxes.

   Select **Fix Texture Coordinate** if textures with applied transformations look incorrectly in the software used to open the exported scene.

   Select **Copy Texture Images** to export all textures used in your 3D scene to a dedicated folder. Without this option activated, the textures from the texture library are used to render the scene. For this, Live Interior 3D must be installed to provide this library.

   **Relative Path to Texture Images** lets you choose either a relative or absolute path to the folder with exported textures created by activating Copy Texture Images. What you should specify depends on the software you will use to work with the exported scene.

6. Type a file name and click **Save**.
Render Boost

1. Choose what you want to export.

   To export an object, select it in the project.

   To export a floor, activate it in the Building Properties tab of the Inspector.

   To export the entire project, you don’t have to select anything particular.

2. Choose File > Export To... in the menu.

3. Select Render Boost (*.lga) in the Save As Type drop-down list.

4. Select a radio button according to what you want to export: an object, a floor or the entire project.

5. Type a file name and click Save.
Printing

To print:

1. Choose File > Print (Cmd-P) to open the Print dialog.

2. Select a paper format. If several printers are installed in your system, select the proper printer before choosing the paper size.

3. Choose the paper orientation. If most of your 3D views or floor plans have horizontal orientation, activate the landscape mode.

4. Set up margins.

5. From the left panel, drag and drop 3D views or floor plans you wish to print onto the sheets. You can add as many sheets as you need.

6. Click Next to proceed to the system Print dialog. Set up the printing options.

7. Click Print to send your project to the printer, or click PDF > Save as PDF to export it as a file.
Chapter 4: Working with Projects

**The Print Dialog**

1 – Select the printer you are going to use. The list of compatible paper depends on the selected printer.

2 – Select a paper format. You can either choose a standard paper size or type in custom dimensions. All sheets have the same size.

3 – The thumbnails of all available 3D views and floor plans. To print, you need to drag them onto the sheets to the right. Each floor plan corresponds to one of the floors in your project. Each 3D view corresponds to one of cameras. If you need more 3D views, add more cameras.

4 – These are the sheets where you compose the printing layout. You can move the placed graphics around using the mouse. To resize a 3D view, select it and drag one of corner handles. To resize a floor plan on the selected sheet, change its **Sheet scale**. If needed, the program automatically increases the sheet size so that its content is laid out over several pages. After printing, you can glue the parts together.
5 – The zoom for the sheet preview. Additionally, you can right-click on the preview area and choose one of zoom options.

6 – Add new sheets.

7 – Remove the selected sheet. You cannot delete the last sheet.

8 – Select the page orientation here. All sheets have the same orientation.

9 – Margins help you define the amount of blank space along the page sides. Certain printers cannot print near the edges of the paper. You may need to increase the margins to meet the capabilities of your printer. By setting up margins, you can insure that no graphics appear in the unprintable area. All sheets have the same margins.

10 – Sheet scale controls let you set up the scale for floor plans on any sheet individually.
Chapter 4: Working with Projects

The Render Boost Plug-in

An alternative way to render a 3D scene is to use the Render Boost plug-in. It is powered by Lightworks Artisan software.

Once you install this plug-in, its controls appear in the main menu and tool bar.

The use of the plug-in is described in its own documentation. The page you are reading is aimed at explaining the integration between Live Interior 3D and the Render Boost plug-in.

Note that only one instance of the Render Boost plug-in can be opened at the same time.

System Requirements

- Live Interior 3D Pro or Standard Edition installed (App Store versions supported)
- Mac OS X 10.6.8 or later
- Intel only, 2 GHz processor
- 500 MB of free hard drive space
- 3D class Video Card with 256 MB, minimum OpenGL 1.4 (1 GB of memory, Unified Shader Model and OpenGL 2.0 support recommended)

Licensing

To obtain the all functionality of the plug-in, you need to purchase the license code. To input it, select Render Boost > License in the main menu, then fill in the Owner and License Code fields.

Opening the Current 3D View Right Inside the Plug-in

To render the current 3D view, you need to open it in the plug-in. You can send the 3D scene to the plug-in directly, or you can export all necessary information to a file, and later open it in the plug-in. The first method is preferred because it lets you modify your project in Live Interior 3D and instantly update the scene in the plug-in.

To export the scene directly, choose Render Boost > Render Scene... from the main menu, or click

in the 3D tool bar. Note that your project must be saved before exporting. This
is needed because the plug-in saves the settings for the scene in the same folder where project is located.

To update the scene in the plug-in, select **Render Boost > Render Scene...** again.

Opening or updating the 3D scene in the plug-in can take some time depending on the complexity of the project.

**Exporting the 3D View to the Render Boost Format**

1. Select **File > Export To...**
2. Set **Save As Type** to **Render Boost (*.lga)**.
3. Choose whether you wish to export: the selected object, the current floor or the entire project.
4. Click **Save**.

**Opening a 3D Scene From a File**

In Live Interior 3D, choose **Render Boost > Open File...**. Then select a *.lga file.
Creating Movies

You can create a movie as you walk through your 3D space. Live Interior uses the MOV file format to save movies.

If you need to create a panorama of the 3D space, see Chapter 4, “Working with Projects” > “Exporting 3D Views to QTVR”.

**Movie Track and Movie Cameras**

Movie creation begins with creating a movie track that is a path along which an imaginary video camera moves. You can place multiple movie tracks in your project. A movie track can be edited at any time. To create a movie, you should select a movie track and start the process by clicking the Record Movie button below the movie track list in Inspector > Cameras.

A movie track is made up of one or several straight or curved segments. The track runs over anchor points – movie cameras. End points of the movie track are also movie cameras. When you create a movie track, you place movie cameras in some key points in the 3D space. Intermediate points will be interpolated automatically according to a Bézier curve.

Movie cameras are represented on the floor plan by an icon with two triangles. Interpolated points are represented by a line. The arrows in the movie camera icon define the direction of camera movement along the path.

1 – The beginning of the movie track (the first movie camera)

2 – Movie track

3 – Intermediate movie camera

4 – The end of the movie track (the last movie camera)
Selecting a Movie Track

Ways to select a movie track:
- Click on a movie track in the 2D view.
- Click on a movie track in the Movie Track category in the Cameras tab of the Inspector window.
- Click on a movie track in the Auxiliary category of the Project Tree.

A selected movie track is highlighted on the floor plan by blue color.

Selecting a Movie Camera

To select a movie camera, click on it on the floor plan, or choose it in the list under the corresponding movie track in the Cameras tab of the Inspector window.

A selected movie camera may also define a point of view for 3D view as an ordinary camera. In this case, a viewing frustum (blue triangle) next to it displays the direction of the camera.

The preview in the Project Tree displays the view produced by the selected movie camera.
**Creation of a Movie Track in 2D**

A simplified process of creating a movie track is described below. A more detailed way can be found in Chapter 4: "Working with Projects" > "Creating and Modifying Movie Tracks in 2D".

1. Choose the **Movie Track** tool in the 2D toolbar.

2. Click on the floor plan where you want the movie track to begin (point 1 in the picture below).

3. Make more clicks to add more movie cameras to the current track (point 2 in the picture below).

4. Double click to place the last camera (point 3 in the picture below).

The location of movie cameras, the shape of track segments and the direction of cameras can be changed after creating the track.

**Important!**
The number of movie cameras depends on how curvy a movie track should be. A less curvy track requires less intermediate cameras. A straight track requires only two cameras at its ends. Do not add unnecessary intermediate cameras. Extra intermediate cameras are needed for a more accurate creation of a track with a complex shape.
**Creation of a Movie Track in 3D**

A simplified process of movie track creation is described below. A more detailed way can be found in Chapter 4: “Working with Projects” > “Creating and Modifying Movie Tracks in 3D”.

1. Walk to a point in 3D that should be the start point for your movie.

2. Open the Cameras tab of the Inspector and click the **Add Movie Track from 3D Viewpoint** button (3D view should be open). The icon of the button indicates the current mode.

   **Add Movie Track mode:**
   In this mode, clicking the button creates a new track and adds a new camera to it.

   The icon of the button will turn into the image below, indicating that new cameras will be added to the current track by clicking the button.

   **Add Movie Camera mode:**
   In this mode, clicking the button adds a new camera at the end of the selected track.

   Note: For creating a new track none of the existing movie tracks should be selected. To deselect a movie track in the Inspector, click the Movie Tracks title above the list of movie cameras.

3. Move in the 3D space to the next position. If necessary, adjust the orientation, tilt and elevation of the camera.

4. Click the **Add Movie Camera from 3D Viewpoint** button in the Inspector.

5. Repeat steps 3 and 4 to add more movie cameras.

**Adjusting a Movie Track**

You can change the shape of a track on the floor plan by:
- moving cameras to new places;
- changing the shape of track segments between movie cameras (location of cameras is unchanged).

To change the location of a movie camera, select a movie track and drag the camera to a new place.

To change the shape of a track segment without moving cameras, drag the camera control points around the corresponding camera.
You can see the view from any movie camera in the 3D view. To do this, select it in the Camera Properties tab of the Inspector. If you start walking around, the camera will change its location and direction correspondingly. This way you can adjust key points of the movie track.

A camera icon in the top-right corner of the 3D view appears when a movie camera is selected. This indicates that if you walk in 3D, its position will change.

![Camera Icon]

**Creating a Movie**

To create a movie from a movie track:

1. Select a movie track.

2. Click the Record Movie… in the Cameras Properties tab of Inspector.

3. Type the name for the new movie file and choose a folder to save it in.

4. Set up the movie properties.

   For better quality, choose higher resolution and frame rate. Note that setting high resolution or high frame rate produces movie files of a large size.

   Select a video codec. The H.264 codec provides better compression ratio (requires QuickTime 7 or higher to play back). Select it for smaller file size at the same movie quality. Prefer the MPEG-4 codec for compatibility with more types of video players.

   The Quality slide bar lets you change the compression rate. The higher quality you set, the lower compression rate is used.

5. Click Save.

After creating a movie, the program offers to play it.

*Tip:* Creating movies with a long track or with high resolution may take quite long. Choose minimum resolution and/or frame rate to create a preview movie. When you are sure that all the cameras are positioned well, create a movie of the desired quality.
**Looping Movies**

You can loop a movie track by placing the beginning and the end of the movie track at the same point. To do this, select a track, bring up its context menu and choose the *Loop Movie* item. Live Interior will automatically add a new track segment to close the track. If you deactivate the loop option, the added segment will disappear.

To play back such a movie, load it in QuickTime and select the **View > Loop** option in its menu. Then click the **Play** button.
Creating and Modifying Movie Tracks in 2D

A Simple Way of Creating a Movie Track

A simple way of creating a movie track is as follows:

1. Choose the **Movie Track** tool in the 2D toolbar.

2. Click with the mouse on the floor plan where you want the movie track to begin (step 1 in the picture below).

3. Make more clicks to add more movie cameras to the current track (step 2 in the picture below).

4. Double click to place the last camera (step 3 in the picture below).

The location of movie cameras, the shape of track segments and the direction of cameras can be changed after creating the track.
Setting the Camera Direction while Creating a Movie Track

The following method lets you point a new camera while adding it. Another way is to change the camera direction after the track is created.

The process of creating movie tracks is as follows:

1. Click the **Movie Track** tool in the 2D toolbar.

2. Place the mouse cursor on the floor plan where you want to place the first movie camera.

3. Press the mouse button (the left one for 2-button mice). Keeping the button pressed, move the mouse to change the camera direction. Then release the button.

4. Repeat steps 2 and 3 for adding more cameras.

5. After adding the last camera, press the **Esc** button.

The location of movie cameras, the shape of track segments and the direction of cameras can be changed after creating the track.
**Keeping the Last Segment Unchanged while Creating a Movie Track**

When you are moving the mouse cursor while adding a new movie camera (4 in the picture), two track segments, before and after the last added camera (2), change according to the location of the cursor (4). Segments (1) and (3) are straight. After the camera moves, they become curved (5).

Press the **Alt** key if you wish to keep the previously added segment unchanged while moving around a new movie camera to find a better place for it. This will force the previous segment (6) to freeze when a new segment (7) reshapes following the mouse cursor (new movie camera).

Follow the steps below:

1. Add one or multiple movie cameras.

2. Add another movie camera (2 in the picture) to your movie track by a click. Do not move the cursor until you press the **Alt** key.

3. Place the mouse cursor where you want to place another movie camera.

4. Click on the floor plan to place a new camera. Now you can release the **Alt** key, or keep it pressed to continue using the current mode.
Setting the Shape of the Current Segment while Creating a Movie Track

The following method lets you adjust the curvature of the last track segment while you are adding a new movie camera. Another way is to use the camera controls after the track is created.

The process of creating a movie track is as follows:

1. Add one or multiple movie cameras.

2. Click on the point on the floor plan where you want to place another movie camera, but do not release the mouse button.

3. Press the Alt key and move the cursor around the camera to adjust the shape of the track segment. The direction of the camera will stay constant.

4. Release the Alt key and continue adding new movie cameras, or finish the process by hitting the Esc key.

The location of movie cameras, the shape of track segments and the direction of cameras can be changed after creating the track.

Adding More Movie Cameras to an Existing Movie Track

To add a camera to the end of a movie track:

1. Select a movie track by clicking on it on the floor plan.

2. Click the Movie Track tool in the 2D toolbar.

3. Click on the last camera of the selected track.

4. Click somewhere on the floor plan to add new movie cameras.

Another way to continue adding cameras at the end of a movie track is to double-click the track in the 2D view. Then click on the floor plan to place new movie cameras.

To add a new movie camera before or after some specified camera on a movie track, select the existing camera, bring up the context menu and choose Add Movie Camera After or Add Movie Camera Before item.
Changing the Location of a Movie Camera

1 – Track segments
2 – Camera control points
3 – Selected camera
4 – Camera direction point

To change the location of a camera:

1. Click on a camera in 2D to select it.
2. Drag the handle (item 3 in the picture above) to move the selected camera to a new place.

Adjusting the Direction of a Movie Camera

You can change the direction of any movie camera after a movie track is created. To do this:

1. Click on a camera in the 2D view to select it.
2. Drag the camera direction handle (item 4 in the picture above) to rotate the selected camera.
Adjusting the Curvature of Movie Track Segments

To adjust the track segments (1) located next to a specific movie camera (3):

1. Click on a camera in the 2D view to select it.
2. Drag the camera control handle (items 2 in the picture above) to modify the shape of track segments.

Removing a Movie Camera

To remove a movie camera, select it on the floor plan by clicking the mouse and press the Del button.

Or, do the following:

1. Open the Cameras tab of the Inspector window.
2. Click the triangle next to the Movie Tracks category to expand it.
3. Expand some specific movie track to get all the included movie cameras displayed.
4. Select a camera and click the Delete button below the list of cameras in the Inspector (or hit the Del key).

Or, bring up the context menu for the selected movie camera on the floor plan and choose the Delete Movie Camera item.

Removing a Movie Track

To remove a movie track, select it on the floor plan by clicking the mouse (click on the line, not on a movie camera) and press the Del button.

Or, do the following:

1. Open the Cameras tab of the Inspector window.
2. Click the triangle next to the Movie Tracks category to expand it.
3. Select a specific movie track and click the Delete button in the Inspector (or hit the Del key).

Or, bring up the context menu for the selected movie track on the floor plan and choose the Delete Movie Camera item.
Creating and Modifying Movie Tracks in 3D

Creation of a Movie Track in 3D

1. Walk to the point in 3D that should be the start point for your movie.

2. Open the Cameras Properties tab of Inspector. The 3D view should be open for further operations.

   Make sure all the existing tracks in the list are deselected. To do this, click the Movie Tracks category title (1 in the picture).

3. Click the Add Movie Track from 3D Viewpoint button (2) in the Inspector.

   If Add Movie Camera mode is activated (in this case, the button icon looks like item 5 in the picture), which means an existing movie track is selected (see step 2).

   Clicking the Add Movie Track… button creates a new track with a new movie camera located at your current position in the 3D space.

4. Move in the 3D space to the next position. If necessary, adjust the orientation, tilt and elevation of the camera by using controls in the 3D toolbar.

5. Click the Add Movie Camera from 3D Viewpoint button (5) in the Inspector.

6. Repeat steps 4 and 5 to add more movie cameras.

The location and orientation of movie cameras can be changed later in the 3D or 2D view.
### Cameras

<table>
<thead>
<tr>
<th>1 Predefined Cameras</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="From Front" /></td>
</tr>
<tr>
<td><img src="image" alt="From Back" /></td>
</tr>
<tr>
<td><img src="image" alt="From Left" /></td>
</tr>
<tr>
<td><img src="image" alt="From Right" /></td>
</tr>
<tr>
<td><img src="image" alt="From Top" /></td>
</tr>
<tr>
<td>2 User Cameras</td>
</tr>
<tr>
<td><img src="image" alt="Movie Tracks" /></td>
</tr>
<tr>
<td><img src="image" alt="Movie Track" /></td>
</tr>
<tr>
<td><img src="image" alt="Movie Track 2" /></td>
</tr>
</tbody>
</table>

| 3 Export 3D View... |

---

### Cameras

| 4 Record Movie... |

---

| 5 Movie Track 2 |
| ![Movie Track 2](image) |

---

<table>
<thead>
<tr>
<th>6 Predefined Cameras</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="From Front" /></td>
</tr>
<tr>
<td><img src="image" alt="From Back" /></td>
</tr>
<tr>
<td><img src="image" alt="From Left" /></td>
</tr>
<tr>
<td><img src="image" alt="From Right" /></td>
</tr>
<tr>
<td><img src="image" alt="From Top" /></td>
</tr>
<tr>
<td>User Cameras</td>
</tr>
<tr>
<td><img src="image" alt="Movie Tracks" /></td>
</tr>
<tr>
<td><img src="image" alt="Movie Track" /></td>
</tr>
<tr>
<td><img src="image" alt="Movie Track 2" /></td>
</tr>
</tbody>
</table>
Changing the Location and Orientation of a Camera in 3D

1. Open the 3D view and the Cameras Properties tab of the Inspector.

2. Expand the corresponding movie track to see the list of included cameras. To do this, click a triangle next to the track name (4 in the picture).

3. Choose a movie camera. When you select a camera, the 3D view renders a picture taken by it. This helps you find the camera you need.

4. Use the walk controls in the 3D toolbar to adjust the location and orientation of the selected camera.

5. Repeat steps 3 and 4 to adjust more cameras.

6. When finished, deselect the current movie camera in the list by clicking on the Movie Tracks category title (1 in the picture), or on a blank line in the Inspector camera list.

Note, if you leave any camera selected and start walking in 3D, its location will change following your current position.

Adding New Cameras at the End of the Existing Track

To continue adding cameras to the end of the existing movie track:

1. Open the 3D view and the Cameras tab of Inspector.

2. Select a movie track in the list, not a camera.

3. Walk to some location to define the place for a new movie camera. Adjust its orientation if necessary.

4. Click the Add Movie Camera from 3D Viewpoint button (5 in the picture) in the Inspector.

5. Repeat steps 3 and 4 to add more cameras.

6. When finished, deselect the current movie camera in the list by clicking on the Movie Tracks category title (1 in the picture), or on a blank line in the Inspector camera list.

Note, if you leave any camera selected and start walking in 3D, its location will change to your current position.
Removing Movie Cameras or Tracks

1. Open the Cameras Properties tab of the Inspector window.

2. Click the triangle next to the Movie Tracks category to expand it.

3. Select a camera or track and click the Delete button below the list of cameras in the Inspector (or hit the Del key).

   To select a camera, expand some specific movie track to get all the included movie cameras displayed.
Chapter 5: Working with Storeys

Introduction

Live Interior 3D supports the creation of multi-storey buildings. A new project contains only one floor. You can add new floors above or below it.

All projects must contain a ground floor. When it contains multiple floors, any of them can be selected as the ground floor.

In the Project Tree, each floor is represented as a compound object that includes other objects – furniture, doors, windows, etc., located on this floor.

To control storeys, use the tools in the Building Properties tab of the Inspector.

Each storey includes a slab above it. This slab is invisible in the 3D view until you add the ceiling to the current storey or add the floor to the storey above.

In the 3D space, the elevation of an object is calculated in relation to the storey where the object is located. An object can be listed in the Project Tree among objects of one storey, but the object can appear in another storey in the 3D picture. This happens when the elevation of an object is greater than the storey height.
Managing Storeys in the Inspector

The *Building Properties* tab of the *Inspector* allows you to perform the following operations on storeys:

- Adding storeys
- Removing storeys
- Choosing the active storey
- Choosing the ground floor
- Changing the slab height
- Changing the storey height

**Inspector Controls**

1 – The elevation of the ground floor. Increasing this parameter elevates the whole building.

2 – The thickness of the foundation. If your building doesn’t have the basement, the Foundation parameter must be equal or greater than Elevation.

3 – The thumbnail of a floor.

4 – The thumbnail of the current floor has a blue frame. To select other floor, click on its thumbnail. The 2D view displays the floor plan of the selected floor.

5 – This icon identifies the ground floor. To change the ground floor, select another floor, and choose “Mark Storey as Ground” in the pop-up menu of button (7).

6 – Add a roof. By click on this button you add a roof above the current floor. If you click and hold the mouse button, the pop-up menu will open. This menu gives a choice to add a roof in the current floor or above it.

7 – Add a floor. By click on this button you add a floor above the current one. If you click and hold the mouse button, the pop-up menu will open. This menu gives a choice to add a floor above or below the current one, or to choose the selected floor as the ground floor.
Chapter 5: Working with Storeys

8 – Delete the selected floor.

9 – The slab thickness. Select a floor to change its slab thickness.

10 – The storey height. Select a floor to change its height.

Adding Storeys

To add a storey above the current one, click the button (7).

To add a storey below the current one, click and hold the button (7) until the pop-up menu is displayed. Choose Add Storey Below Current.

When you add a new storey, it becomes active automatically (its floor plan is displayed in the 2D view). The outer walls, floor and ceiling of the previously selected storey are being copied onto the new floor.

Removing Storeys

To remove the active storey, click the Delete Current Storey button (8) in the Inspector.

All the objects located on the removed storey will be removed too.

If you remove the ground floor, another floor automatically becomes the ground floor.

Choosing the Active Storey

The active (current) storey is the one whose floor plan is displayed in the 2D view. The active storey name is displayed at the bottom of 2D view. In the Inspector, the thumbnail of the active storey is highlighted.

To make another storey active, click on its thumbnail.

Choosing the Ground Floor

A new project has one floor by default. This floor is the ground floor. After adding more floors, you can choose any floor to be the ground floor. To do this, make that storey active. Click and hold the button (7) until the pop-up menu is displayed. Choose Mark Storey as Ground.
Changing the Slab Height

Use edit box or steppers (9) to change the slab height of the active storey.

Changing the Storey Height

Use edit box or steppers (10) to change the height of the active storey.
Storeys and the 2D View

The 2D view displays the floor plan of the active (current) storey.

To preview the outer walls of the storey above or below the current one, choose View > Show Storey Above Current or View > Show Storey Below Current.

Only one storey can be active in the 2D view at any time.

Using a Pop-Up Menu

In the left bottom corner of the 2D view, you can find a pop-up menu that lets you choose the active storey and perform operations on storeys.

![Pop-Up Menu]

- 1st Floor
  - Ground Floor
  - Add Storey Above Current
  - Add Storey Below Current
  - Mark Current Storey as Ground
  - Delete Current Storey
Chapter 6: Working with Roofs

Roofs in Live Interior 3D

A roof is a special object in Live Interior 3D. As well as walls, it is created inside the program (but it cannot be imported). When the program creates the roof it takes into account the original roof style (the template selected in the Roof Assistant) and the outline of the outer walls.

Any roof has several sides. Gables are also considered as sides. So, (1), (4) and (5) in the picture are roof sides. A roof side can have several segments. The side (1) has two segments: (2) and (3).

Roofs are listed in the Project Tree. You can select a roof or its parts in the Project Tree or in the 3D view.

A roof can be added to any storey that is entirely or partially under the open sky. Usually, a roof takes up the whole upper storey.

A roof may change its shape dynamically when you add, delete or resize walls or the floor. The height of the roof is not limited by the corresponding storey height.
To create a skylight, you can cut a window into the roof.

To apply a new material to the roof, drag the material from the library onto the roof in the 3D view. See Chapter 9: "Working with Materials" > "Applying Materials" for more details.

The Roof Types

The Roof Assistant in Live Interior 3D lets you choose one of the basic types such as gable, hip, mansard or other. A more complicated roof can be created by adding or deleting roof slope segments and by changing their angles. The properties of roofs are located in the Object Properties tab of the Inspector.

Using Panels, Openings and Niches with Roofs

To add a panel, opening, or niche to a roof, drag one from the object library onto the roof. Also, you can add any of those objects by using the editor of openings, niches and panels. To open the editor, right-click on the roof in 3D and select Edit Panels, Openings and Niches in the context menu. Panels can be used to create areas with different materials (colors) on the roof surface.
Adding and Deleting Roofs

The Roofing Assistant

The Roofing Assistant helps you add a standard roof to your building.

1 – Roofing templates.

2 – Magnification slider.

3 – Soffit type. You can also change it in the Object Properties tab of the Inspector.

4 – Preview of your project with the added roof. You can rotate the picture with the mouse.

5 – Roof orientation. You can turn the roof in 90 degree increments.

6 – Zoom and live rotation controls for the preview.
Adding a Roof

To add a roof together with a new storey:

1. Select the upper storey of your building (1) in the Building Properties tab of the Inspector.

2. Click button (2) in the Inspector to open the Roofing Assistant.

   The following steps are to be made in the Roofing Assistant described above.

3. Click on a roofing thumbnail (1) to select the roofing type.

4. Set up the Roof Orientation (5).

5. Choose the type of the soffit (3).

6. Click the OK button.
To add a roof in the current storey:

1. Select a storey (1) in the Building Properties tab of the Inspector.

2. In the Inspector, click button (2) and hold it to have the pop-up menu open.

3. Choose Add AutoRoof on the Current Storey (3) to open the Roofing Assistant.

   The following steps are to be made in the Roofing Assistant described above.

4. Click on a roofing thumbnail (1) to select the roofing type.

5. Set up the Roof Orientation (5).

6. Choose the type of the soffit (3).

7. Click the OK button.

Once a roof is added, you can change its properties using the Inspector.

After a roof has been added, the corresponding button in the Inspector changes its function from adding to removing.

**Deleting a Roof**

To delete a roof:

1. In the Building Properties tab of the Inspector, select the storey where the roof is located.

2. Choose Edit > Building > Remove AutoRoof from the Current Storey.

To delete a roof together with the storey, in the Building Properties tab of the Inspector:

1. Select the storey.

2. Click the Delete Current Storey button.
Roof Properties

The tools located in the Object Properties tab of the Inspector let you change the style of a roof. To change the materials of a roof, use tools in the Materials tab of the Inspector.

1 – The type of the soffit. You can choose either basic, simple, horizontal, or box end soffit.

2 – The elevation of the roof in relation to the floor level.

3 – The maximum size of the fascia.

4 – Switch to another roof side.

5 – The list of segments of the selected roof side and parameters of each segment.

6 – Add a roof segment above the selected one.

7 – Add a roof segment below the selected one.

8 – Delete the selected roof segment.

9 – The roof segment type. Slope creates a tilted segment. Gable makes the segment vertical. Hole makes the selected segment disappear.

10 – The angle of the selected roof segment. You can adjust the angle of Slope segments only.

11 – The height of the selected roof segment. Note that you cannot modify the height of the uppermost or a sole segment.

12 – The thickness of the selected roof segment.

13 – The overhang distance of the selected roof segment.
Modifying the Style of a Roof

You can modify the style of a roof using the tools in the *Object Properties* tab of the *Inspector*.

The examples below show how to modify a gable roof to gambrel, hip, and shed roof. All of these roof styles are standard and can be created using the *Roofing Assistant*. The goal of the steps below is to demonstrate the use of the tools in the *Inspector*.

To select the sides of a roof and preview the result of your actions, open the 3D view.

Modifying a gable roof to a gambrel roof:

1. Select a roof slope.

2. In the *Inspector*, click the *Add Segment Below Selected* button (7).

3. Change the angle (10) of the lower segment to 60°.

4. Adjust the height (11) of the lower segment if necessary.
5. Repeat steps 1–4 with the other roof slope.

Modifying a gable roof to a hip roof:

1. Select a gable and change its angle (10) to 45º.

2. If necessary, adjust the overhang distance (13).

3. Repeat steps 1 and 2 for the other gable.
4. Change the material of new slopes using the **Material Picker** located in the *Materials* tab of the *Inspector*.

Modifying a gable roof to a shed roof:

1. Select a roof slope and change its type to *Gable*.

2. Select the other roof slope and change its angle (10) to 10º.

3. If necessary, adjust the overhang distance (13) and thickness (12) of the roof slope.
4. Change the material of new slopes, using the **Material Picker** located in the *Materials* tab of the *Inspector*.
Adding a Skylight to the Roof

To create a skylight, drag a window from the object library (Window > Library > Building Elements) and drop it onto the roof. It is easier to position a skylight in the 3D view. The 2D view can be used to align already added skylights.

This way you can also add an opening, niche or panel. The editor of openings, niches and panels lets you customize these objects.
Adding a Dormer Window

To add a dormer window, drag it from the Dormers category in the Building Elements section of the object library and drop onto the roof. Once the dormer is in the 3D View, move the dormer around to install it properly.

To remove a dormer, select it in the Project Tree and press the Delete key.

You can replace the default window with another window or opening of your choice.

All parts of dormers (except for windows or openings) are the same segments used to create roofs. To change the configuration of a dormer, you should use tools from the Object Properties tab of the Inspector. Here you can set the dormer width and change the angles of its segments.

It is possible to change the dormer type using the same technique as described in the “Modifying the Style of a Roof” section.

You can save modified dormers to the object library.
Interior Walls in the Loft

Use the Loft Walls to split the space in the loft. Unlike the standard walls (the Storey Walls), the height of Loft Walls is not fixed by the current storey height. Loft Wall height follows the ceiling height even if the ceiling is sloped. Unlike other wall types, Loft Walls don’t change the shape of the roof.

The same tool in the toolbar is used to add walls of any type. The default wall type is Storey Wall. When you add walls in the loft, the program automatically switches to the Loft Wall type. To change the wall type, use the **Type** pop-up menu in the *Object Properties* tab of the *Inspector*.

Note that you should use Loft Walls only in the loft.
Chapter 7: Working with Objects

Basics

In the 2D layouts and the 3D views you can operate with several major types of objects:

- Walls
- Ceilings and Floors
- Windows, Doors and Openings
- Niches and Wall Panels
- Columns
- Furniture
- Staircases
- Light Sources
- Cameras

Special objects:

- Dimension Lines
- Text Annotation Boxes
- Images

The object type is the most important property of an object. Objects have different behavior depending on their type. For example, separate wall objects can merge, thus making a greater wall, but the furniture items cannot do that. Depending on the type of the selected object, the program enables or disables some tools or settings (in the Inspector window), showing only the operations allowed for this object.

Objects have two types of representation: one for the 2D layout, and another one for the 3D view.

Adding and Removing Objects

There are two different ways to add objects. For adding walls, ceilings, floors and cameras, use the tools from the 2D view toolbar. All other objects will be taken from the object library or imported to the project.

To remove an object, select it and press the Delete or Backspace key.
Selecting Objects

To perform most of the operations on an object, you have to select it.

To select an object, click on it in the 2D or 3D view.

An object selected in the 2D layout remains selected when you switch to the 3D view, and vice versa.

Objects in 2D

- All selected objects are marked with a light-blue frame, or outline.

- The selected walls, floors, ceilings, text boxes and dimension lines have handles (green dots). They are used for resizing the object. Camera handles let you move the camera with or without turning it.

- For walls, doors, and windows, you can select one of their two sides, and it will be highlighted with the green color. Both sides of the object can be selected at the same time. To select a specific side, click on it in the 2D or 3D view.

- Side selection helps to perform side-specific operations such as changing materials and modifying mouldings.

Objects in 3D

- In the 3D view, the selected object is highlighted by a white boundary frame around it. You can often select an object in the 3D view by clicking on it with the mouse.

An alternative (and sometimes the only) way to select an object is to use the Project Tree (see below).

To prevent the occasional movement or modification of an object, you can lock it in the Project Tree or in the context menu. A locked object cannot be selected by clicking it with the mouse. You should unlock it first.

Using the Project Tree to Select Objects

All objects added to your project are listed in the Project Tree section of the Library panel. This gives you two ways to access an object: it can be selected in the currently open view or in the Project Tree.

To open the Project Tree, choose Window > Project Tree from the menu.
The Project Tree will help you do the following:

- Select several objects, especially if they are of the same type.
- Select locked objects (this is the only way to select them).
- Select an invisible object.
- Select an object that is too close or hidden by other objects making it difficult to click on.

For more information about the Project Tree, see Chapter 4: “Working with Projects” > “The Project Tree”.

**Moving Objects**

To move a selected object, use the arrow keys, or simply drag it with the mouse.

Locked objects cannot be moved. An object can be locked or unlocked in the Project Tree.

**Modifying Objects**

Most object properties are available in the Inspector window. The Inspector window presents an object-dependent set of controls. It shows the tools and settings that can be applied to the selected object.

In the Type and Representation dialog box, you can flip the object and change its orientation and dimensions.

For more information, see the sections describing various types of objects in Chapter 7.

**Materials**

When you add an object to the project, it comes with default materials. You can apply new materials.

The library of materials is found in the Materials tab of the Inspector window.

Applying a new material is described in Chapter 9: “Working with Materials” > “Applying Materials”.
Walls

Walls are the basis of your project. Usually you begin creating a floor plan by drawing external and then internal walls.

Walls can be of different types. Below are described the Storey Walls (general type of walls). Most of information here is also applicable to Loft Walls. To verify or change the wall type, go to the Object Properties tab of the Inspector. Walls of different types cannot join.

Wall Segments

A wall segment is a piece of a wall that is limited by two end points. When the segment is selected, the end points (ends) are marked by green dots - handles (item 6 in the picture).

If you draw a wall segment that crosses another one, both segments will split into two smaller segments.

If a segment joins another one in the middle, the latter will split into two smaller segments.

The program can join two segments of a straight wall into one when you remove the wall that crosses and splits it.

1–5 – Wall segments.

3 and 4 – These are parts of a single segment that has been divided into two parts by joining the 5th segment.

6 – Handles (green dots) of the 5th segment.

7 – The highlighted side (green) of the 5th wall segment. This indicates that this side will change if you modify wall properties in the Inspector (mouldings or materials).
The word “wall” is used in the program documentation both for a single wall segment and for a wall consisting of multiple wall segments if the number of segments does not matter.

When you are creating a room, wall segments should join (like segments 2 and 3, or like 3, 4 and 5) to form a closed shape. The joint may break when you resize, move or add wall segments. Places where segments are joined incorrectly are marked by red circles on the floor plan. You should move a segment aside and then return it back to restore the connection. If this doesn’t help, delete the affected segments and add them again.

**Adding and Removing Walls**

To add a single wall segment:

1. Select the **Straight Wall** tool.
2. Click in the drawing area to start drawing.
3. Double-click to specify the end of the wall.

To draw a rectangular room:

1. Select the **Straight Wall** tool.
2. Make four clicks in the drawing area to specify the corners of the room. The program will end the current wall segment and start a new one with each click.
3. Place the end of the last wall where the first wall begins. The program will make the room outline closed and quit the wall drawing mode.

When you draw, the program snaps the mouse pointer to help you align the wall with other objects or to draw your line in the straight horizontal or vertical direction in the 2D view.
To stop drawing an unfinished wall segment, press the `Esc` key.

To remove a wall, select it and press the `Backspace` key.

**Selecting Walls**

To select a single wall segment, click on it with the mouse.

To select several segments, click on each of them while holding down the `Shift` key, or draw the selection frame over them.

All the wall segments used in the layout are listed in the *Project Tree*. You can use this list to select all the walls together.

When you move the mouse pointer over the selected wall, the pointer changes to:
- bidirectional arrow – indicates that you can move the wall;
- cross (when over a handle) – you can move the handle and change the wall length and direction.

**Moving Walls**

If a wall segment has a free end (which does not make a corner with another segment), you can drag it with the mouse to resize the wall or to change its direction.

When you move a segment with two ends joining other segments, the program will change the length of these segments to keep the walls joined. So, the room will be reshaped. To rip a wall segment out, drag it holding the `Option` key.

To move walls without changing their size and direction, you should select and move all the joined segments together.

**Wall Parameters**

The *Information* bar displays the wall length, thickness and angle. The bar is located above the horizontal ruler at the top of the window. To toggle (show/hide) the ruler together with the *Information* bar, use the *Show/Hide Rulers* command in the *View* menu.

Most of the wall parameters can be modified in the *Inspector* window.
The set of tools in the Inspector window allows you to adjust the thickness and length of the selected wall. You can also choose the shape and size of the wall bases and wall crowns in the Mouldings section.

To change the shape of a crown or a base, use the corresponding drop-down list. If the wall should have no crown or base, select the “-” item. You can also change the width and height of the selected crown or base.

The Flip Sides button swaps the materials, wall crowns and wall bases on the sides of the wall.

The Master Walls box contains wall templates with predefined thickness and materials.

The Project Tree lets you control the Visibility and Lock options.

Making a wall invisible lets you take a picture of the 3D view from a greater distance. You can take a picture from outside the room to encompass more objects in the picture.

Modifying Walls

Wall Size

To change the length of a wall, select it and drag its handle with the mouse. Alternatively, you can use the Object Properties tab of the Inspector window.

The thickness can be set directly in the Object Properties tab, or you can select a predefined wall type from the Master Walls box in the Inspector window. The walls from the Master Walls box come with preset thickness and materials.

Wall Height

All the walls on a floor have the same height equal to the height of the storey. To change it, use the Building Properties tab in the Inspector.
You can make a wall look lower than the storey height. To do this, insert an opening into the top part of the wall.

The editor of openings, niches and wall panels allows you to add and adjust the shape and location of an opening. To open the editor, select a wall and choose **Edit > Wall Panels, Openings & Niches**.

**Wall Crown and Wall Base**

The *Mouldings* section in the *Object Properties* tab of the *Inspector* window controls the wall crown, base and trim. You can change their length and thickness, as well as size and shape. Also, it allows you to remove a crown, base and trim from any side of the wall.

Selecting a particular side of the wall lets you see the mouldings on the side that will be changed.

To change the material of the crown, base or trim, select it in the *Project Tree*, and then select the material in the *Inspector* window. Another way is dragging a material onto the crown, base or trim.

**Materials**

Use the *Materials* tab of the *Inspector* to apply or change a material. See *Chapter 9: “Working with Materials” > “Applying Materials”* for more detail.

The end surfaces (butt-ends) of walls do not have independent materials, they use the same material as one of the wall sides.

**Wall Representation in the 2D Layout**

You may want to make walls look differently in the 2D view depending on their material or thickness. To do this, use tools in the *2D Properties* tab of the *Inspector* window.

You can use the settings from the *Drawing* section to change the color of the wall outline and the fill of wall segments, as well as apply fill patterns.
Ceilings and Floors

Adding and Removing Ceilings and Floors

The program automatically adds a floor and ceiling when you have drawn a closed shape with walls. So, usually you do not need to add ceilings and floors manually.

Automatically added floors and ceilings have the default names “AutoFloor” and “AutoCeiling” in the Project Tree.

In contrast to manually added floors and ceilings, automatic floors and ceilings:
- change size and shape when you move or resize walls;
- split into two parts when a room is broken into two pieces by adding a wall.

The “AutoFloor” and “AutoCeiling” cannot be deleted.

To add a floor or a ceiling manually, select the corresponding tool in the 2D toolbar. Then click in your layout several times to add corners. And finally, double-click to add the last corner and exit the floor/ceiling drawing mode. Floors and ceilings can be added together.

To remove a floor or a ceiling, select it and press the Delete key.
Selecting Ceilings and Floors

To select a ceiling or a floor in the 2D layout, you should click its outline. Sometimes it is difficult because the outline goes over walls (walls have higher priority for selection). Since all ceilings and floors are listed in the Project Tree, you can select them in the list.

The Project Tree lets you control the Visibility and Lock options.

Moving Ceilings and Floors

To move a ceiling or a floor, select it and drag its edge with the mouse.

**Note:** When you move ceilings or floors, they turn to regular (non-automatic) objects: they will not change their shape when you modify walls.

Resizing Ceilings and Floors

To resize a ceiling or a floor, select it and drag a corner handle with the mouse.

The Information bar shows the dimensions of the selected ceiling or floor. If the object is rectangular, and its sides are vertical and horizontal, the dimensions will mean the width and height. To show or hide the Information bar and rulers, press **Cmd-R**.

To change the shape of the ceiling or the floor, you can add or delete its corner handles. To add a handle, right-click on the floor or ceiling outline and select **Add Contour Point** in the context menu. To delete a handle, right-click on it and select **Delete Contour Point**.

To lock or unlock the shape of custom floors or ceilings, click on the **Edit Geometry** icon in the Inspector.
Setting up the Level of the Floor or Ceiling

Rooms located on the same storey may have different floor or ceiling levels. To recreate this in the program, you have to add a custom floor or ceiling and set its elevation different than that of the “AutoFloor” or “AutoCeiling”.

1 – The “AutoCeiling” that has the default level.

2 – A custom ceiling with the **Elevation** lower than “AutoCeiling”.

3 – A custom floor with the **Elevation** higher than the “AutoFloor”.

4 – The “AutoFloor” that has the default level.

To change the floor and ceiling levels, select it in 2D and change the **Elevation** value in the *Object Properties* tab of the *Inspector*.

**Materials**

Use the *Materials* tab of the *Inspector* to apply or change a material. See *Chapter 9: “Working with Materials”* > “Applying Materials” for more detail.
Ceiling and Floor Representation on the Plan

To make objects look differently in the 2D view depending on the material, size or other principle, apply different stroke colors and pattern fills. They can be changed in the 2D Properties tab of the Inspector.

You can use the settings from the Drawing section to change the outline color and fill color, as well as apply fill patterns.

Text Label of the Floor

Unlike the ceiling, the floor has a text label. By default, the label is displayed on the area of the floor. To add your own text, double click the label.

The location of the label in the 2D layout can be changed. To do this, drag the label to a new location.

If a custom floor is placed over the “AutoFloor”, the area of the “AutoFloor” decreases by the area of the custom floor.
Windows, Doors and Openings

Windows, doors and openings have a similar behavior in the program, so the term “opening” will be used for all these objects except we need to describe the difference between them.

Adding and Removing Openings

To add an opening:

1. Open the Building Elements tab in the Library panel.
2. Select the desired category in the drop-down list.
3. Drag an opening to your project layout.

When you bring an opening over the 2D layout, the opening snaps to walls and changes its orientation according to the orientation of the closest wall.

To remove an opening, select it and press the Delete or Backspace key.

The built-in opening editor lets you create and edit openings, niches and wall panels.

Selecting Openings

To select an opening, click on it.

All the openings used in the layout are listed in the Project Tree. You can select them in the list.

Moving Openings

To move an opening, drag it with the mouse. Another way is to use the arrow keys when the opening is selected.

When you move the opening close to a wall, it will be inserted into the wall automatically. To rip the opening out, drag it out of the wall.
Parameters of Openings

The Information bar shows the opening height, width, thickness, elevation and angle. The bar is located above the horizontal ruler. To show or hide the Information bar and rulers, press Cmd-R.

Most of an opening’s parameters can be modified in the Inspector window.

The Flip Sides button rotates the opening 180 degrees.

In the Inspector window, you can control the elevation of openings.

The Elevation parameter can be locked/unlocked by clicking the lock icon. Locking the elevation is useful when you need to move an object only horizontally in the 3D view (for example, to distribute windows in the wall).

The Project Tree lets you control the Visibility and Lock options.

The Look Through check box should be selected if a door or window has transparent parts. In this case, objects in the room behind the door or window are displayed correctly in the 3D view. Deselecting the check box turns off rendering objects behind the door or window. This speeds up rendering the 3D picture.

To change an object’s properties such as the orientation in 3D, the origin point and 2D representation, select the object and click the Type & Representation button in the Inspector. The program will open the Type & Representation dialog.
Dimensions of Openings

To change the dimensions of an opening, use the Object Properties tab of the Inspector window. You can adjust the height, width, thickness, elevation and frame thickness.

The **Inner/Outer Parts Ratio** slider sets the position of an opening in relation to the wall (how deep it is in the doorway).

**Materials**

Use the Materials tab of the Inspector to apply or change a material. See Chapter 9: "Working with Materials" > "Applying Materials" for more detail.

**Opening Representation in the 2D Layout**

You may want to make openings look differently in the 2D view depending on the material they are made of. To do this, use the 2D Properties tab of the Inspector window.

You can use the settings from the Drawing section to change the outline color and fill color for the opening, as well as apply fill patterns.
Niches and Wall Panels

Niches and wall panels have a similar behavior in the program, so the term “object” will be used for these objects except when we need to describe the difference between them.

Adding and Removing Niches and Wall Panels

1. Open the Building Elements tab in the Library panel.
2. Select the corresponding category in the drop-down list.
3. Drag the object into your project layout.

When you bring the object over the 2D layout, it snaps to walls and changes its orientation according to the orientation of the closest wall.

To remove a niche or wall panel, select it and press the **Delete** or **Backspace** key.

The built-in opening editor lets you create and edit openings, niches and wall panels.

Selecting Niches and Wall Panels

To select an object, click on it.

All the openings used in the layout are listed in the Project Tree. You can select them in the list.

Moving Niches and Wall Panels

To move an object, drag it with the mouse. Another way is to use the arrow keys when the object is selected.

When you move an object near a wall, it will be inserted into the wall automatically. To rip the object out, drag it away from the wall.
Parameters of Niches and Wall Panels

The *Information* bar shows the object’s height, width, thickness, elevation, angle and area. If several objects are selected, the combined area is displayed. The bar is located above the horizontal ruler. To show or hide the *Information* bar and rulers, press **Cmd-R**.

Parameters of niches and wall panels can be modified in the *Inspector* window.

**Thickness** of a wall panel object can be either positive or negative. With a positive value, it looks like a wall panel. With a negative value, it looks like a niche.

Niches and wall panels can be attached to walls with only one side.

To attach a niche or wall panel to another wall side, click the **Flip Sides** button in the *Inspector* window.

In the *Inspector* window, you can change the elevation of an object. By clicking the lock icon, you can lock the **Elevation** parameter to move an object only horizontally in the 3D view (for example, to distribute niches in the wall).

The *Project Tree* lets you control the **Visibility** and **Lock** options.

To change an object’s properties such as the orientation in 3D, the origin point and 2D representation, select the object and click the **Type & Representation** button in the *Inspector*. The program will open the **Type & Representation** dialog.

Changing the Size and Shape

To change the size of an object, use the tools located in the *Object Properties* tab of the *Inspector*. You can adjust height, width, thickness, elevation and frame thickness.

To customize the shape of the niche or wall panel, right-click on it and select *Edit Wall Panels, Openings and Niches*. See Chapter 7: “Working with Objects” > “The Wall Panels, Openings and Niches Editor” for details.
Materials

To change the object material, use the material library located in the Materials tab of the Inspector. See Applying Materials for more detail.

Object Representation in the 2D Layout

To make objects look differently in the 2D view due to the material, size or other principle, apply different stroke colors and pattern fills. They can be changed in the 2D Properties tab in the Inspector.

The image used to display an object on the floor plan can be changed in the Type & Representation dialog.
Chapter 7: Working with Objects

Columns

Adding and Removing Columns

1. Open the Building Elements tab in the Library panel. Then select “Columns” in the drop-down list.

2. Drag the column into your project layout.

The height of the added column will be equal to the storey height.

To remove a column, select it and press the Delete or Backspace key.

Parameters of Columns

The Information bar shows the column width, depth and height. The bar is located above the horizontal ruler. To show or hide the Information bar and rulers, press Cmd-R.

Most of the column parameters can be modified in the Inspector window. The Inspector window lets you modify the dimensions of the selected column, as well as the height of its capital and base. You can also rotate columns.

The Project Tree lets you control the Visibility and Lock options.

Column Size

Column dimensions are found in the Object Properties tab of the Inspector window.

The height of the column base and capital can be adjusted separately.

The default column height is equal to the height of the walls.

Materials

Use the Materials tab of the Inspector to apply or change a material. See Chapter 9: “Working with Materials” > “Applying Materials” for more detail.
Furniture

Various pieces of furniture have similar behavior in the program, so the term “object” will be used for all of them except when we need to describe the difference between them.

Adding and Removing Furniture

1. Open the Furnishing tab in the Library panel.
2. Select the necessary category in the drop-down list.
3. Drag the required object to your project.

Furniture can be added from the built-in library or imported from a 3D model file.

To remove an object, select it and press the Delete or Backspace key.

Selecting a Piece of Furniture

To select an object, click on it with the mouse.

To select several objects, click on each of them holding down the Shift key, or use the mouse to draw a selection frame over them.

All the objects used in the layout are listed in the Project Tree. You can select objects by clicking on their names in the list.

Moving Furniture

To move an object, drag it with the mouse. You can move objects in both the 2D and 3D views.

Furniture Parameters

The Information bar shows object’s width, height, depth, elevation and angle. The bar is located above the horizontal ruler. To show or hide the Information bar and rulers, press Cmd-R.

Most of the furniture parameters can be modified in the Inspector window.

The Project Tree lets you control the Visibility and Lock options.
To change an object’s properties such as the orientation in 3D, the origin point and 2D representation, select the object and click the **Type & Representation** button in the **Inspector**. The program will open the *Type & Representation* dialog.

The **Edit Light Sources** button opens the selected object in the **Light Source Editor**. It lets you edit lamps or create a lamp out of imported objects.

### Modifying Furniture

Since the library does not have all possible pieces of furniture, you may want to adjust the existing objects for your needs.

All adjustable parameters can be found in the **Object Properties** tab of the **Inspector** window.

#### Size

To resize the object, select it first, then unlock the dimensions you want to modify, and enter the new values.

To resize the object proportionally, select the **Maintain Aspect Ratio** option.

#### Orientation (Rotation Angle)

To rotate an object, use the **Rotate** tool in the **Inspector** window.

#### Elevation

To change the elevation of an object, use the **Elevation** tool in the **Inspector** window.

The 3D view lets you drag an object with the mouse upward or downward, but this is less accurate.
The **Elevation** parameter can be locked/unlocked by clicking the lock icon. Locking the elevation is useful when you need to move an object only horizontally in the 3D view (for example, to distribute things over a table).

### Object Location in Relation to Walls, Floor and Ceiling

The location of most of the objects in the room is pre-determined by their purpose. For example, tables and chairs are always located on the floor; wardrobes and bookcases stay on the floor near a wall. Most lamps hang from the ceiling or are affixed to a wall.

The program takes this characteristic of the objects into account. This is especially convenient when you move an object in the 3D view: it stays stuck to the selected surface. So you do not need to worry about chairs and lamps hovering somewhere between the floor and the ceiling.

The **Glue By** set of options in the *Inspector* window lets you select up to three object sides that will stick to walls, the floor or the ceiling. The left, right, front and back sides can glue to walls; the top side can glue to the ceiling, and the bottom side – to the floor.

When the **Glue By** option is checked and you bring the object close to a wall, it sticks to the wall. The program may rotate an object if this is necessary to place it parallel to the wall.

### Placing an Object onto the Top of Another

Objects like TV sets, computers, and cookware are usually located atop other objects such as tables and stands.

For example, let’s place a TV set onto a table. To be able to change the elevation of the TV set, unlock its **Elevation** property in the *Object Properties* tab of the *Inspector* by clicking on the lock icon.

Way 1 (works when the TV set object is higher than the table) – Drag the TV set over the table in the 2D or 3D view. The TV set will automatically jump onto the table.

Way 2 (the object’s height doesn’t matter) – Drag the TV set over the table in the 2D or 3D view. If the table’s top is higher than the TV set, the latter will appear under the table. Increase the **Elevation** value in the *Inspector* to lift the TV set until it is on the table.
Way 3 (the object’s height doesn’t matter) – Drag the TV set over the table in the 2D or 3D view. If the table’s top is higher than the TV set, the latter will appear under the table. Press **Cmd-Opt** and drag the TV set upwards in the 3D view.

**The Cast Shadows Option**

The **Cast Shadows** option allows you to turn on/off rendering shadows. This can be useful to:

- Minimize the task for the rendering engine.
  
  Calculating the 3D scene with all the shadows displayed requires more time. To speed up rendering, disable unnecessary shadows. For example, shadows on walls and floor carpets are not seen at all and can be switched off.

- Emphasize some key objects in your 3D design.
  
  You can create a design where only several objects drop shadows. This will attract more attention to key objects, keeping others in the background.

**Lamp Parameters**

Lamps are found in a separate section of the *Furnishing* tab. In addition to the parameters that furniture items have, lamps allow you to change color and luminosity of light. These parameters can be modified in the *Light Properties* tab of the *Inspector* window.

**Materials**

Use the *Materials* tab of the *Inspector* to apply or change a material. See *Chapter 9: "Working with Materials" > "Applying Materials"* for more detail.

**Object Representation in the 2D Layout**

By default, objects are displayed on the floor plan by a simple outline. You can choose another image in the *Type & Representation* dialog. Another option is to use the view of the object from above in 3D. You can select the type of 2D representation in the *2D Properties* tab in the *Inspector*.

To help distinguish objects in the 2D view, apply different stroke colors and pattern fills. They can be changed in the *2D Properties* tab in the *Inspector*. 
Staircases

Stairs are a special object type in Live Interior 3D. Unlike other objects, they create an opening in the slab above. To activate this property, an object should have the *Stairs* type in the *Type & Representation* dialog.

Look at the picture below. There are two copies of the same staircase object. The left one is *Furniture* which is a generic object type. The right one is *Stairs*. When you import a 3D model of a staircase, it has the *Furniture* type by default. Change the object type in the *Type & Representation* dialog manually.

The *Stairs* object consists of two components: the slab opening and the staircase itself. You can see its structure in the *Project Tree*.

The parent item *Stairs Opening* is responsible for the whole object. When it is selected, you can change the material of the opening. To change the material of the staircase, select the *Stairs* item. To change the name of this item, double click on it in the *Project Tree*.

**Adding and Removing Staircases**

1. Open the *Building Elements* tab in the *Library* panel.
2. Select the *Stairs* category in the drop-down list.
3. Choose a model and drag it to your project layout.
To remove a staircase, select it and press the **Delete** or **Backspace** key.

**Selecting a Staircase**

To select a staircase, click on it with the mouse.

All staircases in the project are listed in the **Project Tree**. You can also select them in the list.

**Moving a Staircase**

To move a staircase, drag it with the mouse. Another way is to use the arrow keys when a staircase is selected.

**Parameters of Staircases**

The **Information** bar shows the height, width, thickness, elevation and angle of a staircase. The bar is located above the horizontal ruler. To toggle whether to show or hide the **Information** bar and rulers, press **Cmd-R**.

Parameters of staircases can be modified by using the **Inspector** window.

**Width** and **Height** control the size of a staircase.

The **Height** parameter is the vertical dimension of an object in the 2D view. It is not the same as the object height in the 3D view.

The default height of a staircase in 3D is equal to the storey height (the distance from 1 to 4 in the picture).

The **Elevation** parameter defines the distance (3) between the bottom of a staircase (2) and the floor (4). **Elevation** can be used when a staircase begins on a platform that is located above the floor level (see the picture below).
By default, the top of a staircase meets the floor of the storey above (7). If a staircase has a handrail, its top (5) is above the floor level. You should meet the top stair with the floor manually by setting the Handrail Height value (6).

The Project Tree lets you control the Visibility and Lock options.
To change an object’s properties such as the orientation in 3D, the origin point and 2D representation, select the object and click the **Type & Representation** button in the **Inspector**. The program will open the **Type & Representation** dialog.

**Materials**

Use the library of materials located in the **Materials** tab of the **Inspector** window to apply materials to a staircase.

To change the material of a staircase opening, select this object in the 2D or 3D view. Or select a **Stairs Opening** item in the **Project Tree**.

To apply new materials to a staircase model, expand a **Stairs Opening** item in the **Project Tree** and select its sub-item **Stairs**.

For details, see Chapter 9: "Working with Materials“ > "Applying Materials“.

**Editing the Opening Shape**

The shape of the opening in the slab can be changed on the floor plan. The opening is displayed by a dashed line in the 2D view. The default opening shape usually coincides with the outline of the object seen from the top.

To change the shape of a staircase opening, move the handles on the opening outline with the mouse.

The number and location of the handles depends on the model shape. Spiral staircases usually have more handles than straight stairs.

To prevent the opening shape from occasional change, lock it using the **Edit Geometry** option in the **Object Properties** tab of the **Inspector**. In this case, the handles are not displayed.
Properties of Objects in 2D

The 2D Properties tab of the Inspector lets you specify the appearance of objects in the 2D view.

To open the tab, choose Window > Inspector > 2D Properties.

The described tools work with walls, floors, ceilings and auxiliary objects (for instance, text annotation or an imported image).

1 – Object’s contour line. When this option is on, you can choose the color of the line. Supported objects: walls, floors, ceilings, images and text annotations.

2 – Object’s fill color. Supported objects: walls, floors, ceilings and text annotations.

3 – Pattern fill. It is useful to mark off walls, floors or ceilings when different building materials are used for them or their parts.

4 – The angle of cameras, images, measurements and text annotations.

5 – The text alignment options.

6 – The font size.

7 – Open the standard Fonts pane to change the font of text annotations and measurements.

8 – The color of text annotations and measurements.

9 – Use a simple outline of the object as the representation. The image used by default is in the vector format which provides the best quality when you print the floor plan. You can choose another image in the Type & Representation dialog.

10 – Represent an object using the overhead view of the object in 3D. This representation is created automatically upon the current top view of the object. To change its quality, use the View > 2D Representation > Auto-Generated menu.
11 – Opacity of the automatically created 2D representation.
Type and Representation

The *Type and Representation* dialog lets you change the properties of objects. It opens when you import an object, when you choose the *Type and Representation* command from the *Edit* menu, or use the context menu of an object.

The tools in the *Type and Representation* dialog change only one copy of the object: the one which was selected when you opened the dialog box. Other copies that may be present in your project remain unchanged.

The program uses the same model for all the copies of each object in the project. If you modify one of the copies, the program will have to create one more model specially for the changed object. So, using the *Type and Representation* dialog you can increase the total number of object models in the project. This may result in a decrease in the program’s performance.

Controlling the Object Preview

The *3D Representation* box displays a preview of the 3D model.

To change the size of the preview picture, click the zoom buttons above the preview.

To rotate the 3D model in the preview, place the mouse pointer above the picture, press the mouse button and drag it to any side. To restore the default orientation (angle) and magnification of the model in the preview, double-click on it.

The settings in the preview box do not affect the object, they change the preview picture only.
Object Properties

The **Object type** is the most important object property. It determines the behavior of the object. You can set it to *Furnishing, Window, Door* and *Stairs*. The difference is that windows and doors can be inserted into walls, while furniture cannot. Any object that is not a door or a window, should be specified as *Furnishing*.

**Rotating an Object**

Rotating an object in the *Type and Representation* dialog means the object will change its default orientation.

Changing the orientation of an imported object is necessary when objects are imported upside-down or when a door or window is inserted across a wall.

To rotate an object, use the **Rotate 3D Representation** sliders.

It is recommended that you allow the program to update an object’s origin after an object is rotated. To do this, select the **Change Object Origin to** option, keeping its sub-options unchanged.

**3D Flipping**

3D flipping lets you make several objects out of a non-symmetric model.

For example, by applying front-to-back and left-to-right flipping, you can create three new doors from a single door model. This is especially helpful when the door model has a handle on one side but you need a handle on the other side.

To flip an object, click the corresponding **3D Flip** button.

**Change Object Origin**

The **Change Object Origin** option allows you to change the origin of an object already added to your project and lets choose an origin for an object are currently importing to your project. Changing the object origin affects the current object’s copy only. Objects in the built-in library never change.

The object origin is a point on the object surface that is used by the program to define the object location in the 2D layout and in the 3D space. By default, the most optimal point on the object is used as the origin.
For instance, the origin is used to rotate an object. When you rotate an object, it rotates around its origin. So, changing the origin may change the object behavior.

The default origin is usually set depending on the object type: for furniture this is the center of the bottom; for wall pictures – the center of the back surface; for ceiling lamps – the center of the top.

**Object Size**

Object dimensions determine the size of an object. The size can also be modified in the *Inspector*.

**Image for the Floor Plan**

The 2D representation box shows the current object representation for the 2D view.

To choose an image from the library, click on it.

To use a custom image, click the Custom Image button and navigate to the graphic file.

**2D Flipping**

2D flipping mirrors a 2D representation. This is needed for adjusting the orientation of an image for the 2D view to match with the 3D object. For example, after left-to-right flipping of the door, you should flip its image on the floor plan, too.

*Note:* The 2D and 3D flip operations work independently for better flexibility. Make sure the 2D representation matches the 3D object.
Importing Objects

The built-in object library may not contain all objects necessary for carrying out your project. The program lets you import other objects stored on your disk in the following formats:

- 3DS (created in the Autodesk® 3ds Max® software)
- Trimble SketchUP™
- Ogre XML
- Collada

To import an object from a file:

1. Select **File > Import 3D Object** in the menu.

2. Specify the format of the file you want to import and select the file.

3. Set up the import options (not available for Ogre XML).
   - **Make all surfaces double-sided to avoid invisible surfaces**
   - **Split Object Instances** – split a compound object to turn its parts into separate objects in Live Interior 3D.

4. The **Type and Representation** dialog will open. Adjust the necessary settings and click **OK**. You can change the settings later if necessary. For more details, see the "Type and Representation" section.

Imported objects may have references to one or several textures. The program will try to find them in the folder containing the selected file. If a texture is not found, the program will ask you to locate it in the Finder. The texture name will be shown at the top of the **Open File** window. You can also opt to skip opening textures and simply use the materials from the built-in library.

Import Options

**Make all surfaces double-sided to avoid invisible surfaces**

This option fixes the problem with invisibility of one-sided surfaces.

When you look at a cube, you can see any of the six its sides. To visualize them, 3D software creates faces by one per each side. A faces allow to apply a plain color or texture to corresponding parts of an object making them visible. If there is a need to show the cube from inside as well, each side of the cube
should have two faces: the inner and outer.

Most of objects can be previewed only from outside like a cube. To simplify such 3D models, faces for invisible object parts aren’t created. If we remove any side of a cube to create an open box, both internal and external faces of the all five sides must be present. The lack of faces where they are needed makes parts of an object invisible.

Adding faces leads to increasing the 3D object size, which results in increasing the document size. Activate the Make all surfaces double-sided option if a part of the imported object is invisible.

**Split Object Instances**

Models can be split into parts when they are made out of several components. For example, some models are composed of several objects (a lamp, a computer, books, etc. on a table). If objects are made up of components, you can split them to remove or rearrange some of these components.

The split options let you choose to split all or only identical objects.

The ability to split a model depends on how it was created.
Importing Trimble SketchUp™ Objects

To import an object in the Trimble SketchUp™ format, use the File > Import 3D Object... menu command as described in the "Importing Objects" section.

Using Drag & Drop for Importing

Live Interior 3D supports importing Trimble SketchUp™ models by dragging and dropping them from a folder on your hard disk into the Live Interior 3D project.

To change the properties of an already imported object, use the Type and Representation dialog box. To open it, choose the Type and Representation item in the Edit menu.

If the imported object is a door or a window, you should specify this in the Type and Representation dialog. You can also change the orientation of an object and its icon on the floor plan.

Direct Import from Trimble 3D Warehouse™

Live Interior 3D supports integration with Trimble 3D Warehouse™.

You need to have Internet connection to import objects directly from Trimble 3D Warehouse™ since it is located on a web server.

To import a 3D model directly from Trimble 3D Warehouse™:

1. Click the Trimble 3D Warehouse button in the tool bar or choose the Window > Trimble 3D Warehouse menu item.

   The Trimble 3D Warehouse™ page will open in a pop-up browser window. The interface of the browser is described below.

2. Find the model you want to import. Use thumbnails and hyperlinks in the browser to navigate, or use the search box.

   Once you have found a model for your project, open its page.

3. Click the Get Model button on the object page.

   The button may also be called Download to Live Interior 3D, or Download Model, or Download to Trimble SketchUp.
Until an object is completely downloaded, a replacement image will be shown in the 2D and 3D views.

The duration of the download depends on the object file size and on the speed of your Internet connection.

You can set up the import from Trimble 3D Warehouse™ by using the Make all surfaces double-sided to avoid invisible surfaces and Split Object Instances options described below in the “Import Options” section. These options can be changed in the the Trimble 3D Warehouse™ tab of the program Preferences. Click the Import Options button in the browser window toolbar for quick access to these options.

To change the properties of an already imported object, use the Type and Representation dialog box. To open it, choose the Type and Representation item in the Edit menu. If the imported object is a door or a window, you should specify this in the Type and Representation dialog. You can also change the orientation of the object and its icon for the floor plan.

Browser of Trimble 3D Warehouse™ Model Collection

The built-in browser used to navigate the on-line model collection has a toolbar, preview box and a status bar.

Toolbar buttons (from left to right):
- Go to the previous page and Go to the next page – navigation through the recently previewed pages.
- Reload current page.
- Go to the home page – opens the Trimble 3D Warehouse™ home page.
- Import settings – opens the import settings in the Trimble 3D Warehouse™ tab of the program preferences.

The browser mostly behaves as an ordinary web browser.
Editing Objects in Trimble SketchUp

You can edit objects in Trimble SketchUp (version 6 or higher) if this software is installed on your computer.

1. Select an object.
2. Choose **Edit > Edit in Trimble SketchUp...**
3. Modify the object in Trimble SketchUp.
4. Choose **File > Save** in the menu of Trimble SketchUp.
5. Click **Finish** in Live Interior to replace the original object with the edited one.

Note that an object should be of the *Furniture* type to have the editing function enabled. The type of an object can be changed in the *Type and Representation* dialog.

The resulting object model from Trimble SketchUp (even if you have changed nothing) differs from the original one. The more different models are present in a project, the more time is required to render the 3D view. For better program performance, you should avoid increasing the quantity of models.

*Chapter 4, "Working with Projects" > "Exporting to 3D File Format"* describes how to export an object to a file in the SketchUp format.
The Wall Panels, Openings and Niches Editor

This editor helps you create or modify the shape of an opening, niche or wall panel (all of them are called “objects” in this section). Standard niches and openings are located in the built-in library of 3D models (Window > Library > Building Elements). The editor allows you to work with objects of non-standard shape and size (as the L-shaped opening in the picture).

The same tools are used to create panels, openings and niches for roofs.

Details about openings can be found in Chapter 7: "Working with Objects” > "Windows, Doors and Openings”.

To open the editor, select a wall and choose Edit > Wall Panels, Openings & Niches. Or right-click (Ctrl-click) on a wall and choose Edit Wall Panels, Openings & Niches in the context menu.
1 – Selection tool. Use it to select objects and move the corner handles of objects.

2 – Wall Panel tool. Use it to draw the outline of a new wall panel.

3 – Niche tool. Use it to draw the outline of a new niche.

4 – Opening tool. Use it to draw the outline of a new opening.

5 – Pan tool for scrolling the preview area. Choose this tool and drag the preview.

6 – Zoom in.

7 – Zoom out.

8 – Wall side selector.

9 – Lock option. Lock an object to prevent changing its shape. Changing its location remains possible.

10 – Flip an opening, or put a wall panel or niche onto another wall side.

Objects look different in the editor depending on their type (2, 3 and 4 in the picture below).
In the editing area:

1 – Wall outline.

2 – Wall panel.

3 – Niche.

4 – Opening.

5 – A selected object is highlighted.

6 – Corner handles. Move them to change the object shape or size. To add a new handle, Ctrl-click on an object’s side and choose **Add Contour Point** in the pop-up menu. To delete a handle, Ctrl-click on it and choose **Delete Contour Point** in the context menu.

To move an object, drag it with the mouse.
Aligning and Distributing Objects

In Live Interior, you can arrange objects in the layout using the **Align** and **Distribute** commands located in the **Arrange** menu.

**Aligning Objects**

Objects can be aligned by centers or edges.

**Align Centers Horizontally:**

![Align Centers Horizontally Diagram](image)

The **Align Centers** command aligns the centers of the selected objects along a straight line.

**Align Right Edges:**

![Align Right Edges Diagram](image)

When you apply the **Align Edges** command, objects are aligned to the outermost object.
Distributing Objects

Arrange > Distribute Spacing makes the distance between the edges of the selected objects equal.

Arrange > Distribute Centers makes the distance between the centers of the selected objects equal.

When you distribute objects, only the middle ones will change their location. The top and bottom objects (when distributed horizontally) and the left and right (when distributed vertically) stay in the original location.

The Distribute operation allows you to speed up adding and positioning multiple objects.

For example, you need to insert four windows in a wall and distribute them with the same distance between each window. The quickest way is:

1. Insert all windows in the wall.
2. Place the left and right windows to the proper locations.
3. Choose Arrange > Distribute > Openings Spacing in the menu to get other windows placed automatically.

Note that unlike furniture, openings have separate distribute commands in the menu. This is necessary because openings should stay in the wall when moved. For this, both their coordinates (in the 2D layout) may be changed if the wall is not parallel to any of the rulers. Other objects, when distributed, change only one coordinate.
Grouping and Ungrouping Objects

You can combine several objects into a group to treat them as a single one. For example, you might group objects laying on a table with the table in order to move them together.

To group objects together, select them by clicking on them while holding down Shift, and choose Arrange > Group (Cmd-G) in the menu.

To ungroup the objects, select the group and choose Arrange > Ungroup (Cmd-Shift-G) in the menu.

A group of objects is represented in the Project Tree as a single item.

Nested grouping is also supported. You can group either separate objects or a group with another group. When you ungroup the bigger group, objects in a nested group will remain grouped. For example, you can group a lamp with a table. Then group this group together with a chair. After ungrouping the overall group, the table with the lamp will remain grouped and the chair will be separate.

Merging Objects

One more command to combine objects is Arrange > Merge into Single Object.

Merged objects become one regular object. Unlike grouping, merging is irreversible. You cannot split merged objects unless you apply Edit > Undo (Cmd-Z).

Merging is effective for objects that contain identical details. For example, a 3D model of a tree can be created by duplicating the same leaf many times. This tree will be rendered faster if you merge its parts rather than group them. Also prefer merging if the objects you wish to combine have the same material applied.

If there is a chance you need to separate objects, or arrange them in different way and combine again, use grouping.
Chapter 8: The Library of Objects

The program is provided with a library of objects (3D models of furniture, doors, etc.). In your projects, you can use this built-in library or import more objects. Imported items can be added into the library for further use. The library is located in the Library panel.

The Library Panel

The Library panel is a part of the main program window. To open the panel (if it is hidden), use the Toggle Library toolbar button (4 in the picture) or the Window > Toggle Library menu command.

To change its width, move the handle near the bottom-right corner of the panel.
1 – The Project Tree lists all the objects in the project. See the “Project Tree” section for more information.

2 – The Furnishing section of the library of objects. It includes furniture, lamps, fireplaces and other objects.

3 – The Building Elements section of the library of objects. It includes doors, windows, niches, openings, columns, staircases and 3D shapes.

4 – Hide/Show the Library panel.

5 – The object categories pop-up menu. The objects in the Furnishing and Building Elements sections are grouped into categories. You can add more categories for objects that you add yourself. Custom categories appear below the main list. To manage custom categories, use the options at the bottom of the list.

6 – The thumbnail of an object. To add an object to the project, drag its thumbnail into the 2D or 3D view.

7 – Search box. To find an object, type an object name into this field and press the Return key.
Chapter 8: The Library of Objects

8 – The context menu of the library is intended for managing objects in custom categories. To bring up the context menu, you can also right-click on an object thumbnail in the library. Some operations work only with objects in custom categories.

- Cut – remove a selected object and place its copy to the Clipboard.
- Copy – copy a selected object to the Clipboard.
- Paste – paste an object from the Clipboard in the open category.
- Delete – delete a selected object.
- Substitute with Selection in Project – replace an object selected in the library with an object selected in the project.
- Substitute with Selection in Library – replace an object selected in the project with an object selected in the library.
- Item Info – display details of an object selected in the library.

9 – Hide/Show the object preview box (12).

10 – Zoom in and zoom out of the object preview.

11 – Turn the preview animation mode on/off. When the animation mode is enabled, the object rotates in the preview box so that you can see it from all sides. It is recommended that you turn this feature off on slow computers.

12 – Preview of the selected object. To rotate the object in the preview box, place the mouse cursor over the preview, press and hold the right button, then move the mouse in the direction you wish to rotate the object.

13 – The logo of the item manufacturer. If you like one of the doors, windows or a piece of furniture, click on the logo. Your web browser will show the manufacturer’s website where you may be able to purchase the actual piece of furniture or get more information about it.
Object Information in the Library

The *Item Info* dialog box shows information about an object selected in the library.

To open the dialog box, double-click on a thumbnail in the object library.

The displayed data can be modified if you have selected a custom object (an object added to the library by the user). The information of objects supplied with the program cannot be changed.

The **Title** is the object name shown in the library below the object thumbnail.

The **Description** field may contain some additional information. It will be displayed as a pop-up hint when the mouse pointer is over the object thumbnail.

The name selected in the **Manufacturer** drop-down list will be shown together with the company logo in the 3D preview box of the library when the object is selected. If the object does not have an actual prototype, or if the manufacturer is unknown, select “Unknown” for this field.

The **Keywords** box is intended for searching keywords.

The **Thumbnail** section allows you to preview the thumbnail of the object and change it (for custom objects only).

The thumbnail can be made as a snapshot of the 3D object. To change the thumbnail picture, click the **Change** button. Use the mouse to rotate the object in the box. Then click **OK**.

When you add a new object to the library, the program offers you to enter information into the *Item Info* dialog.
Managing Objects in the Library

The interface of the 3D object library is described in the Library Panel section. To open the Library panel, use the Window > Library menu.

Adding and Removing Object Categories

To add new object categories to the library, click on the pop-up menu and choose the New Category item. Spaces in the category name are not allowed, the program replaces them with the underline character.

To delete a custom object category with all included objects, choose Delete Category in the pop-up menu. Note that the built-in categories and objects cannot be deleted.
Adding and Removing Objects

Objects imported into your project can be added to the library.

1. Open the category in the library where you would like the object to be stored. It is recommended that you add new objects to a custom category.

2. Right-click on the object and choose Copy in the context menu.

3. Right-click on the object thumbnails area of the library and choose Paste.

4. The Item Info dialog box will appear. Type the object name into the Title box.

   The Description and Keywords fields can be left blank. If you plan to add a great number of objects to the library, enter some information into these boxes. This will simplify finding the required object later. Keywords should be separated by spaces.

   If necessary, change the 2D thumbnail.

5. Click OK.

   Later, you can open the Item Info dialog by double-clicking on the object thumbnail in the library.

To delete a custom object (a built-in one cannot be deleted), right-click on the object and choose Delete.

Copying and Moving Objects

To create a copy of an object in the library, right-click on it and choose Copy. Then open the destination category, right-click in the thumbnail area and choose Paste.

To move an object to another location in the library, right-click on the object and choose Cut. Open another object category, right-click in the thumbnail area and choose Paste.
**Replacing an Object in the Library**

You can only replace objects in custom categories.

To replace an object in the library with an object selected in the project:

1. Select an object in your project.
2. Right-click on an object in the library and choose *Substitute with Selection in Project* in the context menu.

**Changing the Order of Objects**

To change the order of objects within a particular category, drag the objects thumbnails to new positions. You can re-order objects only in custom categories.

**Undoing and Redoing Previous Actions**

To undo or redo your previous actions in the object library, right-click on the thumbnail area and choose *Undo* or *Redo*. 

---

Chapter 8: The Library of Objects

179
Chapter 9:
Working with Materials

Materials are used to apply some color to an object or to map a texture onto its surface. This makes the object look like its real prototype. A material determines the object color and also affects light dissipation and light reflection.

Materials are controlled from the *Materials* tab of the *Inspector* window.

The materials supplied with the program cannot be modified.

Applying Materials

The material library is located in the *Materials* tab of the *Inspector*. It lets you:

- Choose and apply a material to an object.
- Preview materials already applied to an object.
- Create new materials.
1 – The list of all materials of the selected object(s). Each item here represents a part of the object. The same material may appear in the list several times. This means that it has been applied to several parts of the object. Actions possible with the materials listed here are described below in “Working with the List of Object Materials”.

2 – Material picker. It allows you to choose a material of one object and apply it to another. Use it to make objects match.

3 – A handle to expand or collapse the list (1).

4 – Texture size (horizontal and vertical). See “Adjusting the Texture Size and Orientation” for more details.

5 – Maintain aspect ratio.

6 – Texture offset parameters allow you to change the positioning of the texture on the object’s surface.

7 – Texture rotation control.

8 – Material category selector (it allows you to add and remove custom categories).

9 – Thumbnails of materials.

10 – Thumbnail size control.

11 – Actions menu:
   - New Material – opens the Create New Material dialog.
   - New From Selected – opens the Create New Material dialog with the parameters of the selected material set.
   - Edit Selected – opens the selected material in the Material Editor dialog if it is a custom material. A material from the built-in opens in the preview mode and cannot be changed.
   - Delete Selected Material – removes custom materials.
Applying a Material to an Object

Method 1:

In the 3D view, drag a material from the library (9) or from the Object’s Materials list (1) and drop it onto an object. Be careful, as an object may have multiple parts. Point to the exact part of the object you want to modify.

Method 2:

To change the material:

1. Select one or several objects.

2. In the box (1), select one or several materials that you wish to change. To select multiple items, click on them while holding down the **Cmd** key.

3. Choose a new material in the material library (9). You can either click on it or drag and drop it onto any material of that object (1).

To copy a material from another object, use the material picker (2).

Working with the List of Object’s Materials

1 – One of the object’s materials.

2 – The name of the object whose materials are listed below.

3 – Material on a side of a wall. The icon to the right indicates which part of the wall this material belongs to.

4 – Material of the selected wall side (indicated by green highlight).
Materials used for walls have an additional icon (3 and 4) that indicates which part of the wall this material belongs to. An icon with a green highlight indicates that this side is currently selected.

To apply the material of one part of an object to another, drag and drop it. For example, to apply the brick material in the above illustration to both wall sides, grab the material (3) and drop it onto the other (4).

Clicking on a material while holding Option selects all identical materials. Alternatively, you can right-click on a material and choose Select in the List. This way you can update materials universally in a few clicks. For instance, replace all fabric parts of multiple furniture objects with a different material.

To locate an object’s material inside the library, double-click on it or right-click on this material and select Reveal in Library. Note that some objects in the library have materials that aren’t present in the library. As a rule, these objects are provided by furniture manufacturers and its logo is displayed in the library preview.

When you drag and drop a material onto another in the Object’s Materials list, you update not only the material but also its transformation settings.

### Adjusting the Texture Size and Orientation

Use the Texture Transform settings to adjust the texture size and orientation of materials applied to an object. This function is available for walls, ceilings, floors, wall panels, openings and niches if a material with a texture has been used. You can also adjust the texture of roofs and dormers.

The Texture Transform settings are useful for making a texture meet a wall edge or corner.

The Texture Transform settings in the Inspector differ from the Rotate and Scale parameters in the Material Editor. See the table for details.

<table>
<thead>
<tr>
<th>Texture Transform</th>
<th>Material Editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Works with materials applied to a limited number of object types.</td>
<td>Works with all materials that have texture.</td>
</tr>
<tr>
<td>Changes only the selected object.</td>
<td>Changes all the objects to which the edited material was applied.</td>
</tr>
<tr>
<td>Rotates a texture by any angle.</td>
<td>Rotates a texture 90, 180 and 270 degrees.</td>
</tr>
<tr>
<td>Resizes a texture with any side proportion.</td>
<td>Resizes a texture proportionally.</td>
</tr>
</tbody>
</table>
Sets up the physical texture tile size (in meters, inches, etc.)

<table>
<thead>
<tr>
<th>Sets up relative texture tile size.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live preview in the 3D view.</td>
</tr>
<tr>
<td>Texture preview on a sample object.</td>
</tr>
</tbody>
</table>

It is recommended that you use the *Texture Transform* controls if they are supported by the object that you want to modify.
Adding Materials to the Library

To add a material, click the gear button at the bottom of the *Materials* tab. It offers two commands for adding materials: **New Material** and **New from Selected**. The second option will create a customizable copy of the selected material. Both commands open the *Create New Material* dialog.
1 – Preview box.

2 – Preview mode switch: sphere, cube and flat surface samples.

3 – Matte / Glossy selector.

4 – Library of materials.

5 – Texture category selector.

6 – Library of textures.

To create a new material:

1. In the Materials tab of the Inspector, open the category that best suits the material you wish to create.

2. Click the gear button and choose New Material... in the pop-up menu.

3. Type the material name.

4. Choose either matte or glossy.

5. Select a material template. If you plan to use a texture, choose a white or light-gray template.

6. To create a textured material, select the Has Texture check box, choose the texture category.

   Select a texture from the library. To choose a custom image, scroll down the texture thumbnails, and click on Import Custom.... The maximum allowed texture size is 512 x 512 pixels. When you import a larger image, it will be scaled down retaining the original aspect ratio.

7. Click OK to save your material.

To add a custom texture, right-click on the texture library and choose Import Custom Texture....

To remove a custom texture, right-click on it and choose Delete Current Texture....

If you want to adjust all the parameters by yourself instead of using material templates, click the Advanced button to open the material editor.
Editing Materials

The *Inspector* window allows adding and adjusting materials. You can only change custom materials. The parameters of the supplied materials are displayed but cannot be modified, but you can make copies and modify them.

To open a material in the editor, double-click the material thumbnail in the *Materials* tab of the *Inspector* window (*Window > Inspector > Materials*).
Chapter 9: Working with Materials

1 – Preview box.
2 – Color settings.
3 – Reflection (100% creates a mirror, 0% is no reflection).
4 – Texture settings.
5 – Preview mode switch.
6 – Texture library.
7 – Texture preview zoom control.

**Preview Box**

The preview shows your material applied to one of three shapes: sphere, cube or flat surface.

The preview has its own spot lighting and ambient lighting.

**Setting Up Colors**

**Ambient Color**

Ambient light is the constant amount of light that is present everywhere in the scene. So, the ambient color is the color of ambient light reflected by the object.

**Diffuse and Specular Colors**

The way objects reflect light depends on the type of their surface. Uneven or granular surfaces reflect light in a number of angles that is called diffuse reflection. Glossy surfaces reflect light in one direction - this is specular reflection.

Generally, surfaces produce both kinds of reflection, but in different proportions.

The **Shininess** control lets you adjust the size of the specular reflection spot.
No specular reflection

Specular reflection with Shininess = 3

Specular reflection with Shininess = 25

**Self Illumination Color**

A self-illuminating surface looks like it is under the ambient light but is independent of ambient lighting. This feature can be used for elements of light sources (glass-shade, for instance).
**Materials with Texture**

Your material may or may not have a texture (check or uncheck Has Texture to control this). Textures can be taken from the built-in library (use the Categories drop-down list) or from a graphic file on your disk.

To import a custom texture, choose the Import Custom Texture item from the gear pop-up menu. The maximum allowed texture size is 512 x 512 pixels. When you import an image of a greater size for a new texture, the image will be scaled down. The original aspect ratio remains.

To remove a custom texture, right-click on it and choose Delete Current Texture....

The Scale slider adjusts the size of the texture pattern.

The Blending Method drop-down list has two color blending methods:
- Modulate – uses color and light features of the selected texture.
- Modulate and Lighten – uses color and light features set by the selected texture and by the color boxes above.

**The Actual Texture Size**

The texture for wall or floor tiles should render corresponding to the actual tile size. To achieve this, set the Scale slider in the material editor in the middle. Apply the texture to an object (wall or floor). Now you can set up the actual tile size. Select the object and click on a triangle to expand the Texture Transform section (Inspector, Materials tab) to access the texture size controls. Set the Texture Height and Texture Width to 12 if the tile size is 12 by 12 inches. Note that you should have inches selected in File > Project Setup.
Material Picker

The **Material Picker** tool is used to copy a material from one object to another instead of searching for this material in the library. If two objects allow you to apply the **Texture Transform** tool, the **Material Picker** copies the transformation settings too.

Using the **Material Picker** is convenient when you need to match materials for several furniture objects.

To copy a material:

1. Open the **Materials** tab of the **Inspector** window. Open the 3D view.
2. Select the destination object for which you want to change a material. Its material(s) will be shown in the **Object’s Materials** box.
3. Select the material(s) you want to change.
4. Click the **Material Picker** button to activate the tool.
5. With the **Material Picker** tool, click the source object to pick one of its materials, and repeat the clicks if necessary to go through its other materials, one at a time. Each time, the material picked will replace the selected material of the armchair.
6. Click the **Material Picker** button again to deactivate the tool.

When you point with the tool to an object, its material is displayed in the **Inspector** to the right from the **Material Picker** button.
Chapter 10: Lighting

Light Sources

To make 3D pictures more realistic, the program allows you to add and adjust light sources. The program simulates light from the sun and moon as well as light from electric lamps and fire. If enabled, reflections and shadows are shown in the 3D view.

The rendering quality depends significantly on the settings in the 3D Settings tab of the program Preferences.

To see reflections and shadows in the 3D view, you should turn them on. To do this, use the View > 3D View > Rendering Quality menu command or the 3D toolbar.

To render light, turn “Lights and Shadows” on. This can be done using the Render Quality buttons in the toolbar.
The Inspector window lets you control the properties of light sources. The light sources are listed in the Light Properties tab. They can be switched on and off by clicking the bulb icon.

**Sunlight and Moonlight**

The sunlight settings are available in the Environment panel.

To open it, choose Window > Show Environment or press Cmd-E.

**Artificial Lighting**

To add a lamp, drag it into your project from the Furnishing > Lamps section of the Library.

Lamps and candles behave almost the same as ordinary pieces of furniture.

The Light Properties tab of the Inspector window has the light parameters section. There you can adjust the luminosity and color of the light source and turn it on/off.

If a lamp has several bulbs, you can usually control them separately. This depends on the 3D model.

To create or modify lamps, use the Light Source Editor.

*Note: If your project has a lot of light sources and other objects, the 3D scene may be rendered quite slowly when you are walking in it. In this case it is recommended that you turn on the lights and shadows only if it’s necessary. For more information on performance, see the Troubleshooting section.*
Managing Light Sources in the Inspector

The *Light Properties* tab of the *Inspector* controls light sources. To open this tab, choose **Window > Inspector > Light Properties**.

The list of light sources in the *Inspector* contains light sources actually present in the project.

1 – Daytime buttons let you select phases of the daylight. This option affects the sunlight.

2 – The light source that emulates the sunlight. It is always present in the list.

3 – The selected light source.

4 – Parameters of the selected light source.

To change the brightness or color of a light source, select it in the list and change the parameters (4).

To turn the light on or off, click the bulb icon.

To adjust several light sources together, select them in the list (3). Then change their parameters (4).

A lamp may have several light sources. If you select such a lamp in the list (3), the *Inspector* will display the parameters (4) of all light sources of the lamp. To adjust the luminocity or color of several light sources at the same time, select them in the list (4).
The Light Source Editor

Live Interior 3D lets you create and edit light sources. To open the editor, select an object and choose Edit > Light Sources in the menu.

**Note:** The word “lamp” will be used in this section for any object that emits light (a lamp, a candle, a fireplace, etc.). The word “light source” will be used for a part of a 3D model that simulates a single light source and is actually the source of light in the 3D scene. One lamp may have one or more light sources.

Main Elements of the Light Source Editor

1 – Viewpoint selector. Choose one of six predefined points of view (from front, from back, etc.).

2 – Preview area.

3 – Day time selector. Allows you to preview the light source at a different time of day.

4 – Spotlight controls. They are activated when the current light source is of a spotlight type.

5 – Clean View switch. Hides/shows the spotlight direction and coordinate axes of the lamp.

6 – List of light sources.
7 – Location. These controls change the position of the current light source in relation to the lamp.

8 – Color controls.

9 – Glow Size control.

10 – Luminosity and Light Attenuation controls. They define how quickly the light fades out depending on the distance from the light source.

**Preview**

The preview shows the lamp in a small empty room. You can see how the light falls on walls, floor and ceiling.

1 – Glow.

2 – Location of the light source.

3 – Cone that displays the cone of rays and the location of the light source.

4 – A lamp object.
5 – Origin point and coordinate axes of the lamp. The colors of axes correspond to the colors of X, Y and Z coordinates in the Location section.

6 – Reflection of the light on the floor.

To change the point of view, place the cursor over the preview box. Press the mouse button (left one for 2-button mice) and move the mouse around. To choose a predefined view, use the view point selector. To restore the default view, double-click on the preview.

To preview the lamp in different day or night light conditions, use the daytime selector.

The preview zoom buttons are located above the preview to the right.

**Light Source List**

A lamp may have several light sources. To select and modify one, click on it in the list.

To add a light source, click the plus button below the list. To remove the selected light source, use the minus button.

A light source has the following parameters next to its name:

1. **Type** – can be set to Point (omni-directional light) or Spot (directional light).

2. **Glow** – different types of glow that appears around the light source. The size of the selected glow can be adjusted by the **Glow Size** slide bar below the preview.

3. **On/Off** – turn the light on or off. This is the same option that can be found in the **Light Properties** tab of the **Inspector** window. This option can be useful for switching off all the light sources except the one that you are adjusting.
**Location**

To move a light source to another location, use the **Location** controls.

The location is calculated according to the coordinate system of the lamp. The zero point is shown in the preview.

**Light Attenuation and Luminosity**

The **Light Attenuation** parameters (Constant, Linear and Quadratic) control how quickly the light fades out depending on the distance from a point in the 3D space to the light source.

These parameters are used by the rendering engine for calculating the attenuation factor:

\[ Af = \frac{1}{(Kc + Kl*D + Kq*D^2)} \]

Af – Attenuation factor; Kc – Constant; Kl – Linear; Kq – Quadratic. D – distance from the light source to a point in the 3D space (when the program is calculating light for this point).

The **Luminosity** parameter changes the common luminosity of a light source. It does the same as the **Luminosity** control in the **Light Properties** tab of the **Inspector** window.

Tip:
Adjust the **Light Attenuation** parameters when the **Luminosity** slider is in the middle.

The images below demonstrate how parameters affect the light spot.
Default parameters:
Constant = 0.50  
Linear = 0.30 
Quadratic = 0.00

Constant increased:
Constant = 3.00  
Linear = 0.30 
Quadratic = 0.00

Linear increased:
Constant = 0.50 
Linear = 2.00 
Quadratic = 0.00

Quadratic increased  
(light fades quicker than above):
Constant = 0.50  
Linear = 0.30 
Quadratic = 0.80
**Directional Light Settings**

To set up a beam of light, there are additional parameters. They are available when the type of light source is *Spot*.

**Spot Direction** angles are measured in degrees. When you adjust one of angles, the others may change automatically.

- Spot Angle = 80°  
  Spot Falloff = 1

- Spot Angle = 40°  
  Spot Falloff = 1

- Spot Angle = 80°  
  Spot Falloff = 12
Colors

You can adjust **Diffuse Color** (1) that defines diffuse spot color, and **Specular Color** (2) – the reflection of a light source on glossy surfaces. The **Diffuse Color** can be also adjusted in the *Light Properties* tab of the *Inspector*. 

![Image of a light source with labels 1 and 2]
Chapter 11: Using Cameras

Cameras are special objects used to specify locations and perspectives in the 3D space for taking pictures. Cameras can be also used as the starting point for walking around in 3D. Choosing such a predefined camera, you can quickly jump to a specified location at any time.

By default, five cameras (views) are set up in the project. Their locations are fixed (you cannot remove them), and they are not shown on the floor plan.

You can add more cameras to save your favorite points of view. Custom cameras behave in almost the same way as ordinary objects, and they are visible on the floor plan. You can change their direction, move and delete them.

Let’s suppose you want to take pictures of a room from three points, change the color of walls or furniture, take another series of pictures, and then compare them to choose the best color combination. In this case, you will put three custom cameras in the desired positions, and after changing the wall color, select a camera from the list and save a picture.

Managing Cameras in the Inspector

The Cameras Properties tab lists all the cameras in the current project: predefined, custom and movie cameras. To open this tab, choose Window > Inspector > Cameras.

Unlike predefined cameras, custom cameras and movie cameras can be added and removed by the user.

The Inspector lets you select any existing camera, including movie cameras. The selected camera defines what is displayed in the 3D view.

New cameras and movie tracks have default names. To change the name, double-click on it.
1 – The list of predefined cameras. Their quantity is constant. Their location in the 3D space cannot be changed.

2 – The list of custom cameras.

3 – The list of movie tracks. Sub-items of each movie track are movie cameras. For more information, see Chapter 4, “Working with Projects“ > "Creating Movies".

4 – The **Delete** button lets you delete selected custom cameras, movie tracks and movie cameras.

5 – **Add Movie Track from 3D Viewpoint** (**Add Movie Camera from 3D Viewpoint**) lets you add a movie camera to an existing movie track or create a new track. The button is activated when the 3D view is visible.

If a movie track or a movie camera is selected in the list, clicking the button adds a new camera to the current movie track. Otherwise a new movie track is created.

The location and orientation of the added camera corresponds to your current position and point of view in the 3D view.

6 – **Add Camera from 3D Viewpoint** lets you add a new camera. The location and orientation of the added camera corresponds to your current position and point of view in the 3D view.

7 – Controls that allow you to adjust the elevation and orientation of custom cameras and movie track cameras. These tools can also control the current point of view that isn’t linked to any camera.

8 – Export an image or create a movie. The function of this button depends on the type of selected camera.

**Export 3D View...** – export a picture from the current 3D view. This button does the same as the **File > Export 3D View** menu item.
Chapter 11: Using Cameras

Record Movie... – start the process of creating a movie from the selected movie track.

Choosing a Camera

All predefined and user cameras are available in the Cameras Properties tab of the Inspector window (the User Cameras section). Custom cameras are also listed in the Project Tree.

To jump to a saved position in the 3D view, select a camera in the Inspector.

If you select a custom camera and walk around in the 3D view, the camera will change its location to reflect your current position. This way you can better adjust the location and direction of the camera.

The preview in the Project Tree displays the view of the selected custom camera.

To prevent the occasional movement of a camera, lock it in the Project Tree. Alternatively, click on another object in the 3D view (a wall, for instance) to deselect a custom camera and then start walking.

A camera icon in the top right corner of the 3D view indicates that a custom camera has been selected and that its position can change.

Adding and Deleting Cameras

To add a camera, use the Camera tool from the toolbar above the 2D view.

While walking around in the 3D view, you may want to save some viewpoints to return to them later. To do this, click on the Add camera from 3D Viewpoint tool in the Cameras Properties tab of the Inspector.

All user cameras are listed in the Cameras Properties tab of the Inspector and in the Auxiliary section of the Project Tree.
To delete a custom camera, select it in the *Inspector* and click on the “x” button.

To rename a camera, double-click on its name in the *Inspector*.

Cameras can be also renamed or deleted using the *Project Tree*.

**Moving Cameras in the 2D View**

To move a camera, drag it with the mouse, or select it and press the arrow keys. This results in parallel movement (without rotation).

When selected, the camera has two handles: the front one (the upper dot on the picture) and the central one.

When you move the front handle with the mouse, the camera turns around the central handle point. The camera location stays unchanged.

By dragging the center handle, you will move and rotate the camera at the same time.

**The Viewing Frustum of the Active Camera**

The viewing frustum and the view direction of the active camera are displayed in the 2D view. Use them to point a camera to some place or object. You can turn the frustum on or off using *View > Show 3D Viewpoint*.

**Printing a Floor Plan without Cameras**

Most likely, you do not need to have cameras visible on the printed floor plan. To hide cameras, open the *Project Tree* (*Window > Project Tree*), select the camera(s), and click on the “eye” icon to make the camera(s) invisible.
Chapter 12: Auxiliary Objects

Auxiliary objects are objects that help you create a project. They appear on the floor plan but aren’t visible in the 3D view. In this chapter these objects are described: text annotations, images and measurement tools.

There are also guide lines and cameras in the program. These objects are described in separate sections.

Auxiliary objects are grouped together in the Project Tree.

Text Annotation

The Text Annotation tool is used for adding text comments to the 2D drawing.

To activate the tool, choose Insert > Text Annotation. Or use the toolbar button.

To format text, use the tools in the 2D Properties tab of the Inspector window. The font size doesn’t change when you choose another scale in the Project Setup dialog.

Text boxes can be moved and resized in the same way as other objects (by moving the resize handles while the object is selected).

The text boxes used in the project are listed in the Project Tree. You can use the Project Tree to lock the text boxes or make them invisible.
To add text, select the *Text Annotation* tool, draw a box in the layout, and then type text.

To edit text, double-click on it.

**Note:** There is another type of text box in Live Interior 3D: *text labels*. This is a part of a "floor" object. For more detail, see Chapter 7: “Working with Objects” > “Ceilings and Floors”.
Measurement Tool

The Measurement tool lets you measure and show the distance between two points in your layout.

To add a dimension line:

1. Select the Measurement tool. This tool shares a button in the tool bar with another tool. To choose the Measurement tool, click the tool bar button and hold it until a pop-up tool list appears.

2. Click in the layout to select the first point.

3. Click in the layout to select the second point.

4. By the last click, select where you want the measurement to be displayed.

The dimension line object has three handles when selected. The middle handle lets you adjust the distance between the numeric value and the object you are measuring. The handles on the ends define the distance to be measured.

The measurement units will be the same as the ones used for the rulers. You can change them in the Project Setup dialog. To hide the measurement units, use the Suppress Units option.

The measurement tool can be snapped to object sides or to handles (of a wall, for instance). In this case it moves and changes its size together with the object. Placing handles of the measurement tool near these points will cause it to move separately from an object. Zoom in the 2D view and move the handles of the measurement tool around to be sure that they have snapped to the object.
To change the font, size or color of text, use the 2D Properties tab of the Inspector. The font size doesn’t change when you choose another scale in the Project Setup dialog.

The Information bar displays the total length of all selected measurements.
Images

Images on the Floor Plan

An image can be added to your floor plan. This image may contain your logo, the floor plan or other information.

Adding an image with a floor plan is useful because you can see where walls, furniture and other are located. For this purpose, a floor plan created in other program should be saved in a graphic format such as PDF, TIFF or JPEG.

To add an image, choose the Insert > Image menu command. Or drag and drop an image from Finder to the 2D view.

The image properties are located in the Object Properties tab of the Inspector.

The image size in the Inspector is displayed in the measurement units selected for the project.

The Project Tree lets you control the Visibility and Lock options.

Images in 3D

To display an image in the 3D view, you should apply it to an object as a material (texture).

There are several ways:
  • Create a custom material, and then apply it to the object.
  • Drag an image from Finder and drop it onto an object. This is the simplest way. The program will create a custom material automatically and place it in a category with imported materials. The texture will more than likely be tiled on the object’s surface.
Creation of a Wall Picture

1. Right-click on an image in Finder to open the Info pane. Find out the aspect ratio of the image sides.

   We have:
   \[ \frac{765}{473} = 1.62 \]

2. Add a wall panel from the library to your project.
3. Resize the panel using the *Object Properties* tab of the *Inspector*. Let’s say that we need to have the height 1.5 m. The width will be calculated using the aspect ratio of the image:

\[ 1.5 \times 1.62 = 2.43 \text{ m} \]

4. Drag the image from Finder and drop onto the panel. Alternatively, you can choose a material in the *Materials* tab of the *Inspector*. 
5. The image is tiled. Correct this using the *Texture Transform* tool in the *Materials* tab of the *Inspector*. Make sure that the *Preserve Texture Aspect Ratio* is on (the chain icon indicates this). Input up one of the image dimensions, for instance the width.

![Texture Transform Tool](image.png)

The same way you can apply a texture to other objects. But remember that the *Texture Transform* tool works only with walls, wall panels, ceilings, floors.
Chapter 13: Guidelines and the Layout Grid

Guidelines

Guidelines allow you to align objects on the floor plan and mark up the layout before drawing and placing objects. The guidelines are not exported.

To add a guideline:

- Place the mouse pointer over the ruler, press the mouse button (the left one if you have a 2-button mouse) and drag the guide into the drawing. Then release the mouse button.

- Alternatively, you can choose the Horizontal Guide or Vertical Guide item in the Insert menu.

To select a guideline, click on it with the mouse. The selected guideline becomes highlighted.

If you place the mouse pointer over a guideline, the pointer changes into a bidirectional arrow. Ctrl-clicking (right-clicking) a guideline will open its context menu.

To move a guide, drag it with the mouse.

To remove a guideline, select it and press the Delete key, or use the context menu.

Like other objects, the guides are listed in the Project Tree. There is the Lock option in the Project Tree: by setting it, you will prevent the guide from unwanted movement.

Live Interior 3D also has smart guides. Smart guides are temporary guides that appear when you draw walls, floors, or ceilings, and when you move objects. Smart guides are aimed to help you align objects.
Layout Grid

In addition to layout guides and smart guides, you can use the layout grid when arranging objects in the 2D layout.

The **View > Show Grid** menu shows and hides the grid.

Grid spacing is linked to the measurement units used for rulers and to the layout scale. The program changes grid spacing automatically when you change the scale of the 2D view.

One vertical and one horizontal line of the grid cross the zero point of the rulers.

**Aligning Objects to the Grid**

Only layout guidelines can snap to the grid. Objects do not snap to the grid.

To align objects to grid lines:

1. Add a guideline (using the **Insert** menu, or in another way).
2. Move the guide to snap it to the grid.
3. If necessary, lock the position of the guide in the *Project Tree*.
4. Align the object(s) to the guideline.
Chapter 14: Solving Problems

Troubleshooting

Cannot Register the Program

See recommendations in Chapter 1: "Introduction" > "Registration".

Cannot Open the Program

- The program cannot find its files or folders, or they are damaged.

  Solution: Re-install the program. Before this it is recommended that you remove files and folders according to the uninstallation procedure in Chapter 1: "Introduction" > "Removing the Program".

- Incorrect program settings were saved in the program preferences file.

  Solution: Delete the preferences file `com.belightsoft.LiveInterior3DPro.plist` from the `~/Library/Preferences/` folder.

- The program cannot open a broken document.

  Solution: Open the program by double-clicking its icon, then try to open the document.

Cannot Select an Object

The object you cannot select may be locked. Find the object in the Project Tree to verify this.
Performance Issues

To speed up 3D rendering:

1. Check the settings in the 3D Settings tab of the Preferences dialog.
   - Set the Full Scene Anti-aliasing parameter to a lower value or None.
   - Set the Reflections Quality parameter to a lower value.
   - If you have an option to choose between the Stencil Shadows or Shadow Maps shadow rendering, select Shadow Maps with a lower value of the Shadow Maps Quality. In the Stencil Shadows mode rendering works slower but creates more realistic pictures. Switch to Stencil Shadows in order to create screen shots or movies.
   - Set Shadow Casting Lights to Nearest 2 or Nearest 4. This way you limit the number of light sources considered in the current 3D scene.
   - Make the 3D view window size as small as possible for comfortable work. This is effective on computers with small amount of video memory.
   - While you are working on the project, choose View > 3D View > Rendering Quality > Without Lights and Shadows mode in the main menu. Choosing Lights Only is less effective.
   - On a Mac with the Retina™ display, deselect the Retina™ High Resolution check box.

2. Keep this in mind when you are editing your project.
   - In the Project Tree hide those objects that aren’t critical for your current work, or those which are invisible from the current point of view. For example, if you have a very detailed model of the car in the garage, or a lot of trees outside, hide them while you are editing the interior of the rooms.
   - Turn off the light sources located outside the room you are editing, and those which aren’t critical for the current 3D scene. You can control the light sources on the Lights Properties tab of the Inspector.
   - Objects shouldn’t plunge into the floor, ceiling or walls. To be sure that an object is placed properly, activate the Glue By (appropriate object side) option, and move the object around to let it snap to the floor, ceiling or other nearby surface. Be careful when you change the object’s elevation manually.
• Draw the walls carefully. Red circles on the floor plan indicate the places where walls join not neatly. Fix all such issues.

• Avoid opening more than one project at the same time. Such projects opened in the background consume computer resources that could be used for the project you are working on.

• Don’t use too many reflective materials. The program performance can drop down if you apply reflective materials to a large number of small objects.

• Avoid creating many variations of the same object using the Type and Representation dialog (3D properties) or in the SketchUp application. The more different objects are present in the project, the longer rendering takes. The program works faster with a number of copies of the same object rather than with the same number of different objects (of the same complexity). The program uses one pattern object for all its copies in the project. An object even slightly modified can be treated it as a completely different one.

The following settings can also help you optimize the program performance.

<table>
<thead>
<tr>
<th>Parameter or Property</th>
<th>Where to Change</th>
<th>Set To</th>
<th>Affected View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decrease Quality when Moving (does not increase the speed of walking when Rendering Quality is set to “Without Lights and Shadows”)</td>
<td>Program Preferences -&gt; the 3D Settings tab</td>
<td>No Lights and Shadows</td>
<td>3D</td>
</tr>
<tr>
<td>Textures Filtering</td>
<td>Program Preferences -&gt; the 3D Settings tab</td>
<td>Bilinear (setting None can make the quality of the 3D picture unacceptable)</td>
<td>3D</td>
</tr>
<tr>
<td>Cast Shadows (switch off shadows of unimportant objects, and when the shadow is invisible because of the object location)</td>
<td>Inspector window -&gt; the Object Properties tab</td>
<td>Off</td>
<td>3D</td>
</tr>
</tbody>
</table>
Red Circles on the Floor Plan

Every red circle on the floor plan indicates a place where wall segments are joined incorrectly. A bad joint may cause problems with creating automatic floors and ceilings, displaying the affected walls in the 3D view, etc.

To fix the problem, you should move a segment aside and then return it back to its place. If this doesn’t help, delete the affected segments and add them again.
Chapter 14: Solving Problems

Printing Problems

The printer does not print:
- Check the cable connection between the printer and the computer.
- Make sure the printer is turned on.
- If several printers are installed in your system, make sure the correct printer is selected in the program.
- Check the paper source selected for the printer: some printers have several input trays.
- Make sure paper is properly loaded into the printer.

If your printed text or images have low quality (light stripes or gaps on the printout, the printout fades out, you see wrong colors), check the ink or toner level.

If the printout is blurry, or ink dries out for a long time:
- Make sure the paper meets the printer specification requirements.
- Check if the correct side of the paper is used.
- Check if the proper paper type is selected in the printer settings.

To understand the cause of the problem, make a test printout from another software. If the problem persists, the problem is connected with the hardware.

For more detailed guidance, refer your printer User’s Manual.
Known Issues and Limitations

The developer is constantly working to resolve problems that appear in the software. The developer is aware of the inconveniences and problems listed below.

To avoid submitting a duplicate problem report, please check if the issue is already listed here.

**The 3D View is too Small**

The 3D view is too small or it doesn’t expand by resizing the main window.

Unlike the 2D view, the size of the 3D picture is limited by the amount of the video memory in your computer. To find out whether the problem is connected with a broken 3D picture (possible bug) or memory limitation (normal behavior), look at the 3D picture in a blank document. The 3D View should have a plain gray background. The 3D picture should have a shadow along two or more opposite borders. When you make the main window smaller, the 3D picture may take all the space in the view area. In this case the gray background and shadow will disappear.
Video Cards that do not Support Per-pixel Lighting

The following and earlier models don’t support per-pixel lighting: GeForce4 Ti, GeForce3, GeForce2 MX/4 MX, Radeon 9000/9200, Radeon 8500, Radeon 7200/7500, Radeon 7000.

To find out which type of video card is in your computer, click the Apple menu and choose About This Mac. Then click the More Info... button to open the system profiler and navigate to the Graphics/Displays section.

The Project Exported to SketchUp Contains Unwanted Triangles

The project or objects exported in Trimble SketchUp format contains unwanted triangles.

The incorrectly exported model looks in SketchUp this way:

The correctly exported model:
To solve the problem, in the 3D Settings tab of the program Preferences (Cmd-,) select the Stencil Shadows shadow technique instead of Shadow Maps before exporting.

**VRML Player Displays a Project too Dark**

This can happen because players support limited number of simultaneous light sources. The VRML 2.0 specification requires for support at least eight light sources. If your VRML file is displayed much darker then your project in the 3D view in Live Interior, try to turn off some light sources and export VRML again.

Different VRML players support different number of light sources. For example, Instant Player 2.0.0beta7 worked normally only with seven (or less) light sources.

Note that the spotlight in a VRML player should also be considered as a light source. Turning it on you may exceed the limit.

**An Object Doesn’t Cast a Shadow**

Make sure that:
- The appropriate rendering mode is activated. Choose View > 3D View > Rendering Quality > Lights & Shadows.
- The object has the Cast Shadow check box selected in the Object Properties tab of the Inspector.

If there is no shadow anyway, check how many triangles the object has. If the number of triangles indicated in the 2D toolbar is greater than 32000, the object cannot cast a shadow.
Technical Support

The developer of Live Interior 3D offers free technical support.

By E-mail:
support@belightsoft.com

Technical support form on BeLight’s website:
http://www.belightsoft.com/support/

Forum on BeLight’s website:
http://www.belightsoft.com/forum/

When reporting a problem, please make sure to specify:
- The version of Live Interior 3D you are using.
- The version of Mac OS X installed on your computer.
- Your previous actions that could have lead to the problem.
- If the problem persists, describe how to reproduce it.
- When necessary, illustrate your report with screenshots (press Cmd-Shift-3 to save a screenshot on your Desktop).