Page 1 of 1

Two-level room how to? FXAA stopped working on Surface RT.

Posted: September 26th, 2014, 11:18 am
by SargeT
Hi!
I got the pro version, really just in time for me and great to use the app on my ARM-based Surface RT on the go.
I have a couple of questions, couldn't find any solution in the manual (manual didn't seem very full actually, more like quick guide).
1. How to build a home like on the scheme? Sorry for the quality.
home.jpg
home.jpg (28.6 KiB) Viewed 3215 times

Specifically, how to unite the stories marked red into one great room or make vertically biased (on different heights) floors/rooms?
2. As I started using the app on my Surface RT (1st gen), it was rather long ago, but I believe I saw the FXAA working, and that was great for a mobile device. Suddenly it stopped working, and that made using the app quite inconvenient. I even tried reinstalling, but that never helped. How to get antialiasing back to work?
Thank you in advance!

Re: Two-level room how to? FXAA stopped working on Surface R

Posted: September 28th, 2014, 2:24 am
by Nick
Hi

1. The Ceiling Opening tool can help you. This tool visually removes a part of the slab, but the latter will still exist. This means that you won't be able to add a window across the slab (only above or below it). Also the library staircase objects have ceiling openings as a property. Surrounded with a bigger ceiling opening, the one which belongs to the staircase will be visible. To avoid this partially, you can apply the glass material to what you don't want to see. A better way is to download a staircase from Trimble Warehouse. Objects from there don't have the ceiling opening properties.

2. Antialiasing can be turned on/off in the program Preferences. Swipe over the right side of the screen to open settings and then choose the Preferences option.

Nick

Re: Two-level room how to? FXAA stopped working on Surface R

Posted: September 28th, 2014, 12:48 pm
by SargeT
Hi Nick,

1. Thanks for the tip, I played with that for a while. I assume this is a workaround but not a solution because I you can't put a closet or a window into a room on it's own different height (if it's above a ground garage while other rooms start from a basement 1 meter above ground), so are you going to implement separate levelling functions?
2. Sure its the first thing I tried. You have this option off by default in your app, so I turned it on and was happy it worked. Another day it stopped. Switching it in preferences won't help. Any other advices?

Thanks!

/оффтопик
Вот что особенно рвёт шаблон в имперских исчислениях, так это то что 12:24 pm это раньше 10:48 pm, никак не мог понять почему ваш пост написан раньше моего :)

Re: Two-level room how to? FXAA stopped working on Surface R

Posted: September 29th, 2014, 6:49 am
by Nick
Hi SargeT,

1. I wouldn't expect this feature soon but the programmers are aware of this issue.
There is another workaround. You can make your building to have one storey instead of two as the right side of your drawing requires. Then add a fake floor to the left part. A shape from the built-in library can be used for it.

2. What version of Live Interior do you have? We've updated the program recently. It is interesting if the problem repeats in the last version.

Basically, the program can switch antialiasing off when it doesn't have enough resources to render the 3D scene at higher quality. Maybe this has happened on your computer. We've got an ARM-based device for tests, and antialiasing is off on it. So we are working on this issue.

Nick
--------
Да, со временем получилось забавно.

Re: Two-level room how to? FXAA stopped working on Surface R

Posted: September 30th, 2014, 4:17 am
by Eugene Golushkov
1st gen Surface RT is based on Tegra3 chipset, as well as the most of Windows RT machines of the 1st generation. We have similar test machine, Lenovo Yoga 11, based on Tegra3 too. Current video drivers reports no MSAA antialiasing support on it. Also, at several places I read that one of enhancements made for Tegra4 chipset was antialiasing support.
Even without hardware MSAA support it could be emulated in software, either in video driver or in application. So it is possible, that you see MSAA support on some older version of video driver that is disabled now.

Re: Two-level room how to? FXAA stopped working on Surface R

Posted: September 30th, 2014, 7:49 am
by SargeT
1. That's a more advanced solution, but still doesn't fit my needs because my plan is too complex so it needs to be built of shapes from the ground to the roof... Thank you, anyway, for the first solution, it's more suitable in my case.
2. Version 1.4, updated last week. Well, on one side, tegra 3 is officially said to support some AA (i was wrong, not fxaa which is a great thing due to zero performance loss even on weaker chips, but csaa), and I remember I saw it working in some apps on my RT, but on the other side I got a bulk of devices here and there is a slight chance I mixed up something...
As to resources, surface rt has 2gb ram and besides i tried rebooting, that doesn't help. Well, anyway, new features like #1 are great but I hope you find some software workaround for edge antialiasing (googling reports there are some), AA is not essential to games but definitely is to precise modelling and even viewing and demonstrating on mobile device.
Serge