[L&A 1.6 v451] Printing? --> NSRangeException

dr3do
New member
Posts: 3
Joined: June 2nd, 2011, 4:11 am

Postby dr3do » June 2nd, 2011, 4:18 am

Hi there

I'm running L&A on OSX 10.6.7. When I'm trying to print a label (on a LabelWriter 450 DUO) I get in Console message like this:

Code: Select all

02.06.11 11:10:21    Labels & Addresses[26235]    *** -[NSCFArray objectAtIndex:]: index (9) beyond bounds (9)
02.06.11 11:10:25    Labels & Addresses[26235]    NSExceptionHandler has recorded the following exception:
NSRangeException -- *** -[NSCFArray objectAtIndex:]: index (9) beyond bounds (9)
Stack trace:  0x9502ad24  0x930bf509  0x932373f8  0x9323736a  0x91f9c1f0  0x91eefdee  0x74750  0x78a3f  0x91083816  0x910824b4  0x910827e9  0x910809d3  0x91081948  0x91081948  0x91081948  0x91081948  0x91081948  0x91081948  0x91081948  0x91080547  0x9107ce8e  0x90fdda73  0x90fa6d94  0x90fd82a6  0x931e3e02  0x9319fd8d  0x9319f464  0x9319f291  0x92194d60  0x92194a53  0x9219499c  0x90fae7dd  0x90fae01e  0x90f702a7  0x90f68339  0x1660e  0x16535  0x2

I have then to force quit L&A. Printing from other applications does work fine.

Any idea what's wrong?


Cheers,
dr3do
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » June 2nd, 2011, 5:49 am

Hi dr3do,

What type of paper did you use?

Did you specify in the program this paper type?

At what printing stage the error message appears in the log: when the print dialog of L&A opens, when you click Next in it, or when you click Print in the system print dialog?

If the preview of L&A opens, does it display the label correctly?

If you can get to the system print dialog, select opening the label in the system preview. Does it look normally?

Nick
dr3do
New member
Posts: 3
Joined: June 2nd, 2011, 4:11 am

Postby dr3do » June 2nd, 2011, 6:37 am

Hi Nick,

thanks for you fast reply! #thumbsup


What type of paper did you use?

Dymo 11256 Name Badge Labels (41*89mm)

Did you specify in the program this paper type?

Yes.

At what printing stage the error message appears in the log: when the print dialog of L&A opens, when you click Next in it, or when you click Print in the system print dialog?

Immediatly after opening the printer dialog. After while of rendering the preview - which takes in L&A really long, compared to other apps - I can see the printing preview. The "next" or "cancel" won't work any more --> Force quit.

Right now I have tested the printing with Word, Excel and Bento... eveything fine /smooth. No errors.

If the preview of L&A opens, does it display the label correctly?

Yes.

If you can get to the system print dialog, select opening the label in the system preview. Does it look normally?

Yes.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » June 2nd, 2011, 10:43 am

Probably you are printing many addresses and one of them causes the problem. In this case printing a single label could work.

Please check the settings in the system print dialog. Make sure that the Presets is set to Standard.

Try to print:
1. An empty label.
2. One address (or some text) with no graphics.
3. One label with your original content in raster mode. To activate this mode, open the Preferences (Cmd-,) and select the "Print document as raster image" in the Printing tab. After this experiment, don't forget to deactivate this printing mode.

Nick
dr3do
New member
Posts: 3
Joined: June 2nd, 2011, 4:11 am

Postby dr3do » June 2nd, 2011, 10:51 am

Nick wrote:Probably you are printing many addresses and one of them causes the problem. In this case printing a single label could work.

I'm sorry to "destroy" your thought: It's already a single label.

1. An empty label.

OK, I'll try this later, because right now I'm not in my homeoffice.

2. One address (or some text) with no graphics.

Already done, because I thought that the contentcould Did not work.

3. One label with your original content in raster mode. To activate this mode, open the Preferences (Cmd-,) and select the "Print document as raster image" in the Printing tab. After this experiment, don't forget to deactivate this printing mode.

OK, later too.

Return to “Labels & Addresses / Mail Factory”

Who is online

Users browsing this forum: No registered users and 2 guests