Using the iPhoto,Aperture,Other Folder (clipart) Icon CRASH

lindas
New member
Posts: 7
Joined: August 27th, 2015, 5:53 pm

Using the iPhoto,Aperture,Other Folder (clipart) Icon CRASH

Postby lindas » August 27th, 2015, 6:06 pm

I got the program installed (had to Allow programs downloaded from Anywhere & I left that checked to keep testing this issue).

All I do is open the program and choose New Blank. It opens with the Show Clipart Collections open (this is clipart that came with SP4). Well, I want to open my own Clip art Folder. So I click on the iPhoto,Aperture Other Folder Icon (right next to Show Clipart) and Swift Publisher 4 just CRASHES.

It opens a dialog box where I can Ignore, see Detail or Reopen SP 4.

I have tried deleting ALL program caches. Resetting Permissions. Starting from a NEW user account. Starting in SAFE MODE. I tried it on my Desktop Mac and my MacBook Pro. I tried uninstalling Swift Pub version 3.

It always crashes when I try to use that Icon for clipart (it looks like a camera).

I am using Mavericks 10.9.5.
I have Plenty hard drive space -- over 500 gigs free.
I have 16 megs of RAM installed.

This is really disappointing. I have never had such trouble with Swift Publisher. I have used SP 3 for years now. This icon gives me no trouble. I use and need this function of Swift Pub.

HELP!!
Yes, I have sent in a trouble ticket this morning and have not heard back yet. (about 12 hours ago) I did also send in a crash text file.

Thanks for any help.
javierdealfonso
New member
Posts: 3
Joined: August 29th, 2015, 3:42 pm

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby javierdealfonso » August 29th, 2015, 3:49 pm

Exactly the same problem here on my two macs (mini and macbook air) with Mavericks 10.9.5.
The "iPhoto, Aperture Other Folder" Icon crashes the app.

Regards,
lindas
New member
Posts: 7
Joined: August 27th, 2015, 5:53 pm

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby lindas » August 29th, 2015, 4:21 pm

Hello. Yes, it's frustrating! :wink:
The last contact with them they said, "...Thanks for letting us know. Yeah, it looks like a bug. We're working on this issue. In some time our support team will contact you to solve it. Thanks ."

So they recognize and acknowledge that it is a bug. Hopefully they will resolve the issue and release a fix...Soon! :D

Thanks for posting!
javierdealfonso
New member
Posts: 3
Joined: August 29th, 2015, 3:42 pm

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby javierdealfonso » August 29th, 2015, 6:23 pm

You're welcome. Nice to know that we are not alone :)
axys
Member
Posts: 364
Joined: February 27th, 2007, 4:30 am

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby axys » August 30th, 2015, 3:47 am

I'm running 10.8.5 and can't reproduce this bug, either on my MacMini or MacBook Air.
SP user for 11 years --- v2, 3, 4, 5.0.6 --- Mac OS 10.11.6 --- iMac Retina 5k 27" late 2015
javierdealfonso
New member
Posts: 3
Joined: August 29th, 2015, 3:42 pm

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby javierdealfonso » August 30th, 2015, 5:51 am

It must be a Mavericks 10.9.5 related issue :/
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby fonetico » August 30th, 2015, 10:44 pm

You can add me to the list.
10.10.5 works fine.
10.9.5 crashes.
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CR

Postby Nick » September 2nd, 2015, 8:23 am

Hi,

The program crashed when you tried to access your photos only on OS x 10.9. Version 4.0.1 has this bug fixed.
SP 4.0.1 is already available on our site, and it is under reviewing on App Store.

Nick
lindas
New member
Posts: 7
Joined: August 27th, 2015, 5:53 pm

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CRASH

Postby lindas » September 1st, 2016, 6:25 pm

This issue has returned in a new way. :cry: :cry:

I open an existing document or create a brand new one.

I can add clip art from SP4(4.0.4) Gallery, and change the category or item or do a search and no issues.

If I choose my own Folder, all seems okay, until I click on a different sub-folder or folder. Everything locks up. If I try to close SP4, the graphics of the program turn white - I can't see the words in the dialog box and can't close any boxes or file that is open.

I have to Force Quit and start over.
All is okay as long as I don't change the folder in my own collection using the iPHoto, Aperature, Other Folder option.

So, it's kind of the same problem and I just haven't been doing that much clip art, at least not enough to notice this issue.

I'm now using El Capitan 10.11.6.
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: Using the iPhoto,Aperture,Other Folder (clipart) Icon CRASH

Postby Nick » September 2nd, 2016, 7:43 am

Hi

I cannot reproduce this problem on my computer. Please give more details.
1. When you select a Custom Folder in the left panel, you can choose a sub-folder directly. Will this cause the same problem?

2. How many images are in the top level folder (the one you select) and in the sub-folder clicking on which would lead to the problem?

3. Try to open some of the images that you wanted to use in Swift Publisher in Preview.app Will it work? This way we can ensure that the files are accessible and not broken.

4. Send your Console log to support@belightsoft.com - it may contain error messages related to the problem. To do this, try to access a sub-folder again. When the program stops responding, open the Console application from the Applications/Utilities folder. Choose "All Messages" in the left panel. Then select File > Save a Copy As in the menu of Console to save the log.

Nick

Return to “Swift Publisher”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests