Page 1 of 1

Preview in Font Panel…

Posted: February 14th, 2017, 11:07 am
by Jean-Jacques Boutaud
HI, Nick
(PW 1.2.1 build 3069) OS X 10.11.6 MBP UNIBODY 17")
As you can see in this screenshot, the preview feature of the font panel doesn't seem to work, displaying Helvetica all the times:
Image
Note: Text in a document is updated when changing font from the font panel.

Re: Preview in Font Panel…

Posted: February 15th, 2017, 6:42 am
by Nick
Hi Jean-Jacques,

Thanks for telling about this problem. It might relate to Printworks or to the Fonts panel. Our developers will check this.

I managed to repeat the problem that you described by selecting two portions of text with different fonts applied and then choosing a new font. Not all combinations of fonts can confuse the Fonts panel in this way. I also could reproduce the same problem in TextEdit.app.

Nick

Re: Preview in Font Panel…

Posted: February 15th, 2017, 7:44 pm
by Jean-Jacques Boutaud
thanks Nick
in TextEdit, the Font Preview feature seems to be working, yet

Re: Preview in Font Panel…

Posted: February 16th, 2017, 10:59 am
by Nick
There is a chance that my steps to reproduce the problem differ from yours. Here is what I did (in both SP and TextEdit):
1. Type a few characters.
2. Select a portion to the left and apply Courier New, Bold Italic.
3. Make the rest Didot, Regular.
4. Select the whole text and click on different fonts in the Fonts panel. With some fonts, the problem will repeat, and it won't with others.

My guess is that selecting fonts that don't have the Bold Italic typeface will confuse the Fonts panel.

If you can repeat the problem by following other steps and you know them, please let me know.

Nick