Preview in Font Panel…

Jean-Jacques Boutaud
Member
Posts: 1635
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Preview in Font Panel…

Postby Jean-Jacques Boutaud » February 14th, 2017, 11:07 am

HI, Nick
(PW 1.2.1 build 3069) OS X 10.11.6 MBP UNIBODY 17")
As you can see in this screenshot, the preview feature of the font panel doesn't seem to work, displaying Helvetica all the times:
Image
Note: Text in a document is updated when changing font from the font panel.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
Nick
Member
Posts: 7214
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: Preview in Font Panel…

Postby Nick » February 15th, 2017, 6:42 am

Hi Jean-Jacques,

Thanks for telling about this problem. It might relate to Printworks or to the Fonts panel. Our developers will check this.

I managed to repeat the problem that you described by selecting two portions of text with different fonts applied and then choosing a new font. Not all combinations of fonts can confuse the Fonts panel in this way. I also could reproduce the same problem in TextEdit.app.

Nick
Jean-Jacques Boutaud
Member
Posts: 1635
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Re: Preview in Font Panel…

Postby Jean-Jacques Boutaud » February 15th, 2017, 7:44 pm

thanks Nick
in TextEdit, the Font Preview feature seems to be working, yet
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
Nick
Member
Posts: 7214
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: Preview in Font Panel…

Postby Nick » February 16th, 2017, 10:59 am

There is a chance that my steps to reproduce the problem differ from yours. Here is what I did (in both SP and TextEdit):
1. Type a few characters.
2. Select a portion to the left and apply Courier New, Bold Italic.
3. Make the rest Didot, Regular.
4. Select the whole text and click on different fonts in the Fonts panel. With some fonts, the problem will repeat, and it won't with others.

My guess is that selecting fonts that don't have the Bold Italic typeface will confuse the Fonts panel.

If you can repeat the problem by following other steps and you know them, please let me know.

Nick

Return to “Printworks”

Who is online

Users browsing this forum: No registered users and 2 guests