Cards disappeared

paxtonpackers
New member
Posts: 1
Joined: September 5th, 2011, 5:42 pm

Postby paxtonpackers » September 5th, 2011, 5:46 pm

The .bundle file is still there. I can still log in with my master password. At the main screen, however, the desktop is blank and it says "no cards" at the bottom ... not even the sample cards. What do I do?

OS X 10.7.1
Concealer 1.0.8
Macbook Pro 17" early 2011
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » September 6th, 2011, 4:48 am

Hi paxtonpackers,

Select the All category at the top left corner. This can help if an empty category is currently selected.

Check the Trash of Concealer. In case the cards you are looking for are there, select them, right-click and choose Put Back.

Did you experienced the problem after updating to 1.0.8 ? If yes, you can try to open the .bundle file using an old version. Can you remember if you updated from 10.0.7 or from an earlier version?

Did you change the location of the .bundle file ? If yes, start the application, choose File > Change Card Repository, and navigate to the proper location.

Please create a backup copy of the .base file.

Nick
milestgeau
New member
Posts: 1
Joined: September 5th, 2011, 5:37 pm

Postby milestgeau » September 6th, 2011, 7:18 am

Thanks, Nick.
I tried all those things and no luck.
I had to go inside the bundle file and open the file storage .dmg with my password and move everything out. I'm reluctant to start over because I don't know why this happened in the first place.
Are these .bundle files subject to corruption? I've only been using the program for a couple of months. No problem until the cards disappeared yesterday. Files were apparently unaffected, as I was able to recover them.

Michael
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » September 6th, 2011, 9:00 am

Hi Michael,

The .bundle files are subject to corruption in the same extent as any other files on the hard drive.

Nick
jtwice
New member
Posts: 1
Joined: December 7th, 2011, 12:40 pm

Postby jtwice » December 7th, 2011, 12:49 pm

I have the same problem and tried the suggestions above but still no cards. The .bundle file is displayed in finder and the size appears to be correct.

I'm guessing but it appears that an index to the contents was lost. Do you have a utility that can examine concealer.bundle and rebuild the index?
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 8th, 2011, 4:47 am

Hi jtwice,

We don't have any additional utilities.

Try to follow the suggestions in post #2.

What version of Concealer do you have? Did you work with the storage using the same version or with an earlier one as well?

Nick
Artemidis
New member
Posts: 3
Joined: August 6th, 2011, 4:41 am

Postby Artemidis » December 31st, 2011, 9:09 am

Same problem here... This is really annoying, I mean this Software is made for keeping passwords and stuff safe...

I'm running concealer 1.0.8.
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 1st, 2012, 3:54 am

Hi Artemidis,

1. Create a backup of the repository. The default location of the Concealer's file is:
~/Library/Application Support/Concealer/Concealer.bundle
To open it in Finder, copy this line:
~/Library/Application Support/Concealer/
in Finder choose Go > Go to Folder. Paste the path and click Go.

2. In Concealer, select All in the main window to make sure that you don't preview the content of an empty category.

3. Did you update the operating system or Concealer right before the cards have disappeared?

If you updated, what are the previous and current versions?

If you updated Concealer, I can give you the previous version to check if it can display the cards.

What version of Mac OS is installed on your computer?

4. Did you store information in Concealer using cards or added files to the storage?

Nick
hoosierranger
New member
Posts: 2
Joined: January 2nd, 2012, 3:57 pm

Postby hoosierranger » January 2nd, 2012, 4:18 pm

Greetings. Same issue as above appeared when I opened Concealer yesterday. No cards will appear. I also noticed that the Concealer will open with the incorrect (or no) password. I keep multi-backups of the repository and the one I tried did not respond either... I'm hoping this is a software glitch that can be patched quickly or someone can offer a solution.

As for the last post, I am on 1.0.8 as of 10/2/2011, and using Mac OS X 10.7.2. No changes to these recently.

My current repository is approximately 250 GB and the bundle file still reflects the size.
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 3rd, 2012, 5:23 am

Hi hoosierranger,

Did you do any changes in Concealer recently (password, the location of the repository)?

Did you open the same repository on another computer?

Please do this:
1. Make sure that the program opens your working repository. The path to the current repository is displayed in the program Preferences (Cmd-,). Compare this path with the default one (see step 2), or with the custom path if you have moved the repository to another folder.

2. Create a backup of the repository. The default location of the Concealer's file is:
~/Library/Application Support/Concealer/Concealer.bundle
To open it in Finder, copy this line:
~/Library/Application Support/Concealer/
in Finder choose Go > Go to Folder. Paste the path and click Go.

3. In Concealer, select All in the main window to make sure that you don't preview the content of an empty category.

4. Find out the sizes of the repository files to compare with the default sizes. Open the Terminal application located in the Applications/Utilities folder. Copy this line (there is a space character in the end)
ls -la
paste into Terminal. Drag the repository Concealer.bundle from the Finder into the Terminal window and press Return. Send me the output by email (support@belightsoft.com), or post in the forum. It will look like this:
nicks-MacBook-Pro:/ nick$ ls -la /Users/nick/Library/Application Support/Concealer/Concealer.bundle
total 72
drwxr-xr-x 5 nick staff 170 Jan 3 12:01 .
drwxr-xr-x 4 nick staff 136 Jan 3 12:07 ..
drwxr-xr-x 3 nick staff 102 Aug 1 13:57 Accounts
-rw-r--r-- 1 nick staff 30063 Jan 3 12:01 Accounts.iconf
-rw-r--r-- 1 nick staff 405 Jan 3 12:01 Info.plist

Nick
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 4th, 2012, 10:18 am

Hi hoosierranger,

Thanks for the lines from the Terminal. The size of the storage suggests that the cards may be lost. The default storage has almost the same size.

If you stored files in a file storage, they can be still present there, and we can try to access them.

Please answer these questions:
- Did you do any changes in Concealer recently (password, the location of the repository)?
- Did you open the same repository on another computer?

This information could help us understand what has caused the problem.

Nick
hoosierranger
New member
Posts: 2
Joined: January 2nd, 2012, 3:57 pm

Postby hoosierranger » January 4th, 2012, 2:51 pm

Nick, definitely no to both questions. No password changes. Both the primary location of the repository and the backup location have not changed. The hard drives that hold the repositories have not been used on another computer - this is my only Mac with Concealer.

What is interesting is that the bundle file that is not opening for me is larger than the file I can open from an earlier back-up; that tells me that the files added are present in the unaccessible bundle.

Other than that, I've had a few routine updates to apps and the OS - could there be an update to another ap causing an issue?

Again, thank you for your time with this - I appreciate it.
Nick
Member
Posts: 7237
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 5th, 2012, 6:39 am

Hi,

What is interesting is that the bundle file that is not opening for me is larger than the file I can open from an earlier back-up; that tells me that the files added are present in the unaccessible bundle.

The bundle stores files you have added to the file storage separately from the cards. Even if the cards aren't displayed in the main window, the files can be inside the bundle, and it is very probable that they can be accessed manually.

Other than that, I've had a few routine updates to apps and the OS - could there be an update to another ap causing an issue?

A major update of Mac OS (for instance, from 10.6 to 10.7), or an update of Concealer could somehow affect the bundle. Updating other apps has nothing to do with it. Also, the storage could be affected by a file system error on your hard drive. Backing up the storage can help you avoid the data loss.

Nick
ankara23
New member
Posts: 2
Joined: September 26th, 2012, 2:27 pm

Postby ankara23 » September 26th, 2012, 2:33 pm

Nick..this is ridiculous.. I'm having the same thing! here's the output from terminal - Last login: Wed Sep 26 15:28:30 on console
localhost:~ ankara$ /Volumes/the Library at Alexandria/storage repository/ankara's files/Concealer.bundle
-bash: /Volumes/the Library at Alexandria/storage repository/ankara's files/Concealer.bundle: is a directory
localhost:~ ankara$ Im running concealer 1.1 I moved all my private files to this bundle on it's own drive for the purpose of protecting it.. this IS my backup.. I trusted this program to do it's job and it's done the total opposite!.. you guys need to help my find my files.. the bundle is still 120 something gb so my files are there.. the card doesn't show up..
ankara23
New member
Posts: 2
Joined: September 26th, 2012, 2:27 pm

Postby ankara23 » September 26th, 2012, 2:37 pm

same thing as the guy above.. I didn't do anything to concealer or update my os, just opened up concealer and your program just won't display any cards.. I really need my files back.

Return to “Concealer”

Who is online

Users browsing this forum: No registered users and 1 guest