Printing to Dymo LabelWriter 330

BillyBob152
Member
Posts: 15
Joined: March 9th, 2009, 2:56 pm

Postby BillyBob152 » January 19th, 2010, 6:44 pm

iMac G5 Intel, OS 10.6.2, Dymo Label Software 8.2, Belight Labels and Addresses 1.5.2: The label shows in Preview but fails to print. Prints a blank label. Help!!!!!!!!

When I try to print from the Dymo Label Software itself I get the following mwessage: 'Application could not find supported printers. Please reinstall your printer driver.' I already did that 3 times!
Last edited by BillyBob152 on January 19th, 2010, 6:49 pm, edited 1 time in total.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 20th, 2010, 6:13 am

Hi,

Since the Dymo software doesn't work, the driver may be incompatible or improperly installed.

Try to follow the Epson's instruction. It describes how to delete and install again a printer driver.

If you need, driver download page:
http://sites.dymo.com/Support/Pages/AllDriversUsers.aspx?Type=Drivers

Nick
BillyBob152
Member
Posts: 15
Joined: March 9th, 2009, 2:56 pm

Postby BillyBob152 » January 20th, 2010, 7:36 pm

I also have a LabelWriter 330 and mine also would not work on my iMac G5 Intel with Snow Leopard.

So, I called Dymo Support and they told me that the 330 is not supported in machines running Snow Leopard on an Intel Mac because the Dymo software and Writer were too old to invest in.

Therefore, mine is now junk. I guess I will have to get a new one or find another manufacturer who supports the Mac such as Seiko or Brother and stick with them.

Return to “Labels & Addresses / Mail Factory”

Who is online

Users browsing this forum: No registered users and 2 guests