Page 1 of 2

Posted: September 19th, 2009, 1:03 pm
by thomas
After opening Labels & Addresses, I'm ending up with multiple copies of several of the entries in Address Book on my Mac, presumably coming from the Address Book in Labels & Addresses. Doesn't seem to matter if the Address Book is running or not, the next time I open it on my Mac, there they are. When I delete them manually from my Mac, they remain deleted until the next time I launch Addresses & Labels.

Furthermore, this behavior happens each time I open the program, leading to many copies of the same contacts. It's always the same contacts each time, I might add.

Other than that one quirk, I love the program and it works quite well for me.

Very strange. Anyone else experience this?

Thanks for your time.

Posted: September 21st, 2009, 8:45 am
by Ajax
thomas, please tell me OS X and application version you are using. Seems like pre-Snow Leopard compatible Labels & Addresses version.

Posted: September 21st, 2009, 11:06 am
by thomas
I'm sorry, I should have made that clear in my earlier post.

Snow Leopard 10.6
Labels & Addresses 1.3.3

Thank you.

thomas

Posted: September 23rd, 2009, 8:53 am
by Ajax
thomas, this is strange behavior than. Try to install 10.6.1, than trash next

Code: Select all

1. ~/Library/Application Support/BeLight Software/Labels & Addresses/ folder
2. ~/Library/Preferences/com.belightsoft.LabelsAddresses.plist
3. Labels & Addresses application

Download application from http://s3.amazonaws.com/belightsoft/LabelsAddresses.dmg and install it. Try to work with it.

Posted: September 23rd, 2009, 9:12 am
by thomas
Ajax,
Thank you for the advice. I'll try what you suggest a bit later today and report back to you.
Thomas

Posted: September 23rd, 2009, 9:31 am
by Zoidberg
Same issue here with L&A 1.3.3 and 10.6.1; I had manually deleted several dozen duplicates in my Address Book application. When I re-opened L&A this AM, more entries are duplicated multiple times.

Posted: September 23rd, 2009, 9:38 am
by thomas
Zoidberg - I'm sorry for your problem but it means I'm not the only one. Did you upgrade from Mail Factory and if so, how did you convert your Mail Factory files to Labels & Addresses? I changed the "Open With" application from M.F. to L. & A. Perhaps that's the issue.
Thomas

Posted: September 23rd, 2009, 9:42 am
by Ajax
Zoidberg, if you had duplicates in the Address Book that it's looks like consequences or the Snow Leopard upgrade, since our apps doesn't change anything in the data sources, just read them

Posted: September 23rd, 2009, 9:45 am
by Zoidberg
Been using L&A since it's release. I was a Mail Factory user since that program's release as well.

It's not a conversion issue, as the problem is occurring with labels created "from scratch" in L&A as well as older labels. That is to say, it's the "plumbing" of the application itself, I think, and how it works with the system's Address Book application, that's causing the duplicates.

Posted: September 23rd, 2009, 9:48 am
by Zoidberg
Ajax wrote:Zoidberg, if you had duplicates in the Address Book that it's looks like consequences or the Snow Leopard upgrade, since our apps doesn't change anything in the data sources, just read them

I'm not saying it's not Address Book's issue; however, the duplication only occurs after I open Labels & Addresses -- and only to entries that I'm using on labels. I've confirmed this.

That could be coincidental, of course.

Posted: September 23rd, 2009, 9:52 am
by Zoidberg
Confirmed again just now.

Have had Address Book open. Then opened a label in L&A (1.3.3).

When the label appeared onscreen, two entries were duplicated in Address Book -- my own entry (which is the return address) was duplicated four times and the recipient (which was already in the saved label, but *not* an entry in my address book already) was added to my Address Book app three times.

Rescinded: Not entirely sure it's an L&A issue but circumstantially it seems to be. I have seen some posts @ Apple's forums regarding Address Book duplicates/merges and MobileMe sync (which I'm not using).

Posted: September 23rd, 2009, 1:42 pm
by Zoidberg
Ajax wrote:Download application from http://s3.amazonaws.com/belightsoft/LabelsAddresses.dmg and install it. Try to work with it.

Tried this, and am now getting error message "The Installation Failed. Contact the Software Manufacturer."

Have tried installation several times, getting the same error.

Posted: September 24th, 2009, 6:27 am
by Ajax
Zoidberg, while our developers are looking for root of evil, mentioned problem discussed on the Apple forum could be exactly what we are looking for. The thing is that we are extracting data using system provided methods (exactly as mobileMe sync works etc.) and if there is something wrong in what it gives back, we can't do nothing :( just hope that 10.6.2 will fix the issue.

The same thing happened to other our products with iPhoto - having slideshows with the music, using latest iPhoto version, makes our apps unable to access iPhoto library. We've found it out on Apple discussions, where people claimed that sync didn't work either, when slideshows are with music accompaniment.

Posted: October 5th, 2009, 8:17 pm
by Zoidberg
FWIW, looks like Address Book is one of the "minor bug fixes" noted for 10.6.2:

http://www.macrumors.com/2009/10/05/apple-seeds-mac-os-x-10-6-2-build-10c514f-to-developers/

Posted: November 9th, 2009, 9:51 pm
by Zoidberg
Updated to 10.6.2 today; restarted from SL disc to repair disc and permissions just to be thorough.

The "duplicate entries in Address Book" issue remains. It *only* happens when I open a label in L&A.