.laba files not opening via Finder or Applescript

bruce00j
New member
Posts: 3
Joined: August 20th, 2014, 7:42 am

.laba files not opening via Finder or Applescript

Postby bruce00j » August 20th, 2014, 7:51 am

Hi,

I am currently making a script that ties into excel that gets information and puts it on to a label file for Labels & Addresses.

I used to be able to open .laba files via script and Finder but now I can't seem to open a .laba file either way.

It is rather annoying as I know other users of this software with in the office are having trouble opening any files for Labels & Addresses sometimes and it can get rather frustrating.

Any ideas as to why this could be?

Thanks,
Bruce
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: .laba files not opening via Finder or Applescript

Postby Nick » August 20th, 2014, 9:14 am

Hi Bruce,

Opening in Finder:
Did you try double-clicking on a .laba file as well as drag-and-dropping the file onto the program icon? What happens?
Check the Console log for error messages. To do this, open Console.app from the Applications/Utilities folder. Click on the Clear Display button. Try to open a .laba file. If any new messages appear in Console, copy them to the forum.

Opening using AppleScript:
There can be the same reason for the problem as when you are using Finder.
Does the Apple Script Editor show any error message when you run the script?

Nick
bruce00j
New member
Posts: 3
Joined: August 20th, 2014, 7:42 am

Re: .laba files not opening via Finder or Applescript

Postby bruce00j » September 1st, 2014, 5:05 am

Nick wrote:Hi Bruce,

Opening in Finder:
Did you try double-clicking on a .laba file as well as drag-and-dropping the file onto the program icon? What happens?
Check the Console log for error messages. To do this, open Console.app from the Applications/Utilities folder. Click on the Clear Display button. Try to open a .laba file. If any new messages appear in Console, copy them to the forum.

Opening using AppleScript:
There can be the same reason for the problem as when you are using Finder.
Does the Apple Script Editor show any error message when you run the script?

Nick


Hi Nick,

Sorry for the late reply I was on holiday.

It happens when I try to double click to open it, although now it seems to be opening fine at the minuet both through finder and applescript.

I hope this stays the same for other people when I finish the applescript as I would like to be able to run it without any flaws.

Also there is no error within applescript, I will post again when I notice the files not opening again and I will try to find it in the error log in the mean time or when it happens.

Thanks,
Bruce
bruce00j
New member
Posts: 3
Joined: August 20th, 2014, 7:42 am

Re: .laba files not opening via Finder or Applescript

Postby bruce00j » September 1st, 2014, 11:04 am

Hi Nick it has started to do it again through finder.

here is what got outputted to console when it happened

Code: Select all

01/09/2014 17:00:06.604 gkbisd[452]: Unable to collect cdhash for /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/QuickLookUI.framework/Versions/A/Resources/QuickLookUIHelper.app (error code 100024)
01/09/2014 17:00:06.685 Labels & Addresses[37492]: -[__NSArrayM length]: unrecognized selector sent to instance 0x6059a90
01/09/2014 17:00:06.686 Labels & Addresses[37492]: NSExceptionHandler has recorded the following exception:
NSInvalidArgumentException -- -[__NSArrayM length]: unrecognized selector sent to instance 0x6059a90
Stack trace:  0x9619d6d0  0x9a332091  0x99bb1cb3  0x99afd522  0x99afd10e  0x99a5a0dc  0x99a63ca9  0x92d9bfcd  0x92d9be9d  0x92d9be47  0x8c09a  0x99a83b9d  0x99a83a6b  0x99b3094a  0x92ee765a  0x92ee79c0  0x92f04171  0x9a33e304  0x92d8e47a  0x92d8dfb1  0x92d8ddbb  0x988c6b15  0x98895ed6  0x98895dce  0x98e11571  0x9620f148  0x9620e870  0x9620115c  0x961e9ff8  0x1694a  0x1
01/09/2014 17:00:06.686 Labels & Addresses[37492]: An exception was thrown during execution of an NSScriptCommand...
01/09/2014 17:00:06.687 Labels & Addresses[37492]: -[__NSArrayM length]: unrecognized selector sent to instance 0x6059a90


Im not sure if the first bit was anything to do with it but it seemed to be out of the norm than the rest of the log.

Thanks,
Bruce

EDIT:

I can confirm the first bit of the log appears along with the rest when I try to open a .laba file and it fails
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Re: .laba files not opening via Finder or Applescript

Postby Nick » September 2nd, 2014, 5:00 am

Hi Bruce,

Thanks for the log. Its beginning (QuickLook part) has nothing to do with the file opening problem. The rest does.

I seem to have managed to repeat the problem on my computer with the same errors in the log. I opened a .laba file using an AppleScript. Further attempts to open another or the same file failed: AppleScript way and double-clicking in Finder didn't work, but File > Open Recent in the program did. AppleScript Editor gave me "Labels & Addresses got an error: AppleEvent handler failed." Once the problem had occurd, I had to quit and reopen Labels & Addresses to be able to open files again. Closing only a file didn't help.

Also I noticed that Labels & Addresses opened by the script sometimes doesn't open a document by any means. But it does if I quit and reopen Labels & Addresses. It never failed during my experiments, if I open the script (Labels & Addresses opens automatically), then I quit the program and reopen it again.

The developers say that officially AppleScript is not supported in the program what means that you have to search for some workarounds, or find a completely different way to automate your task.

Nick

Return to “Labels & Addresses / Mail Factory”

Who is online

Users browsing this forum: No registered users and 2 guests