Using Copperplate i get ,, for jp when printing envelopes

MichaelR64
New member
Posts: 4
Joined: August 11th, 2013, 10:03 am

Postby MichaelR64 » August 11th, 2013, 10:14 am

hi,

I am using Labels & Adresses to do mailmerge with envelopes from an excel file.
When the addres-street contains ' jp' i get ,, in the output when i use Copperplate.
This only happens with copperplate in L&A in lowercase.
When i use uppercase or propercase it doesn't happen.
Just type in 'JP Morgan Chase '.

I checked with font book to see if any font was corrupt or double and that doesn't seem to be the case.

Does anybodu have any idea what is going on here ?
It doesn't happen in Word or other editors btw.


rgrds mike
Last edited by MichaelR64 on August 11th, 2013, 10:14 am, edited 1 time in total.
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » August 11th, 2013, 11:37 am

Hi MichaelR64
Imho, this may come from a misinterpreted character or text encoding, especially as I see an invisible character before the jp lowercase, at least in your post (yes, I can see invisible character ;^)).
This may be a space, a non-breakable space or something else.
If you can open the Excel file, try to replace this kind of character by a "real" space, if a space is absolutely necessary, and see what happens when importing it in L&A.
Be sure to work on a copy of the Excel file.
Hope this helps.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
MichaelR64
New member
Posts: 4
Joined: August 11th, 2013, 10:03 am

Postby MichaelR64 » August 11th, 2013, 12:05 pm

Jean-Jacques Boutaud wrote:Hi MichaelR64
Imho, this may come from a misinterpreted character or text encoding, especially as I see an invisible character before the jp lowercase, at least in your post (yes, I can see invisible character ;^)).
This may be a space, a non-breakable space or something else.
If you can open the Excel file, try to replace this kind of character by a "real" space, if a space is absolutely necessary, and see what happens when importing it in L&A.
Be sure to work on a copy of the Excel file.
Hope this helps.

That is not the case here, as i retyped the field in the Foreground - Edit window.
I tested it there and just used the same letters in other fields as well.
If a select the letters, and select another font i can see the letters correct and corrupt when i select Copperplate.

I created a video that shows this with a new envelope.
http://screencast.com/t/pMoWcl6kTk
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » August 11th, 2013, 1:29 pm

Hi
I can repeat this problem in SP3 and TextEdit so it doesn't seem to be a L&A/BeLight specific bug but, maybe, an OS X one.
Strangely, I can't find any resource about this from the web/Google/Apple.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
MichaelR64
New member
Posts: 4
Joined: August 11th, 2013, 10:03 am

Postby MichaelR64 » August 11th, 2013, 3:18 pm

Jean-Jacques Boutaud wrote:Hi
I can repeat this problem in SP3 and TextEdit so it doesn't seem to be a L&A/BeLight specific bug but, maybe, an OS X one.
Strangely, I can't find any resource about this from the web/Google/Apple.

Yep, me too.
But that leaves me stumped as to why this happens...
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » August 12th, 2013, 3:40 am

Hi

I've found one more person reporting this bug:
http://hintsforums.macworld.com/showthread.php?t=145025
This user has found another combination of letters "jm" that turns into one comma.

It seems to be Apple's bug, or the font itself has something specific.

I think that it is better not to use some other font.

Nick
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » August 12th, 2013, 7:48 am

Hi all
Good news: it seems that setting ligatures to none (Format>Font>Ligature>Use None) fixes this problem, at least under 10.7.x.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
MichaelR64
New member
Posts: 4
Joined: August 11th, 2013, 10:03 am

Postby MichaelR64 » August 12th, 2013, 8:03 am

Jean-Jacques Boutaud wrote:Hi all
Good news: it seems that setting ligatures to none (Format>Font>Ligature>Use None) fixes this problem, at least under 10.7.x.

Great this seems to work for me to.
And i learned what an ampersand sign really means and what ligatures are.

Apparently Copperplate doesn't support ligatures.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » August 12th, 2013, 9:34 am

Jean-Jacques,

Your solution works on 10.8 as well. I've tested it with L&A, SP and TextEdit.

Mail.app doesn't have the Ligature settings. This could be the reason why it wasn't affected by the problem.

Nick
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » August 12th, 2013, 2:53 pm

MichaelR64 wrote:Apparently Copperplate doesn't support ligatures.

Not exactly, there're two available ligatures, fl and fi, certainly the most usual ligatures with ff.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » August 12th, 2013, 2:58 pm

Nick wrote:Your solution works on 10.8 as well. I've tested it with L&A, SP and TextEdit.

Thank Nick
Strangely, this is not a problem with 10.6.x.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website

Return to “Labels & Addresses / Mail Factory”

Who is online

Users browsing this forum: No registered users and 2 guests