How do I see what font I have selected?

sl567
New member
Posts: 8
Joined: January 22nd, 2008, 6:08 pm

Postby sl567 » January 27th, 2014, 3:56 pm

When I click in a text box, how do I know which font that text is? When I look at the fonts list, nothing is highlighted.
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » January 27th, 2014, 5:42 pm

Hi sl567
You should try to select some text from the box (don't forget that more than one font can be used in the same box):

Image
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
MJBS
Member
Posts: 24
Joined: February 1st, 2013, 12:31 pm

Postby MJBS » January 31st, 2014, 8:15 pm

Unfortunately, this doesn't always work first time. I find I sometimes have to move to another section of type, select some text, check the font as you describe, but then go back to the previous section to repeat the process with the first font I had wanted to check, when it will usually work.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » February 1st, 2014, 5:40 am

Hi MJBS,

What versions of OS X and Swift Publisher are on your computer?

Try to repeat the problem in a template document with a text box containing two or more different fonts, and tell me about the result.

Nick
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » February 1st, 2014, 10:15 am

Hi all
I've made some tests from a new (blank) SP3 document, adding a text box filled with two paragraphs, each one using a different font:

Image

The first time I select this box then open the Font panel, I get this message in the Preview area of this panel: <Plusieurs styles sélectionnés> (something like <Several selected styles>). It seems normal because there're two different fonts used in the box.
If I put the text/edit cursor in one of the paragraphs (no need to select text), I get the right font name and font size (so, in this case Adobe Garamond 11pt or Helvetica Neue 9pt).
But a problem occurs from now:
If I deselect the text box then reselect it, I don't get the message indicating that more than one style are present in the box. All I get is the name of the font used in the last paragraph that had focus.
To get this message back, I need to slightly move or resize the box, something not really friendly to do.

OS X 10.7.5, SP 3.3.3 (build 587)
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » February 3rd, 2014, 4:17 am

Thank you Jean-Jacques for your tests. I'll tell the developers about the problem you have found.

MJBS,

Did you experience what Jean-Jacques has discovered?
Do paragraphs you are working with reside inside own text boxes or a single one?

Nick
Jean-Jacques Boutaud
Member
Posts: 1639
Joined: July 10th, 2006, 2:29 pm
Location: France
Contact:

Postby Jean-Jacques Boutaud » February 4th, 2014, 6:57 am

Hi
I've made a slightly different test with two text boxes, each one filled with text using only one style (different fonts and sizes):

Image

As you can see, the box at bottom is selected (font is Gill Sans) but Adobe Garamond (used in the box at top) is displayed in the Font panel preview.

Moving, resizing with mouse but also editing the position/size fields from the inspector display the right style for the selected text box.
JJBee, Président (à vie) du G.R.O.I.N.
Secrétaire général : iMac C2D 2.16GHz
Secrétaire adjoint : MacBook Pro 17" Unibody 3.06GHz
http://belightcommunity.free.fr/BeLight Community website
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » February 4th, 2014, 8:34 am

Hi Jean-Jacques,

I could see exactly the same behavior. It is interesting if MJBS experienced it as well.

Nick
MJBS
Member
Posts: 24
Joined: February 1st, 2013, 12:31 pm

Postby MJBS » February 4th, 2014, 3:25 pm

Nick,

Sorry to be slow replying. I already use SP3.3.3 but I'm still using Mountain Lion, until more of the bugs reported with Mavericks have been resolved.

I have never had the "Several selected styles" message reported by Jean-Jacques. Moreover, my comments about the font checker was mainly about identifying fonts already included in a basic, page-sized box when preparing my local magazine. However, I find the same behaviour checking fonts in a nested box or in a separate box. This seldom works first time; I almost always have to follow the somewhat laborious double-check procedure I have described.

I wonder if this odd, variable behaviour could be because I downloaded my original copy (and subsequent upgrades) from the App Store and not direct from your SP site. Can't think why this should be any different though…

By the way, please pass on my thanks to the team for adding being able to change the starting page number to whatever number one wants. This has been my top request for an improvement for months now and I appreciate it greatly, as it enables me to make up my local magazine as three or four separate PDF files, which I can then combine, but with an apparently seamless page numbering sequence.

MJBS
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » February 5th, 2014, 5:30 am

Hi MJBS,

Please send your document to supprt@belightsoft.com with the link to this discussion. I'll see if there is something specific in it. My test document doesn't reveal nothing more than described in Jean-Jacques' post.

Nick
MJBS
Member
Posts: 24
Joined: February 1st, 2013, 12:31 pm

Postby MJBS » February 6th, 2014, 2:35 pm

Nick,

Please don't misunderstand. I was simply supporting the original post. I can manage with my workaround. My document, as you describe it, is a 60+ pages monthly magazine at around 100 MB. I could send you a specific page, but I suspect this issue is not intrinsic to the application (as you cannot reproduce it), but something in the interaction between my iMac and Mac OS 10.8.5. The issue has carried over from SP 2 to 3.3.3

Michael
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » February 7th, 2014, 7:38 am

Hi Michael,

Please send a sample page to support@belightsoft.com If I manage to reproduce some new problem, we'll try to fix it.

Nick

Return to “Swift Publisher”

Who is online

Users browsing this forum: No registered users and 5 guests