New bug? Copy and Paste does not always work

MJBS
Member
Posts: 24
Joined: February 1st, 2013, 12:31 pm

Postby MJBS » December 3rd, 2013, 3:04 pm

I've commented before that I use SP 3.3.1 to produce a monthly village magazine in full colour with bleed, running to about 60-68 pages. It's pretty good for its price, allowing for some previously reported bugs and feature omissions.

In the last three months, however, I've discovered that using copy and paste does not always act reliably. Sometimes, what gets pasted is the previous image I have successfully C&P'd. This behaviour then repeats, however many times I try again. However, this doesn't always happen and hasn't been happening with other applications (eg. the Mac version of Word), which is odd, because Copy and Paste is a feature built into OS X (I'm still using Mountain Lion). To reset the function, I have to copy/paste the desired image to something like Graphic Converter, and then copy and paste as a second stage into my SP3 file. Another way is to exit SP3 and fire up one or two different applications before coming back to the file I was working on.

Has anyone else experienced this? Does anyone know why? I've noticed that this odd behaviour usually starts after I have been working an an open SP3 file for some time, so I'm assuming it's some memory thing (RAM isn't clearing).
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 4th, 2013, 3:34 am

Hi MJBS,

This repeats on my computer as well. I've asked our developers to fix this problem as soon as possible.

Nick
Troody
Member
Posts: 25
Joined: June 11th, 2008, 3:54 pm

Postby Troody » December 5th, 2013, 12:06 pm

This is also happening to me. I created a smaller SP file to organize nominee bios and photos. Now I would like to copy and paste this work into a larger file. I can copy and paste the text into the new file with no trouble. I can copy and paste the photo within the smaller file with no trouble. However, when I attempt to paste the photo into the new file, I get a very small piece of a photo I haven't used in days.

I have saved, closed, and reopened the files numerous times. I have repaired permissions, checked for updates, and restarted my computer several times.

Also, for a long time I have been able to put together an image with text in SP, group it, copy and paste it into Word, and save it as a graphic file of the correct size and shape. (When exporting the same configuration in SP, of course, I get a full-size PDF which then has to be cropped to the correct size.) Now I can no longer copy a SP image and paste into a Word document. Word believes something has been pasted, but nothing is visible and there is no placeholder box. If I use "Paste special" in Word, I get the option to chose a picture or a PDF. If I choose "picture," I get the message that "there is not enough memory or disk space to complete the operation." (I have 433.03 GB of disk space available.) If I choose "PDF," an empty box appears. I have no trouble pasting into Word from other applications, just SP.

Suggestions? Would appreciate any help so I can complete this work!
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 6th, 2013, 3:29 am

Hi Troody,

However, when I attempt to paste the photo into the new file, I get a very small piece of a photo I haven't used in days.

You copied a photo to a new SP document, and the pasted photo is not what you copied, right?

If this happens repeatedly, please send your document to support@belightsoft.com and tell what image you copied.

The second issue you described happens on my computer as well. I cannot give you any workaround so far.

Nick

Return to “Swift Publisher”

Who is online

Users browsing this forum: No registered users and 7 guests