OSX Mavericks

Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 12th, 2013, 9:34 am

Hi Glyn,

A was able to download and extract Swift Publisher from that archive. Please try again. Maybe I placed the link before the file was completely copied to our website. Sorry for this trouble.

Nick
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 12th, 2013, 10:37 am

Sorry Nick, still the same.

The file downloads and "extracts" ok but opens with the same message on the iMac and MacBook Pro.

Glyn
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 13th, 2013, 3:41 am

Please email me (support@belightsoft.com) the console log saved after attempting to open Swift Publisher. Copy this log from the Console utility.

To troubleshoot, try to delete (or move to some folder) preferences:
~/Library/Preferences/com.belightsoft.SwiftPublisher3.plist

and auto saved files from this folder:
~/Library/Autosave Information

To access each of these items, copy each path. In Finder, select Go > Go to Folder. Paste the path and click on Go.

I opened the program on several computers with no problems.

Nick
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 13th, 2013, 11:20 am

Well Nick, this is becoming ridiculous!

I've tried your suggestion without success. I should point out that my pref. file is com.belightsoft.SwiftPublisher3.appStore.plist. Is it relevant that I first tried the Demo version on the App Store but bought it from your site?

I've now completely deleted SP and reinstalled it from the link you sent me. This is however, v 3.3.2. When I attempt to update to v. 3.3.3, I get the damaged file routine as above. Even the original update file no longer works.

Where have I gone wrong?

Glyn
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 13th, 2013, 11:49 am

Oh, incidentally Nick, I've even tried logging on as a Guest, but it's the same.
blacksalad
New member
Posts: 5
Joined: December 10th, 2013, 4:25 pm

Postby blacksalad » December 14th, 2013, 5:04 am

Nick,

I've downloaded that link - unfortunately, I can't use it as it asks for a licence number and I bought it originally from the APP store.

Help please!

Steve
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 14th, 2013, 9:26 am

Hi Steve,

The version above is not aimed to be a solution because we didn't test it as we normally do. It is a test version. We asked users to check if the problem with exporting is not repeating.

Nick
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 14th, 2013, 3:53 pm

So Nick, the latest developments are as follows:

I have another MacBook Pro with Mountain Lion (10.8.5) installed on it. Your SP 3.3.3 downloads and installs on this system without any problems. The Export to pdf works perfectly.

I concluded that the problem must be with Mavericks. Accordingly, I've reinstalled Mavericks on my iMac. I then downloaded your SP 3.3.3 file yet again and attempted to install it but, unfortunately, it continues to tell me the file is "damaged."

Your first incarnation of SP3.3.3 installed fine except from the fact it would only create one page as a pdf.

It's all very bizarre!

Where do we go to from here?

Regards,

Glyn
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 16th, 2013, 4:26 am

Hi Glyn,

Thanks for your log. I passed it to developers. I hope to get from them some clues.

Nick
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 16th, 2013, 6:09 am

Glyn,

The problem you experience relates to security settings in the operating system. Please check the Security & Privacy section in the System preferences. I'm talking about the "Allow apps downloaded from" options. On OS X 10.9 Mavericks, SP will open only if Anywhere option is selected. The other two give the same symptoms as you described. Once you open SP, you can switch to your regular option (the first or second).

OS X 10.8 is not so strict. It allows to start SP with one of two options: "Mac App Store and identified developers" and "Anywhere".

Nick
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 16th, 2013, 6:58 am

We have fixed the problem with opening SP. The download link is the same:
http://belightsoft.com/tmp/Swift%20Publisher%203.zip

Nick
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 16th, 2013, 9:00 am

Nick,

At the risk of tempting fate by speaking too soon, it looks like your latest version is working fine.

Many thanks,

Glyn
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » December 16th, 2013, 10:06 am

Oh, one last thing for Xmas. (I sometimes feel I've been sent to torment you. Sorry.)

The icon of .spub files doesn't seem to show graphics, only text.

Is that to be expected?

G.
fonetico
Member
Posts: 47
Joined: October 28th, 2013, 11:18 am

Postby fonetico » January 10th, 2014, 6:36 am

Hi Nick,

Have you any comments or suggestions on my last posting about the lack of graphics on the .spud icon?

Am I unique in experiencing this or have others found the same anomaly? I've tried playing around with the view prefs but to no avail.

G.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » January 10th, 2014, 7:58 am

Hi,

Sorry for missing your question. The developers plan to fix this problem in the next update.

I saw the same on my computer with only one document. Its thumbnail in Finder displayed only text. This took place one or two weeks. Then the problem disappeared itself. Maybe after editing and resaving my document, the preview was updated.

Nick

Return to “Swift Publisher”

Who is online

Users browsing this forum: No registered users and 4 guests