Disc Cover v.2.3.2 is Snow Leopard compatible

jsfarq
New member
Posts: 4
Joined: September 24th, 2009, 9:06 am

Postby jsfarq » September 24th, 2009, 9:15 am

Same print dialog hang problem with HP Photosmart D5160, . Really bothersome. Just did fresh Leapard install then Snow Leapard upgrade. No old drivers hanging around. Something is clearly wrong.

running 2.3.2 v467
User avatar
Ajax
Member
Posts: 317
Joined: February 16th, 2007, 3:27 am
Location: Odessa, UA
Contact:

Postby Ajax » September 25th, 2009, 3:57 am

jsfarq, unfortunately I can't agree with you at the moment - such happens to the selected printers only and only with certain circumstances. I guess it depends on printer drivers - not all manufacturer are properly updated them to the Snow Leopard or maybe OS X has something buggy within the printing system. I can't tell you right now about the Disc Cover but with the Labels & Addresses it's exactly the picture I described; again - unfortunately, because either we adapt our apps to the other's glitches or wait for the fixes. We are trying 1st choice at the moment.
** SCOTT Genius for YevGenius ;) ** MTB Rider **
jsfarq
New member
Posts: 4
Joined: September 24th, 2009, 9:06 am

Postby jsfarq » September 25th, 2009, 9:02 am

Ajax, I appreciate your position. A bit more data for you - The hang did not occur until after 10.6.1 update which included an updated HP printer driver (a separate update item.) The HP drivers are now built into SL.

I do understand that just because OSX has a bug does not make it your problem. However, it is a problem with using your software, so I would appreciate if someone would take a look at it.
User avatar
Ajax
Member
Posts: 317
Joined: February 16th, 2007, 3:27 am
Location: Odessa, UA
Contact:

Postby Ajax » September 25th, 2009, 12:11 pm

jsfarq, could you please clarify about driver updates - did you install drivers from hp.com but Software Update found than update for them? If so, you are using now Apple drivers. Maybe you can re-install hp ones again but do not install update?
** SCOTT Genius for YevGenius ;) ** MTB Rider **
jsfarq
New member
Posts: 4
Joined: September 24th, 2009, 9:06 am

Postby jsfarq » October 1st, 2009, 8:25 am

Ajax, SL now contains HP drivers and instructs to no longer use the HP supplied software. From HP.com:

"HP software is included in the Apple Mac OS X 10.6 Snow Leopard retail DVD, available via Apple Software Updates, and with new Mac computers shipping with Snow Leopard.
Important: Please do not reinstall software from original HP Photosmart, Officejet, Deskjet CDs, or HP web downloads from previous Mac OS X 10.3, 10.4, or 10.5. Older software is not compatible with Snow Leopard. The latest Snow Leopard compatible software is included in Mac OS X 10.6, and you will experience the best performance and functionality if you use the latest HP software.
There are some important updates with the HP software included in Mac OS X 10.6:
Printing: Full print functionality is supported with new HP print drivers included in Snow Leopard. Instructions follow.
HP Utility: HP Utility is included in Snow Leopard."

When doing a Software Update on my mac, at the same time 10.6.1 came down, there was also an update to printer drivers.

At this point I continue to use the software I bought, Disc Cover - wait for the print dialog, and hope for a future fix. Thanks for you attention.
quantise
New member
Posts: 6
Joined: January 24th, 2007, 10:30 am

Postby quantise » October 5th, 2009, 1:21 pm

Just to say that I use Labels and Addresses and it prints without problems on my PX800FW as does Art Text. The only BeLight app that suffers the delay for me is Disc Cover 2.

Regards,

John
jsfarq
New member
Posts: 4
Joined: September 24th, 2009, 9:06 am

Postby jsfarq » October 8th, 2009, 12:59 pm

There is a problem, but not a show stopper, just a little delay (read: frustration.)

Maybe it will work itself out, as it is not recognized as a problem by the developers.

I like the software, but I can't recommend it to anyone until this is resolved.
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » October 9th, 2009, 6:43 am

Hi,

If it's possible, we'll fix this annoying delay in the next update.

Nick
komponist
New member
Posts: 6
Joined: September 10th, 2009, 8:46 am

Postby komponist » October 11th, 2009, 8:25 am

FWIW, the new Epson drivers posted on Apple's Software Update have improved the situation with my R280 considerably.
=)
DJproduction
New member
Posts: 5
Joined: December 15th, 2009, 1:43 pm

Postby DJproduction » December 16th, 2009, 12:52 am

Running Disc Cover 2 2.3.2 (v468) on a Mac Pro Quad Core with OS X 10.6.2. This software package came bundled with my purchase of Toast Titanium. It has worked great up until last week. Every template I open, the graphics are selected (each graphic has a black box highlighting each particular graphic). I try to un-select each graphic and I can't. I tried deleting the graphic(s) and I can't. When I add more graphics or text, the program suddenly quits.

I've tried reinstalling the program and has not solved my issue. I also had a earlier version, 1.5(v.270)....same problem exists. I have run out of options. I assume this is a OS X 10.6.2 issue. I am disappointed with this issue and has tempted me to find another usable program. I hope someone will restore my confidence in what I thought was a great application.

Any help is greatly appreciated.

David Jean
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 16th, 2009, 7:16 am

Hi David,

Don't use Disc Cover 1.5 with Snow Leopard. Try to reinstall Disc Cover 2. Before this, delete all its parts:
- The Disc Cover application from the Applications folder.
- Disc Cover folder from "~/Library/Application Support/BeLight Software/".
- The "com.belightsoft.DiscCover2.plist" file from the "~/Library/Preferences/" folder.

What did you with the computer when Disc Cover stopped working? Maybe updated the operating system or Disc Cover?

Nick
DJproduction
New member
Posts: 5
Joined: December 15th, 2009, 1:43 pm

Postby DJproduction » December 19th, 2009, 12:29 pm

Nick, thanks for your help. I've deleted Disc Cover 1.5 and 2.3.2 per your instructions. However, I am not locating "~/Library/Application Support/BeLight Software/" or "com.belightsoft.DiscCover2.plist" on my computer. Could this be my problem?

I've reinstalled Disc Cover 2 (v. 2.3.2) and I am still encountering the same issue as before. Please see open the following to see my issue. All of the graphics I drag/drop onto my design are surrounded by a black box as if they are highlighted. FYI, it prints they exact way you see it here. Any suggestions on a possible fix?

Click the following link:
http://picasaweb.google.com/dcjean/DiscCover2V232Issue?feat=directlink

Thanks for your help.

David Jean

****
Hi David,

Don't use Disc Cover 1.5 with Snow Leopard. Try to reinstall Disc Cover 2. Before this, delete all its parts:
- The Disc Cover application from the Applications folder.
- Disc Cover folder from "~/Library/Application Support/BeLight Software/".
- The "com.belightsoft.DiscCover2.plist" file from the "~/Library/Preferences/" folder.

What did you with the computer when Disc Cover stopped working? Maybe updated the operating system or Disc Cover?

Nick
Nick
Member
Posts: 7241
Joined: July 6th, 2006, 3:13 am
Location: Odessa, Ukraine
Contact:

Postby Nick » December 21st, 2009, 7:02 am

Hi David,

However, I am not locating "~/Library/Application Support/BeLight Software/" or "com.belightsoft.DiscCover2.plist" on my computer. Could this be my problem?

Absence of these folder and file is possible. The "com.belightsoft.DiscCover2.plist" file is created after the first run of the program. Since you used the program before, I expected that it could exist.

A similar problem was with one of previous versions in a new version of Mac OS. We have fixed it.

To ensure that you have installed the latest version, please check the version number in Disc Cover > About Disc Cover.

Also, open your design to repeat the problem. Then save your console log. Maybe it contains error messages that may help us. To save the console log, open the Console application from the Applications/Utilities folder. Choose File > Open Console Log. Then choose File > Save a Copy As in the menu of Console to save the log.

Nick
kwindrem
New member
Posts: 2
Joined: October 16th, 2009, 7:23 pm

Postby kwindrem » December 21st, 2009, 11:25 pm

Nick wrote:Hi,

If it's possible, we'll fix this annoying delay in the next update.

Nick

Add me to those having problems with delays in printing direct to disc from Disc Cover 2.3.2.

I just migrated to an iMac dual core running Mac OS 10.6.2 and the new HP drivers supplied via an Apple update. I have a HP D5360 that prints directly to CDs. System prefs lists the driver version as 4.0.2. I also have an HP C6180. Its driver version is 3.0.3.

It seems that printing to "Paper" works fine, but if you select "Direct to CD/DVD" I get a delay of 30-40 seconds. This even happens on the C6180. (Even though it can't print directly to CD, you can select that combination.) During this period one of the processors is pegged at 100% utilization.

Those people reporting problems all seem to be using the new Apple-supplied print drivers, HP and Epson.


I've also been having another problem printing direct to CD/DVD on the D5360. I'll do all the setup in both print dialogs, but the printer will instruct me to lift the CD/DVD tray so I can print to plain paper. I need to cancel, print again and reselect all the options. It usually works but I often need to go through the print process several times.
NeoX
New member
Posts: 3
Joined: January 8th, 2010, 6:28 pm

Postby NeoX » January 8th, 2010, 7:05 pm

DJproduction wrote:Nick, thanks for your help. I've deleted Disc Cover 1.5 and 2.3.2 per your instructions. However, I am not locating "~/Library/Application Support/BeLight Software/" or "com.belightsoft.DiscCover2.plist" on my computer. Could this be my problem?

I've reinstalled Disc Cover 2 (v. 2.3.2) and I am still encountering the same issue as before. Please see open the following to see my issue. All of the graphics I drag/drop onto my design are surrounded by a black box as if they are highlighted. FYI, it prints they exact way you see it here. Any suggestions on a possible fix?

Click the following link:
http://picasaweb.google.com/dcjean/DiscCover2V232Issue?feat=directlink

I have the same problem. It seems that any image that has transperancy instead has a black background making it impossible to use most of the clip art. I have 2.2.1 that came with toast 9. It seems that even though we have a 2.x version we are second class citizens and don't get the latest version. That's a shame really as I only make a few discs here and there and can't justify paying for an update. It is odd as Roxio considers toast 9, with the latest update to be 10.6 compat. But Disc Cover is not as it is buggy and crashes a lot. So how about allowing Toast 9 users to update to the latest version, same as toast 10 users? I mean we are not talking major version here, we are talking minor.

Return to “Disc Cover”

Who is online

Users browsing this forum: No registered users and 3 guests